Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Muticast MOH not working for IP Phones in Branch Router

Hi,

Branch Router is able Multicast MOH with PSTN phones but not working between IP Phones. I am enclosing the config below which I have at the brach location.

ip multicast-routing

int vlan 300

description voice vlan

ip pim dense-mode

call-manager fallback-mgcp

ccm-manager musin-on-hold

call-manager-fallback

ip source-address 192.168.10.1 port 2000

max-ephone 20

max-dn 40 dual-line

moh music-on-hold.au

multicast moh 239.1.1.1 port 16384 Loopbak IP and then VLAN IP

Regards,

Amritesh Anand

3 REPLIES
VIP Super Bronze

Re: Muticast MOH not working for IP Phones in Branch Router

Hi,

This is how I have gotten Multicast MOh to work

Router

1. Configure  ip pim sparse-dense-mode on all interfaces that connects to the switch including loopback interface

2. configure multicast routing to all interfaces that will route multicast traffic.

3. makesure the interface that connects to remote WAN has ip pim sparse-dense-mode configured.

Switch

1.Configure  ip multicast-routing distributed on all switches (where phones are connected or swicthes in this path)

2. configure ip pim sparse-dense-mode on all interfaces that connect to router to

finally to test, when IP phones are on hold, use ? on the phone see if they are receiving packets

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
Community Member

Re: Muticast MOH not working for IP Phones in Branch Router

HI,

I have the different scenariow. Where as I have CUCM in HQ and two Branches and it centralized deployement, all my IP Phones are registered to CUCM. I want my branch routers to do the MOH from the Branch Router Flash but it is only giving me the moh for the PSTN caller. When an IP Phones calls it is silent. No music is there. Which definately means that it is not taking from CUCM but also not from the router flash.

Regards,

Amritesh Anand.

Bronze

Re: Muticast MOH not working for IP Phones in Branch Router

First of all check that all phones are using the same network and user hold audio.Then check what ip address that it is configured for.

For example if the Mulitcast MOH  in callmanager is set for 239.1.1.1 is that the same as the Multicast MOH ip address  on the branch gateway?

Regards

Mark

1416
Views
0
Helpful
3
Replies
CreatePlease to create content