Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

MVA, SNR not working

I`ve configured MVA as below

PABX, PSTN >>>>H323G>>>>>>>>>>>>CUCM7.0

I  have it woring using the Mobile Connect with RDP all wokring - dial in via the PABX to an IPT handset1 on CUCM 7.0 the call then rings the IPT device and then rings my RDP. I`ve now set it to use MVA, I dial in via the PABX , enter a User ID and PIN then press 1 as the CLI of the incoming  call does not match the RDP CLI . I then dial the number but CUCM states " call can not be completed as dialled" as if it is  CSS issue. I can dial from the IPT handset the device I wanted to call via the MVA.  I checked the CSS in the RDP and everything looks ok

The Inbound CSS of the CSS  contains the same Partitions as the MVA  resource, the CSS (not re-route CSS ) of the RDP is the same as the IPT Handset, as it is a test cucm everything is on a single Partition

also tested with a call via the RDP device so only teh PIN is required- same result

Any ideas


New Member

Re: MVA, SNR not working

Pls check the " calling search space" on the RDP. THis is the CSS that is responsible for letting you call via MVA.



Re: MVA, SNR not working


Checked that , as you siad there are two  CSS`s  in RDP - CSS is for the mobile access, SNR  , and the re-CSS is for the mobile voice access 2 Staged dialling. I`ve also created a new RE-CSS as someone as suggested but again I still get the "call can not be completed....."

New Member

Re: MVA, SNR not working

The number that you have configured on the service paramater for "Mobile voice access" and also for the Mobile Voice number, pls make sure that you have dialpeer configured on the gateway to reach that number.

I mean if u have 4 digits configured for MOVA number and u have dial-peer for 10 digit or vice versa, that will make the call fail.

Also just wanted tpo check again that u have the partition of the called phone in the css - " Calling search space" in RDP and not rerouting css.

If still it is not working, can you send me the follwoing for the failed call:

following debugs from the gateway

debug voip application vxml all

debug voip ccapi inout

debug isdn q931

detailed call manager traces for the bad call

time of call


called number

MVA number as mentioned in the configuration

sh running configuration



Re: MVA, SNR not working

Hi, I will send you the traces - tomorow?

To recap

Created a VOIP dial peer for DDI calls to IPT phones and create a specific dial-peer for the service ccm application

Dial-peer voice yyyy pots

serice ccm

direct dial inward

answer incoming xxxxxx - DDI for the MVA service

Dial-peer voice xxxx voip

destination-pattern 5551234 (MVA DN)

session target ipv4:xxxxx

Dial-peer voice zzzz voip

destination-pattern 555..... ( ddi numbers)

session target ipv4:xxxxxx

Phone 1 which the RDP is set up another device via ICT trunks . Call to Phone 1 from another handset and it rings and then affer x sec phones another phone to  provide SNR is all working. I repeat the above suing an external device - makes use of Dial-peer ZZZZ voip again SNR works. Repeat the  test for MVA -call into the MVA number  via a DDI number on the H323GW( dial-peer voice xxxx)  the caller hears the the prompts and enters the PIN and press 1 to make the call to phone 2- at this point I get the "Call can not be completed"

Also  Phone 1 can call phone 2 ok

Put everything in the same Partions, CSS fails, created new CSS for the RDP fails


Once the call has been answered on the GW and the MVA answers the call - does the GW play any part in the call

Also is it only the Re-CSS whi cdetermines whether the MVA Caller can make the call and to where?

New Member

Re: MVA, SNR not working


  When call hits the incoming dial-peer ( yyyy in ur case), it invokes the MVA service. Now MVA prompts are played and MVA service picks the MVA DN that you configures in the call manager from there and searches for outgoing voip dial-peer acc. to that MVA DN.

To your second question, rerouting CSS on the RDP is not used for MVA. Its used for SNR ( i.e for outbound call to call the remote destination). " Calling search space" option on the RDP page decides where the calling party has access to call when calling in during MVA.



Re: MVA, SNR not working

Sorry I got mixed up , the re-css as you said is used for the SNR part and the CSS is used for MVA. So am I correct in that if the caller hears the MVA prompts then the CSS, voip dial-peer and even the Inbound CSS for Remote Destination in the Service Parameter are all set up correctly and the only thing stopping or effecting the call is the CSS on the RDP- it is this which determines which partitions, route patterns the user after pressing 1 and dialing a number can route to ?.

New Member

Re: MVA, SNR not working


New Member

MVA, SNR not working


Did you get it working? I've same issue.

Thanks in advance,


New Member

MVA, SNR not working

Hi, did you solve this?

I've the same problem.

Fernando Vazquez

New Member

MVA, SNR not working

Hey guys,

I don't know if you figured this out yet or not but the service needs to be applied to the incoming POTS dial-peer and not the outgoing VOIP dial-peer.

Hope this helps.

CreatePlease to create content