Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

mwi indicator on wrong dn/line with CUE/CUCME

Hi,

my CUE/CUCME MWI integration does not work as expected.

After recording a voicemail the CUE system sends an SIP MWI NOTIFY to the CUCME and the red envelope symbol gets activated on the wrong line number (in my case dn 1 instead of dn 2) - phone is 9971. Resetting the CUE and configuring it form scratch didn't help.

Somehow the whole 9971 integration seams a little bit unstable (call transfer does not work - no idea if there is anything in parallel).

Configuration and debug is attached

Thanks for any ideas.

Regards, Frank

******************Configuration*************************

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

boot-start-marker

boot-end-marker

!

!

no logging buffered

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

!

!

!

!

!

aaa session-id common

network-clock-participate wic 1

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

!

ip dhcp relay information trust-all

ip dhcp excluded-address 10.10.10.1 10.10.10.10

!

ip dhcp pool phone

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 217.0.43.97 217.0.43.113

option 150 ip 10.10.10.1

!

!

ip name-server 217.0.43.97

ip cef

no ipv6 cef

!

multilink bundle-name authenticated

!

!

voice rtp send-recv

!

voice service voip

no ip address trusted authenticate

callmonitor

no callmonitor trace

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip handle-replaces

sip

  registrar server expires max 3600 min 180

  asymmetric payload full

  video screening

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g711ulaw

codec preference 3 g723r53

codec preference 4 g729r8

codec preference 5 g729br8

codec preference 6 g726r32

codec preference 7 g728

!

!

voice register global

mode cme

source-address 10.10.10.1 port 5060

max-dn 10

max-pool 4

load 9971 sip9971.9-4-1-9

load ATA-187 ATA187.9-2-3-1

authenticate register

authenticate realm all

timezone 21

time-format 24

date-format D/M/Y

voicemail 999

tftp-path flash:

file text

create profile sync 0000420080667255

network-locale DE

user-locale DE

camera

video

overlap-signal

!

voice register dn  1

number 91

allow watch

no-reg

mwi

!

voice register dn  2

number 90

call-forward b2bua noan 999 timeout 20

allow watch

no-reg

mwi

voice register pool  1

registration-timer max 300 min 60

id mac 0008.3030.6AAA

feature-button 5 DnD

session-transport tcp

type 9971

number 1 dn 1

number 2 dn 2

dtmf-relay rtp-nte

voice-class codec 1

no vad

camera

video

!

!

!

!

no ip ftp passive

!

!

!

interface FastEthernet0/0

description ***ISP Provider***

ip address dhcp

no ip proxy-arp

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface Integrated-Service-Engine0/0

ip unnumbered Vlan1

ip nat inside

ip virtual-reassembly in

service-module ip address 10.10.10.2 255.255.255.0

service-module ip default-gateway 10.10.10.1

!

interface Vlan1

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

ip forward-protocol nd

ip http server

ip http authentication aaa

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip http path flash:

!

!

ip nat inside source list 1 interface FastEthernet0/0 overload

ip route 0.0.0.0 0.0.0.0 87.186.225.92 254

ip route 10.10.10.2 255.255.255.255 Integrated-Service-Engine0/0

access-list 1 permit 10.10.10.0 0.0.0.255

!

!

control-plane

!

!

!

mgcp profile default

!

!

dial-peer voice 20 voip

description **Mailbox**

destination-pattern 99.

session protocol sipv2

session target ipv4:10.10.10.2

voice-class codec 1 

dtmf-relay rtp-nte

no vad

!

!

presence

presence call-list

!

sip-ua

credentials username ***number*** password ***password*** realm **realm**

authentication username ***user*** password ***password*** realm ***realm**

nat symmetric role active

nat symmetric check-media-src

no remote-party-id

retry invite 4

retry response 3

retry bye 2

retry cancel 2

retry notify 6

retry register 5

retry options 10

timers connect 100

timers notify 100

timers register 250

mwi-server ipv4:10.10.10.2 expires 3600 port 5060 transport udp

registrar 1 dns:**registrar** expires 3600

sip-server dns:**registrar**

connection-reuse

host-registrar

presence enable

!

!

!

telephony-service

no auto-reg-ephone

max-ephones 12

max-dn 30

ip source-address 10.10.10.1 port 2000

max-redirect 5

timeouts interdigit 2

url services http://10.10.10.2/voiceview/common/login.do

cnf-file location flash:

user-locale U1 load CME-locale-de_DE-German-8.8.2.5.tar

load 7925 CP7925G-1.4.4.3.LOADS

time-zone 23

time-format 24

date-format dd-mm-yy

voicemail 999

max-conferences 4 gain -6

dn-webedit

time-webedit

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

!

line con 0

no modem enable

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

line vty 0 4

access-class 102 in

privilege level 15

transport input all

transport output all

line vty 5 15

access-class 101 in

exec-timeout 30 0

privilege level 15

transport input all

transport output all

!

!

end

********************************** debug ccsip messages **************************************

NOTIFY sip:90@10.10.10.1:5060 SIP/2.0

Via: SIP/2.0/UDP 10.10.10.2:5060;branch=z9hG4bKSLiy2tv6m.ZgKxUe8Y2eLQ~~144

Max-Forwards: 70

To: <sip:90@10.10.10.1>;tag=A7BEBF8-B74

From: <sip:90@10.10.10.2>;tag=daf14882-1160

Call-ID: BDAE6318-4BB311E3-8B318DCC-E4968F82@10.10.10.1

CSeq: 5 NOTIFY

Content-Length: 109

Contact: sip:90@10.10.10.2

Event: message-summary

Allow-Events: refer

Allow-Events: message-summary

Allow-Events: telephone-event

Subscription-State: active

Content-Type: application/simple-message-summary

Messages-Waiting: yes

Message-Account: sip:90@10.10.10.2

Voice-Message: 1/0 (0/0)

Fax-Message: 0/0 (0/0)

*Nov 13 18:08:29.743: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 10.10.10.2:5060;branch=z9hG4bKSLiy2tv6m.ZgKxUe8Y2eLQ~~144

From: <sip:90@10.10.10.2>;tag=daf14882-1160

To: <sip:90@10.10.10.1>;tag=A7BEBF8-B74

Date: Wed, 13 Nov 2013 18:08:29 GMT

Call-ID: BDAE6318-4BB311E3-8B318DCC-E4968F82@10.10.10.1

CSeq: 5 NOTIFY

Content-Length: 0

*Nov 13 18:08:29.747: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

NOTIFY sip:90@10.10.10.12:52895;transport=tcp SIP/2.0

Via: SIP/2.0/TCP 10.10.10.1:5060;branch=z9hG4bK250B21A8

From: <sip:90@10.10.10.1>;tag=AEFE09C-119E

To: <sip:90@10.10.10.12>

Call-ID: 6F329427-4BC511E3-8C258DCC-E4968F82@10.10.10.1

CSeq: 101 NOTIFY

Max-Forwards: 70

Date: Wed, 13 Nov 2013 18:08:29 GMT

User-Agent: Cisco-SIPGateway/IOS-15.2.4.M5

Event: message-summary

Subscription-State: active

Contact: <sip:90@10.10.10.1:5060;transport=tcp>

Content-Type: application/simple-message-summary

Content-Length: 23

Messages-Waiting: yes

*Nov 13 18:08:29.751: //0/000000000000/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 200 OK

Via: SIP/2.0/TCP 10.10.10.1:5060;branch=z9hG4bK250B21A8

From: <sip:90@10.10.10.1>;tag=AEFE09C-119E

To: <sip:90@10.10.10.12>

Call-ID: 6F329427-4BC511E3-8C258DCC-E4968F82@10.10.10.1

Date: Wed, 13 Nov 2013 18:08:31 GMT

CSeq: 101 NOTIFY

Content-Length: 0

152
Views
0
Helpful
0
Replies
CreatePlease to create content