Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

MWI not lighting on CME phones

Hello guys, we recently took over a phone system and it has the following problem.  When someone calls in and leaves a voicemail message the message waiting light does not appear or does not who the envelope.  Any ideas on what is missing from this configuration to enable the light

Thanks

--------------------------------------------------------------------------------------------------

! Last configuration change at 17:45:23 Central Wed Feb 5 2014

! NVRAM config last updated at 17:47:13 Central Wed Feb 5 2014

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname PBX_System

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

memory-size iomem 20

clock timezone Central -6 0

clock summer-time DST recurring

ip source-route

!

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.20.1 192.168.20.19

!

ip dhcp pool voip_dhcp

   network 192.168.20.0 255.255.255.0

   dns-server 75.75.75.75 75.75.76.76

   option 150 ip 192.168.20.1

   default-router 192.168.20.1

!

!

ip cef

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

trunk group main

!!

!

!

!

!

voice-card 0

!

!

!

license udi pid CISCO2801 sn FTX1111Z17K

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.20.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface Service-Engine0/1

ip unnumbered FastEthernet0/0

service-module ip address 192.168.20.5 255.255.255.0

service-module ip default-gateway 192.168.20.1

!

interface FastEthernet0/1

ip address X.X.X.X 255.255.255.224

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

ip forward-protocol nd

!

!

ip http server

ip http authentication local

ip http path flash:

ip nat inside source list 1 interface FastEthernet0/1 overload

ip route 0.0.0.0 0.0.0.0 X.X.X.X

ip route 192.168.20.5 255.255.255.255 Service-Engine0/1

!

logging esm config

access-list 1 permit 192.168.20.0 0.0.0.255

!

!

tftp-server flash:S00105000400.sbn

tftp-server flash:P00308000800.loads

tftp-server flash:P00308000800.sb2

tftp-server flash:P00308000800.sbn

tftp-server flash:P00308000800.txt

tftp-server flash:OS79XX.TXT

tftp-server flash:cnu70.63-0-1-4.sbn

tftp-server flash:Jar70.63-0-1-4.sbn

tftp-server flash:jvm70.603ES1R4.sbn

tftp-server flash:term70.default.loads

!

control-plane

!

!

!

!

voice-port 0/0/0

trunk-group main 3

timeouts call-disconnect 2

timeouts ringing infinity

timeouts wait-release 5

connection plar 1051

description PSTN XXX-xXX-5353

caller-id enable

!

voice-port 0/0/1

trunk-group main 2

timeouts call-disconnect 2

timeouts ringing infinity

timeouts wait-release 5

connection plar 1052

description PSTN XXX-XXX-5354

caller-id enable

!

voice-port 0/0/2

trunk-group main 1

timeouts call-disconnect 2

timeouts ringing infinity

timeouts wait-release 5

connection plar 1053

description PSTN XXX-XXX-5355

caller-id enable

!

!

!

dial-peer voice 1 pots

trunkgroup main

destination-pattern 412.......

no digit-strip

!

dial-peer voice 200 voip

destination-pattern 2...

b2bua

session protocol sipv2

session target ipv4:192.168.20.5

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 2 pots

trunkgroup main

destination-pattern 1..........

no digit-strip

!

!!

gatekeeper

shutdown

!

!

telephony-service

max-ephones 30

max-dn 32

ip source-address 192.168.20.1 port 2000

system message My Business

cnf-file location flash:

load 7914 S00105000100

load 7960-7940 P00308000800

load 7970 TERM70.6-0-3SR1S

time-zone 8

voicemail 2000

max-conferences 8 gain -6

moh music-on-hold.au

multicast moh 239.2.2.2 port 2000

web admin system name xxxx password xxxxxxx

dn-webedit

time-webedit

transfer-system full-consult

create cnf-files version-stamp 7960 Feb 05 2014 17:42:45

!

!

ephone-dn  1

number 1001

label Room 1

description Room 1

name Room 1

call-forward busy 2000

call-forward noan 2000 timeout 10

!

!

ephone-dn  2

number 1002

label Room 2

description Room 2

name Room 2

call-forward busy 2000

call-forward noan 2000 timeout 10

!

!

ephone-dn  3

number 1003

label Room 3

description Room 3

name Room 3

call-forward busy 2000

call-forward noan 2000 timeout 10

!

!

ephone-dn  4

number 1004

label Room 4

description Room 4

name Room 4

call-forward busy 2000

call-forward noan 2000 timeout 10

!

!

ephone-dn  5

number 1010

label Recep

description Recep

name Recep

call-forward busy 2000

call-forward noan 2000 timeout 10

!

!

ephone-dn  25

number 1051

label Main Line

description Main Line

name Main Line

call-forward noan 2000 timeout 10

!

!

ephone-dn  26

number 1052

label Line 2

description Line 2

name Line 2

!

!

ephone-dn  27

number 1053

label Line 3

description Line 3

name Line 3

!

!

ephone-dn  30

number 6000

label Paging

description Paging

name Paging

paging ip 239.1.1.10 port 2000

!

!

ephone-dn  31

number 8000....

mwi on

!

!

ephone-dn  32

number 8001....

mwi off

!

!

ephone  1

mac-address 0015.F9ED.3CDC

button  1:1

!

!

!

ephone  2

mac-address 001A.2FE7.7CFA

button  1:2

!

!

!

ephone  3

mac-address 001A.2FE7.79F6

button  1:3

!

!

!

ephone  4

mac-address 000F.3412.8D42

button  1:4

!

!

!

ephone  5

mac-address 0015.6389.B6FF

type 7960

button  1:5 3:25 4:26 5:27

!

!

!

line con 0

line aux 0

line 130

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120

line vty 0 4

login local

transport input telnet

!

scheduler allocate 20000 1000

ntp peer 192.168.20.1

ntp server 216.228.192.69

end

Everyone's tags (4)
3 REPLIES

MWI not lighting on CME phones

Add this..

dial-peer voice XXXX voip

description MWI

incoming called-number 800[0,1]....

codec g711ulaw

no vad

Check MWI status by "show ccn application"

Here is the useful link for MWI troubleshooting...

http://www.cisco.com/c/en/us/support/docs/voice-unified-communications/unity-express/60081-unity-mwi-problems.html

Rate useful post.

Thanks

Manish

MWI not lighting on CME phones

Hi,

Try below command and check it it works:-

IN CME:-

sip-ua

mwi server ipv4:192.168.20.5 unsolicited

In CUE:-

ccn subsytem sip

nwi sip unsolicited

Regards,
Nishant Savalia

Regards, Nishant Savalia
Cisco Employee

MWI not lighting on CME phones

Hi Pirinoe,

There are three ways in which we can configure MWI.

Please find the configuration that needs to be done on CME and CUE for each method.

  1. Outcalling

  • CUCME:

dial-peer voice 100 voip

destination-pattern1000

session protocol sipv2

session target ipv4:10.10.10.10

incoming called-number 399[89]….

dtmf-relay sip-notify

codec g711ulaw

no vad

!

ephone-dn  1

number 3998…. no-reg primary

mwi off

!

ephone-dn  2

number 3999…. no-reg primary

mwi on

  • CUE:

ccn application ciscomwiapplication aa

parameter "strMWI_OFF_DN" "3998"

parameter "strMWI_ON_DN" "3999"

end application

2.SIP Subscribe Notify

CUCME:

sip-ua

mwi-server 10.10.10.10

!

ephone-dn 1

number 1001 no-reg

mwi sip

CUE:

ccn subsystem sip

gateway address "10.10.10.11"

mwi envelope-info

mwi sip outcall sub-notify

end subsystem

3.SIP Unsolicited Notify

CUCME:

sip-ua

mwi-server 10.10.10.10 unsolicited

CUE:

ccn subsystem sip

gateway address "10.10.10.11"

sip unsolicited

end subsystem

For more information, you can refer to following link as well.

https://supportforums.cisco.com/docs/DOC-1285

I would recommend using SIP unsolicited Notify.

Once the above configuration is done, go to the GUI of CUE and refresh all the mailboxes associated and make the test call.

Thanks & Regards,
Mudit Mathur

Thanks & Regards, Mudit Mathur
2404
Views
10
Helpful
3
Replies
CreatePlease to create content