Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

National Call gets Disconnect Cause=34

Hello partners,

 

I will explain the situation:

 

- The called number is 002812677847 and the dial-peer 4 strip the fisrt 0

- Only with national call the router receive Disconnect Cause=34, with other calls the function is OK, in the following extract of the debug voice ccapi inout you will see the Disconnect Cause=34:

 

004762: May 14 17:14:58.933 CCS: //-1/80EE2CFD960B/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=Spider Conferencias OP/TEC P5
   ----- ccCallInfo IE subfields -----
   cisco-ani=2127717500
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=1
   dest=002812677847
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-lastrdn=
   cisco-rdntype=-1
   cisco-rdnplan=-1
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

004763: May 14 17:14:58.933 CCS: //-1/80EE2CFD960B/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x296B83DC, Call Info(
   Calling Number=2127717500,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),
   Called Number=002812677847(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,
   Incoming Dial-peer=100, Progress Indication=NULL(0), Calling IE Present=TRUE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=8607
004764: May 14 17:14:58.933 CCS: //-1/80EE2CFD960B/CCAPI/ccCheckClipClir:
   In: Calling Number=2127717500(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)
004765: May 14 17:14:58.933 CCS: //-1/80EE2CFD960B/CCAPI/ccCheckClipClir:
   Out: Calling Number=2127717500(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)
004766: May 14 17:14:58.937 CCS: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
004767: May 14 17:14:58.937 CCS: :cc_get_feature_vsa malloc success
004768: May 14 17:14:58.937 CCS: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
004769: May 14 17:14:58.937 CCS:  cc_get_feature_vsa count is 1
004770: May 14 17:14:58.937 CCS: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
004771: May 14 17:14:58.937 CCS: :FEATURE_VSA attributes are: feature_name:0,feature_time:709733944,feature_id:8607
004772: May 14 17:14:58.937 CCS: //8607/80EE2CFD960B/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=2127717500(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),
   Called Number=002812677847(TON=Unknown, NPI=Unknown))
004773: May 14 17:14:58.937 CCS: //8607/80EE2CFD960B/CCAPI/cc_process_call_setup_ind:
   Event=0x31695A00
004774: May 14 17:14:58.937 CCS: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:
   Try with the demoted called number 002812677847
004775: May 14 17:14:58.937 CCS: //8607/80EE2CFD960B/CCAPI/ccCallSetContext:
   Context=0x2A4DDA9C
004776: May 14 17:14:58.937 CCS: //8607/80EE2CFD960B/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 8607 with tag 100 to app "_ManagedAppProcess_Default"
004777: May 14 17:14:58.937 CCS: //8607/80EE2CFD960B/CCAPI/ccCallProceeding:
   Progress Indication=NULL(0)
004778: May 14 17:14:58.937 CCS: //8607/80EE2CFD960B/CCAPI/ccCallSetupRequest:
   Destination=, Calling IE Present=TRUE, Mode=0,
   Outgoing Dial-peer=4, Params=0x2A4DC7E4, Progress Indication=NULL(0)
004779: May 14 17:14:58.937 CCS: //8607/80EE2CFD960B/CCAPI/ccCheckClipClir:
   In: Calling Number=2127717500(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)
004780: May 14 17:14:58.937 CCS: //8607/80EE2CFD960B/CCAPI/ccCheckClipClir:
   Out: Calling Number=2127717500(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)
004781: May 14 17:14:58.937 CCS: //8607/80EE2CFD960B/CCAPI/ccCallSetupRequest:
   Destination Pattern=002........., Called Number=002812677847, Digit Strip=TRUE
004782: May 14 17:14:58.937 CCS: //8607/80EE2CFD960B/CCAPI/ccCallSetupRequest:
   Calling Number=2127717500(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),
   Called Number=002812677847(TON=Unknown, NPI=Unknown),
   Redirect Number=, Display Info=
   Account Number=Spider Conferencias OP/TEC P5, Final Destination Flag=TRUE,
   Guid=80EE2CFD-DAE3-3137-960B-84010AE39C03, Outgoing Dial-peer=4
004783: May 14 17:14:58.937 CCS: //8607/80EE2CFD960B/CCAPI/cc_api_display_ie_subfields:
   ccCallSetupRequest:
   cisco-username=Spider Conferencias OP/TEC P5
   ----- ccCallInfo IE subfields -----
   cisco-ani=2127717500
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=1
   dest=002812677847
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-lastrdn=
   cisco-rdntype=-1
   cisco-rdnplan=-1
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

004784: May 14 17:14:58.937 CCS: //8607/80EE2CFD960B/CCAPI/ccIFCallSetupRequestPrivate:
   Interface=0x29CE4410, Interface Type=6, Destination=, Mode=0x0,
   Call Params(Calling Number=2127717500,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),
   Called Number=002812677847(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,
   Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE, Outgoing Dial-peer=4, Call Count On=FALSE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)
004785: May 14 17:14:58.937 CCS: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
004786: May 14 17:14:58.937 CCS: :cc_get_feature_vsa malloc success
004787: May 14 17:14:58.937 CCS: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
004788: May 14 17:14:58.937 CCS:  cc_get_feature_vsa count is 2
004789: May 14 17:14:58.937 CCS: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
004790: May 14 17:14:58.937 CCS: :FEATURE_VSA attributes are: feature_name:0,feature_time:709733720,feature_id:8608
004791: May 14 17:14:58.937 CCS: //8608/80EE2CFD960B/CCAPI/ccIFCallSetupRequestPrivate:
   SPI Call Setup Request Is Success; Interface Type=6, FlowMode=1
004792: May 14 17:14:58.937 CCS: //8608/80EE2CFD960B/CCAPI/ccCallSetContext:
   Context=0x2A4DC794
004793: May 14 17:14:58.937 CCS: //8607/80EE2CFD960B/CCAPI/ccSaveDialpeerTag:
   
VZAMRVOIP2#Outgoing Dial-peer=4
VZAMRVOIP2#
004794: May 14 17:15:02.033 CCS: //8608/80EE2CFD960B/CCAPI/cc_api_call_proceeding:
   Interface=0x29CE4410, Progress Indication=NULL(0)
004795: May 14 17:15:03.689 CCS: //8608/80EE2CFD960B/CCAPI/cc_api_call_disconnected:
   Cause Value=34, Interface=0x29CE4410, Call Id=8608
004796: May 14 17:15:03.689 CCS: //8608/80EE2CFD960B/CCAPI/cc_api_call_disconnected:
   Call Entry(Responsed=TRUE, Cause Value=34, Retry Count=0)
004797: May 14 17:15:03.689 CCS: //8607/xxxxxxxxxxxx/CCAPI/ccCallReleaseResources:
   release reserved xcoding resource.
004798: May 14 17:15:03.689 CCS: //8608/80EE2CFD960B/CCAPI/ccCallSetAAA_Accounting:
   Accounting=0, Call Id=8608
004799: May 14 17:15:03.689 CCS: //8608/80EE2CFD960B/CCAPI/ccCallDisconnect:
   Cause Value=34, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=34)
004800: May 14 17:15:03.689 CCS: //8608/80EE2CFD960B/CCAPI/ccCallDisconnect:
   Cause Value=34, Call Entry(Responsed=TRUE, Cause Value=34)
004801: May 14 17:15:03.741 CCS: //8608/80EE2CFD960B/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x29CE4410, Tag=0x0, Call Id=8608,
   Call Entry(Disconnect Cause=34, Voice Class Cause Code=0, Retry Count=0)
004802: May 14 17:15:03.741 CCS: //8608/80EE2CFD960B/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
004803: May 14 17:15:03.741 CCS: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
004804: May 14 17:15:03.741 CCS: :cc_free_feature_vsa freeing 2A4DAD50
004805: May 14 17:15:03.741 CCS: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
004806: May 14 17:15:03.741 CCS:  vsacount in free is 1
004807: May 14 17:15:03.741 CCS: //8607/80EE2CFD960B/CCAPI/ccCallDisconnect:
   Cause Value=34, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
004808: May 14 17:15:03.741 CCS: //8607/80EE2CFD960B/CCAPI/ccCallDisconnect:
   Cause Value=34, Call Entry(Responsed=TRUE, Cause Value=34)
004809: May 14 17:15:03.741 CCS: //8607/80EE2CFD960B/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
VZAMRVOIP2#
004810: May 14 17:15:03.741 CCS: //8607/80EE2CFD960B/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x296B83DC, Tag=0x0, Call Id=8607,
   Call Entry(Disconnect Cause=34, Voice Class Cause Code=0, Retry Count=0)
004811: May 14 17:15:03.741 CCS: //8607/80EE2CFD960B/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
004812: May 14 17:15:03.741 CCS: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
004813: May 14 17:15:03.741 CCS: :cc_free_feature_vsa freeing 2A4DAE30
004814: May 14 17:15:03.741 CCS: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
004815: May 14 17:15:03.741 CCS:  vsacount in free is 0

 

Here is the router config:

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service tcp-small-servers

service sequence-numbers

service counters max age 5

!

hostname VZAMRVOIP1

!

boot-start-marker

boot system flash c2900-universalk9-mz.SPA.152-1.GC1.bin

boot-end-marker

!

!

card type e1 0 0

security authentication failure rate 10 log

security passwords min-length 6

logging buffered informational

logging console informational

enable secret 5 $1$Uq.Q$H.NWgH0a1DDlZG4pmcrkC.

!

aaa new-model

!

!

aaa authentication login AUTH-VTY group tacacs+ local

aaa authentication login AUTH-CON local-case

aaa authorization exec AUTH-VTY if-authenticated

aaa authorization commands 1 AUTH-VTY if-authenticated

aaa authorization commands 15 AUTH-VTY local group tacacs+

aaa accounting update newinfo

aaa accounting exec AUTH-VTY start-stop group tacacs+

aaa accounting commands 1 AUTH-VTY stop-only group tacacs+

aaa accounting commands 15 AUTH-VTY stop-only group tacacs+

aaa accounting connection AUTH-VTY stop-only group tacacs+

!

!

!

!

!

aaa session-id common

clock timezone CCS -4 30

network-clock-participate wic 0

network-clock-select 1 E1 0/0/0

!

no ipv6 cef

no ip source-route

no ip gratuitous-arps

!

!

!

!        

!

no ip bootp server

no ip domain lookup

ip domain name bes.gbes

ip cef

login on-failure log

login on-success log

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

crypto pki token default removal timeout 0

!

!

voice-card 0

!

!

voice call disc-pi-off

no voice call carrier capacity active

!

voice service voip

 h323

  no h225 timeout keepalive

  call preserve limit-media-detection

!

voice class codec 100

 codec preference 1 g711alaw

 codec preference 2 g711ulaw

 codec preference 3 g729r8

!

!

!

!

voice translation-rule 1

 rule 1 /^75/ /11/

 rule 2 /^76/ /12/

 rule 3 /7700/ /004146210261/

!

!

voice translation-profile INCOMING

 translate called 1

!

!

!

license udi pid CISCO2911/K9 sn FTX1522AM0J

license accept end user agreement

hw-module pvdm 0/0

!

!

!

archive

 log config

  logging enable

  logging size 1000

  notify syslog contenttype plaintext

  hidekeys

 path flash0:/LOGS_CONFIG

 write-memory

!

redundancy

!

!

controller E1 0/0/0

 framing NO-CRC4

 line-termination 75-ohm

 pri-group timeslots 1-31

!

!

interface Embedded-Service-Engine0/0

 no ip address

 shutdown

!

interface GigabitEthernet0/0

 ip address 192.168.159.141 255.255.255.240

 duplex auto

 speed auto

!

interface GigabitEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed 1000

!

interface GigabitEthernet0/2

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial0/0/0:15

 no ip address

 encapsulation hdlc

 isdn switch-type primary-net5

 isdn timer T310 120000

 isdn incoming-voice modem 64

 no cdp enable

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 192.158.159.129

ip tacacs source-interface GigabitEthernet0/0

!

logging origin-id hostname

logging facility local0

logging source-interface GigabitEthernet0/0

logging 10.227.154.13

!

!

!

control-plane

!

!

voice-port 0/0/0:15

 translation-profile incoming INCOMING

 disc_pi_off

 echo-cancel coverage 32

 cptone VE

 bearer-cap Speech

!

!

!

mgcp profile default

!

!

dial-peer voice 1 pots

 incoming called-number .

 direct-inward-dial

 forward-digits all

!

dial-peer voice 2 pots

 description ** Llamadas locales desde la CPA **

 destination-pattern 0[1-9]......

 port 0/0/0:15

 forward-digits 7

!

dial-peer voice 3 pots

 description ** Llamadas 0800 y 0500 desde la CPA **

 destination-pattern 90[5,8]0........

 port 0/0/0:15

 forward-digits 11

!

dial-peer voice 4 pots

 description ** Llamadas Nacionales desde la CPA **

 destination-pattern 002.........

 port 0/0/0:15

 forward-digits 11

!

dial-peer voice 5 pots

 tone ringback alert-no-PI

 description ** Llamadas Celulares Movistar desde la CPA**

 destination-pattern 004[1,2]4.......

 port 0/0/0:15

 forward-digits 11

!

dial-peer voice 6 pots

 tone ringback alert-no-PI

 description ** Llamadas Celulares Movilnet y Digitel desde la CPA**

 destination-pattern 004[1,2][2,6].......

 port 0/0/0:15

 forward-digits 11

!

dial-peer voice 7 pots

 corlist outgoing Internacional

 description ** Llamadas Internacionales desde la CPA **

 destination-pattern 00T

 port 0/0/0:15

 forward-digits all

!

 

dial-peer voice 9 pots

 description ** Llamada al 171  **

 destination-pattern 0171

 port 0/0/0:15

 forward-digits 3

!

dial-peer voice 10 pots

 corlist outgoing Especial

 description ** Llamada al 171  **

 destination-pattern 171

 port 0/0/0:15

 forward-digits all

!

dial-peer voice 100 voip

 destination-pattern 1...

 session target ipv4:10.227.159.135

 incoming called-number .T

 voice-class codec 100 

 dtmf-relay h245-alphanumeric

!

dial-peer voice 101 voip

 preference 2

 destination-pattern 1...

 session target ipv4:10.227.152.135

 incoming called-number .T

 voice-class codec 100 

 dtmf-relay h245-alphanumeric

!

dial-peer voice 9000 voip

 destination-pattern 9...

 session target ipv4:10.227.159.135

 voice-class codec 100 

 dtmf-relay h245-alphanumeric

 no vad

!

dial-peer voice 9001 voip

 preference 2

 destination-pattern 9...

 session target ipv4:10.227.152.135

 voice-class codec 100 

 dtmf-relay h245-alphanumeric

 no vad

!

dial-peer voice 10000 pots

 destination-pattern 04146598490

 port 0/0/0:15

 forward-digits all

!

dial-peer voice 11 pots

 corlist outgoing Local

 description ** Llamadas Emergencias 113 Caracas **

 destination-pattern 0113

 port 0/0/0:15

 forward-digits 3

!

dial-peer voice 12 pots

 corlist outgoing Local

 description ** Llamadas Emergencias 113 Caracas **

 destination-pattern 113

 port 0/0/0:15

 forward-digits all

!

!

gateway

 timer receive-rtp 1200

!

!

!

gatekeeper

 shutdown

 

I know that Disconnected Cause No. 34 - no circuit/channel available [Q.850]:
This cause indicates that there is no appropriate circuit/channel presently available to
handle the call.

 

So, the question is: the disconnected cause=34 in this case mean that is a 100% service-provider issue.

 

Thanks in advance

 

Ronald García

1 ACCEPTED SOLUTION

Accepted Solutions

Hello Ronald, Yes, the

Hello Ronald,

 

Yes, the provider call leg is first disconnected and it seems issue with provider. you may also collect 'debug isdn q931' for another test national call and a working call and check the channel numbers. Mostly the issue should be with provider side. Please have a word with  them

 

//Suresh

Please rate all the helful posts

//Suresh Please rate all the useful posts.
1 REPLY

Hello Ronald, Yes, the

Hello Ronald,

 

Yes, the provider call leg is first disconnected and it seems issue with provider. you may also collect 'debug isdn q931' for another test national call and a working call and check the channel numbers. Mostly the issue should be with provider side. Please have a word with  them

 

//Suresh

Please rate all the helful posts

//Suresh Please rate all the useful posts.
407
Views
0
Helpful
1
Replies
CreatePlease login to create content