Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Need help for Australia E1 x 2

I am configuring a E1 PRI in Australia connected to a 3935 GW which has a SIP trunk to a 8.6 Call Manager. The circuit is in and good with no errors and inbound calls from the PSTN work fine. However, outbound calls connect but there is no audio from the Call Manager to the PSTN however the call manager phones can hear the PSTN side, i.e.:

  • If a call originates from the PSTN both sides hear good audio
  • If the call originates from a Call-manager registered phone the PSTN side does not get audio but the Call Manager side does.

Cisco verified that the audio is making is way from the phone to the gateway correctly and says the issue is a carrier issue which of course Telstra disagrees with. I have pasted the santized gateway config below. Does anybody have any ideas?

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service sequence-numbers

!

hostname voiprouter

!

boot-start-marker

boot system flash0:c3900-universalk9-mz.SPA.152-1.T1.bin

boot system flash0:c3900-universalk9-mz.SPA.151-4.M2.bin

boot-end-marker

!

!

card type e1 0 0

logging buffered 1000000

enable secret 5 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

!

aaa new-model

!

!

aaa authorization exec default local

!

!

!

!

!

aaa session-id common

clock timezone CET 11 0

network-clock-participate wic 0

!

no ipv6 cef

!

ip traffic-export profile test mode capture

  bidirectional

!

!

!

!

!

no ip domain lookup

ip domain name au.ncite

ip cef

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

isdn voice-call-failure 0

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice call send-alert

voice rtp send-recv

!

voice service voip

ip address trusted list

  ipv4 <Call Manager IP>

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

!

!

voice hpi capture buffer 1000000

voice hpi capture destination flash:pcm.dat

!

!

!

application

global

  service alternate default

!

!

license udi pid C3900-SPE100/K9 sn FOC15330TE6

hw-module pvdm 0/0

!

!

!

redundancy

!

!

controller E1 0/0/0

pri-group timeslots 1-31

!

ip ssh version 2

ip scp server enable

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address XXXXXXXXXXXX 255.255.255.192

ip traffic-export apply test size 2000000

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex full

speed 1000

media-type rj45

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

no logging event link-status

no snmp trap link-status

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

router rip

network XXXXXXXXX

!

ip forward-protocol nd

!

no ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 0.0.0.0 0.0.0.0 XXXXXXXXXXX

!

!

nls resp-timeout 1

cpd cr-id 1

!

!

!

!

control-plane

!

!

voice-port 0/0/0:15

cptone AU

bearer-cap Speech

!

voice-port 0/1/0

!

voice-port 0/1/1

!

!

!

mgcp profile default

!

!

dial-peer voice 100 voip

preference 1

destination-pattern 62690...

session protocol sipv2

session target ipv4:<Call Manager IP>

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

dial-peer voice 200 pots

destination-pattern 0

direct-inward-dial

port 0/0/0:15

!

dial-peer voice 300 voip

session protocol sipv2

incoming called-number .T

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

!

!

!

gatekeeper

shutdown

!

!

call-manager-fallback

max-conferences 8 gain -6

transfer-system full-consult

ip source-address XXXXXXXX port 2000

max-ephones 50

max-dn 100

!

3 REPLIES
Green

Need help for Australia E1 x 2

Nathan,

Can you post

show ip int brief

This is usualy an IP routing issue

Regards

Alex

Regards, Alex. Please rate useful posts.

Need help for Australia E1 x 2

Hi Nathan

Can you also post a show voice call status for both incoming and outgoing call?

Regards

Carlo

Please rate all helpful posts "The more you help the more you learn"
New Member

Need help for Australia E1 x 2

This was a bug in IOS. Going from 15.2T to 15.1M resolved the issue. As I said, we (Cisco and me)  verified IP routing, we verified that the actual voice media packet was getting to the gateway but there was just no voice. Finally I  went from a 15.2T train to a 15.1M load and it worked like a champ.

328
Views
0
Helpful
3
Replies
CreatePlease to create content