Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Need help with configuring 3550 for home lab

I've started to setup a home IPT lab to try learn a little about Unified Communications a little more.  I'm having problems with getting my 3550 switch configured properly to get IP phones to register properly.

I have a dedicated machine that has ESXI 5.0 installed on it.  I have 4 virtual machines installed on the ESXI server.  CUCM (Pub), CUCM (Sub), Unity Connection, and Presence.

My topology is as follows:

Internet

DSL Modem (192.168.2.1)

Linksys Router  (192.168.3.1)

Linksys assigns DHCP from 192.168.3.2 -> 192.168.3.19)  (All my home devices, other pc's, etc....)

My desktop PC is static 192.168.3.20

The 3550 (vlan 1) is static 192.168.3.50. 

   -  Port f0/1 connects to esxi server which houses all the UCM

   -  Port f0/2 connects to 7940 phone I have configured in CUCM

   -  Port f0/24 connects back to my Linksys (home network)

The ESXI server is static 192.168.3.200

The CUCM (Pub) is static 192.168.3.201

The CUCM (Sub) is static 192.168.3.202

The UC (Pub) is static 192.168.3.211

The CUP (Pub) is static 192.168.3.221

per above, all of this is on the same subnet (I'm assuming that's ok).  My softphone that I installed on my desktop came up and registered with no problems but my hardphones are not registering.  Can someone help me with how I need to configure the switch (3550)?

Thanks.

19 REPLIES
Hall of Fame Super Silver

Need help with configuring 3550 for home lab

Can you provide switch port configuration of the port the phone is connected to?

Is your Voice VLAN defined to be the same as data VLAN?

Is the phone not getting IP address or not registering?

Is the phone using the Linksys DHCP, if so can you define option 150 in your DHCP scope? Not sure if this is doable on Linksys router, you could try defining static IP on the phone or use the 3550 as DHCP server.

HTH,

Chris

Community Member

Need help with configuring 3550 for home lab

my config is as follows:  I've tried several things, using dhcp, not using it.  I've tried assigning a static ip to the phone and setting the tftp server to .201 (which is cucm pub - the tftp server also)

-----

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname tgc-3550

!

mls qos

ip subnet-zero

ip routing

no ip domain-lookup

ip dhcp excluded-address 192.168.3.1 192.168.3.20

ip dhcp excluded-address 192.168.3.200 192.168.3.254

!

ip dhcp pool phone

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   option 150 ip 192.168.3.201

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

!

!

!

interface FastEthernet0/1

switchport mode dynamic desirable

!

interface FastEthernet0/2

switchport mode access

switchport voice vlan 20

mls qos trust cos

spanning-tree portfast

!

interface FastEthernet0/3

switchport mode dynamic desirable

!

interface FastEthernet0/4

switchport mode dynamic desirable

!

interface FastEthernet0/5

switchport mode dynamic desirable

!

interface FastEthernet0/6

switchport mode dynamic desirable

!

interface FastEthernet0/7

switchport mode dynamic desirable

!

interface FastEthernet0/8

switchport mode dynamic desirable

!

interface FastEthernet0/9

switchport mode dynamic desirable

!

interface FastEthernet0/10

switchport mode dynamic desirable

!

interface FastEthernet0/11

switchport mode dynamic desirable

!

interface FastEthernet0/12

switchport mode dynamic desirable

!

interface FastEthernet0/13

switchport mode dynamic desirable

!

interface FastEthernet0/14

switchport mode dynamic desirable

!

interface FastEthernet0/15

switchport mode dynamic desirable

!

interface FastEthernet0/16

switchport mode dynamic desirable

!

interface FastEthernet0/17

switchport mode dynamic desirable

!

interface FastEthernet0/18

switchport mode dynamic desirable

!

interface FastEthernet0/19

switchport mode dynamic desirable

!

interface FastEthernet0/20

switchport mode dynamic desirable

!

interface FastEthernet0/21

switchport mode dynamic desirable

!

interface FastEthernet0/22

switchport mode dynamic desirable

!

interface FastEthernet0/23

switchport mode dynamic desirable

!

interface FastEthernet0/24

switchport mode access

no cdp enable

!

interface GigabitEthernet0/1

switchport mode dynamic desirable

!

interface GigabitEthernet0/2

switchport mode dynamic desirable

!

interface Vlan1

ip address 192.168.3.50 255.255.255.0

!

ip default-gateway 192.168.3.1

ip classless

ip http server

ip http secure-server

Community Member

Need help with configuring 3550 for home lab

forgot I just added this on f0/2 also:

mls qos trust device cisco-phone

Hall of Fame Super Silver

Need help with configuring 3550 for home lab

well, you are using VLAN 20 as Voice VLAN, what is doing routing for this VLAN as I do not see any VLAN interfaces for it.  Chanage port 0/2 to:

interface FastEthernet0/2

switchport mode access

switchport voice vlan 1

mls qos trust cos

spanning-tree portfast

Chris

Community Member

Need help with configuring 3550 for home lab

I don't have any routers other than my home linksys router.  I guess I would need the switch to act as router.

Hall of Fame Super Silver

Need help with configuring 3550 for home lab

Correct, if you want seperate VLAN for phones, but since this is just a lab, simply assign the same VLAN for voice as your data, default VLAN 1 will be just fine.

Chris

Bronze

Need help with configuring 3550 for home lab

Do you have a helper address assigned to vlan 1 on the 3550?

Community Member

Need help with configuring 3550 for home lab

I do not have a helper address configured, I just included my config above.

Re: Need help with configuring 3550 for home lab

If I read your configuration correctly, you have the phone on fa0/2 which has a voice vlan configured as vlan 20.  But all of the other ports have default configuration, which would place them in vlan 1.  Show your vlans:

show vlans

You'll likely find that fa0/2 is in vlan 20 all by it's lonesome.  (Actually, I cannot recall if this command shows the *voice* vlan for the port).  Regardless, it appears your phone is all alone.  It's on the same subnet (layer 3) yes.  But, on layer 2 it's isolated from everyone else.

The quick check would be Chris Deren's suggestion to change voice vlan to 1 so the phone is in the same layer 2 domain as your other equipment.

I assume your desktop (with CIPC) is connected to one of the other ports on the 3550.  It is therefore in the same default vlan (1) as the other ports, and metaphorically on the same side of the fence.

Best,

Ed

(edited for typo)

Community Member

Need help with configuring 3550 for home lab

OK. I changed the voice vlan to 1 on the f0/2 config and here are my symptoms now.

I'm attaching screenshots. I can see the phone in cdp neigh, it has ip of 192.168.3.12.  I can ping it (couldn't before).  The phone itself is displaying 'Configuring IP', then says opening 72.32.218.57  - thats it.

Here are screenshots.

Hall of Fame Super Silver

Need help with configuring 3550 for home lab

Do you have TFTP server set on the phone? What is it when you go to view it under network settings on the phone?

Chris

Community Member

Need help with configuring 3550 for home lab

settings on phone show TFTP server as 192.168.3.201 (which should be correct)

default router showing 192.168.3.1 (which is my linksys router)

Phone still doing same as before.

Hall of Fame Super Silver

Need help with configuring 3550 for home lab

Can you perform factory reset on it, press Settings --> **# --> more --> Erase

Chris

Community Member

Need help with configuring 3550 for home lab

I did factory reset and same thing.  still saying configuring ip.

I just tried setting a static ip on it now that we've changed everything to vlan 1, waiting to see what happens.

Community Member

Need help with configuring 3550 for home lab

still no luck.

to avoid confusion, here are portions of config again.

mls qos

ip subnet-zero

ip routing

no ip domain-lookup

ip dhcp excluded-address 192.168.3.1 192.168.3.20

ip dhcp excluded-address 192.168.3.200 192.168.3.254

!

ip dhcp pool phone

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   option 150 ip 192.168.3.201

interface FastEthernet0/1  (connected to my ESXI server)

switchport mode dynamic desirable

!

interface FastEthernet0/2  (connected to the 7940 phone)

switchport mode access

switchport voice vlan 1

mls qos trust device cisco-phone

mls qos trust cos

spanning-tree portfast

!

interface FastEthernet0/24  (connected back to linksys home router)

switchport mode access

no cdp enable

I've tried using DHCP on phone and static assign on phone and phone still not registering.

Hall of Fame Super Silver

Re: Need help with configuring 3550 for home lab

Can you ping the IP address of the phone from CUCM server?

Is CUCM server defined with IP address or hostname under CUCM Server configuration under System --> Servers?

What does the staus log on the phone show?

Was this phone used recently with another CUCM 8.0+ system? If so delete ITL certificate.

Chris

Community Member

Need help with configuring 3550 for home lab

Yes, ping successful from CUCM

Servers defined with hostnames.

Status message on phone says DNS timeout. Do I need to change the servers to ip addresses?

Community Member

Need help with configuring 3550 for home lab

It's working now.

Thanks so much for your assistance.

Green

Need help with configuring 3550 for home lab

Hi,

You have int fas 0/2 in VLAN 20

VLAN 20 has no DHCP scope or routing.

You will need to build these in something like

!

vlan 20

name PHONES

!

int vlan 20

desc *** LAYER3 FOR PHONES ***

ip address 192.168.20.1 255.255.255.0

no shut

!

ip dhcp excluded-address 192.168.20.1 192.168.20.20

ip dhcp excluded-address 192.168.20.200 192.168.20.254

!

ip dhcp pool PHONES-VLAN20

   network 192.168.20.0 255.255.255.0

   default-router 192.168.20.1

   option 150 ip 192.168.3.201

!

!also change your phone port config so that your pattop/pc works in

!the PC port too.

!

int fas 0/2

shut

desc *** PHONE & PC **

switchport host

swithcport voice vlan 20

switchport access 1

mls qos trust cos

no shut

!

HTH

Alex

Regards, Alex. Please rate useful posts.
1056
Views
9
Helpful
19
Replies
CreatePlease to create content