Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need some Help configuring sip

Hi all ! ,

Im kind off new to sip calling and cisco telephony , but here goes ,: i have a 2821 router with CME installed

IOS : C2800NM-IPVOICEK9-M

Sofware version : 15.1(4)M4 / CME 8.6

Attached to GE0/0 is a CISCO 3750 switch

GEO - consisfts of 3 VLANS  , the native

172.22.1.X

172.22.100.X VOICE

172.22.101.X DATA

my tftpserver = 172.22.1.150

i need some help configuring a sip trunk , i have 10 testing phonenumbers from vodafone , but i do not know where to start to get this working

i have tried

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_example09186a00808f9666.shtml

but im getting stuck with what to fill in where .. is there anyone form NL whom has the same setup ? or similar ? or can give me some guidance on how to make the test calls

25 REPLIES

Need some Help configuring sip

Hi Vincent.

With conf you uploaded, your are at good point.

Now you should receive authetication credentials from you TSP for both receive and place calls.

Once you have your account, you have to add it undre sip-ua configuration section.

Eg.

sip-ua

authentication username "user" password "password" realm tspdomain.com (valid to authenticate for outgoing calls)

credentials username (or number) "username" password "password realm tspdomain.com (valid to receive calls)

registrar 1 dns:sipregistrar.com:5060 (you can add up to 6 registrar in case of different services)

HTH

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
New Member

Need some Help configuring sip

Hi Carlo ,

thanks for your quick reply :

is the user "phonenumber"  eg

0101234567@blah.com ?

Need some Help configuring sip

Hi Vincent.

Yes sure could be the telephone number and, in this case, to authenticate for incoming calls, you should add.

credentials number password realm blah.com

HTH

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
New Member

Need some Help configuring sip

Hi Carlo ,

Ok . i have added the info which vodafone provided me , is there any way to trace this ? eg

picking up the horn ?

i have tried debug callmanager events .. which shows me picking up the horn but im unable to verify the connection to sip?

Need some Help configuring sip

Try using the show commands in the document below:

http://www.cisco.com/en/US/docs/ios/voice/sip/configuration/guide/sip_cg-vrfy_trouble.pdf

1. show sip service

2. show sip-ua register status

3. show sip-ua statistics

4. show sip-ua status

5. show sip-ua timers

New Member

Need some Help configuring sip

aha !

thanks james for the command , however i think i have done something wrong :

Router#show sip-ua register status

Line                             peer       expires(sec) registered P-Associ-URI

================================ ========== ============ ========== ============

0262610290                       -1         138          no

2626102901                       20002      138          no

901                              20001      138          no

Router#show sip-ua status

SIP User Agent Status

SIP User Agent for UDP : ENABLED

SIP User Agent for TCP : ENABLED

SIP User Agent for TLS over TCP : ENABLED

SIP User Agent bind status(signaling): DISABLED

SIP User Agent bind status(media): DISABLED

SIP early-media for 180 responses with SDP: ENABLED

SIP max-forwards : 70

SIP DNS SRV version: 2 (rfc 2782)

NAT Settings for the SIP-UA

Role in SDP: NONE

Check media source packets: DISABLED

Maximum duration for a telephone-event in NOTIFYs: 2000 ms

SIP support for ISDN SUSPEND/RESUME: ENABLED

Redirection (3xx) message handling: ENABLED

Reason Header will override Response/Request Codes: DISABLED

Out-of-dialog Refer: DISABLED

Presence support is DISABLED

protocol mode is ipv4

SDP application configuration:

Version line (v=) required

Owner line (o=) required

Timespec line (t=) required

Media supported: audio video image

Network types supported: IN

Address types supported: IP4 IP6

Transport types supported: RTP/AVP udptl

Re: Need some Help configuring sip

Hi Vincent.
Please post relevant sip-ua configuration

thanks

Regards

Carlo

Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
New Member

Need some Help configuring sip

Hi Carlo ,

i dont quite understand what u mean by relevant , as u know im from the netherlands , and the CME config i spitted in there is from a USA config posted on the cisco site , i duplicated that and now trying to get sip to work

i have 10 testing phone numbers , eg 0262610290 through 9

i have connected 1 ephone with the explained 901 extention as shown in the example

if i dial the number from my phone , the call is received on the modem , but does not get to the 2821

i can ping the vodafone RTR from my 2821 console , apperently im missing something

i can use the number as sip user , but im uncertain how to go from there?

New Member

Need some Help configuring sip

after enabling the debug ccsip messages the following log appears

Router#debug ccsip messages

SIP Call messages tracing is enabled

Router#

Jan  2 14:28:00.875: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

REGISTER sip:62.140.159.225:5060 SIP/2.0

Via: SIP/2.0/UDP 172.22.1.51:5060;branch=z9hG4bK5B1A

From: <2626102901>;tag=64348-1098

To: <2626102901>

Date: Thu, 02 Jan 2014 14:28:00 GMT

Call-ID: F7CC4D1-72F011E3-8003C222-F14BE05E

User-Agent: Cisco-SIPGateway/IOS-12.x

Max-Forwards: 70

Timestamp: 1388672880

CSeq: 4 REGISTER

Contact: <2626102901>

Expires:  3600

Supported: path

Content-Length: 0

Jan  2 14:28:00.883: //50/000000000000/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 503 Service Unavailable - registrar unavail or not enabled

Via: SIP/2.0/UDP 172.22.1.51:5060;branch=z9hG4bK5B1A

From: <2626102901>;tag=64348-1098

To: <2626102901>;tag=42F4ABC0-9E1

Date: Thu, 02 Jan 2014 13:51:55 GMT

Call-ID: F7CC4D1-72F011E3-8003C222-F14BE05E

Server: Cisco-SIPGateway/IOS-15.2.4.M3

Timestamp: 1388672880

CSeq: 4 REGISTER

Content-Length: 0

Jan  2 14:28:04.871: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

REGISTER sip:62.140.159.225:5060 SIP/2.0

Via: SIP/2.0/UDP 172.22.1.51:5060;branch=z9hG4bK62467

From: <901>;tag=652E4-216E

To: <901>

Date: Thu, 02 Jan 2014 14:28:04 GMT

Call-ID: F307A93-72F011E3-8002C222-F14BE05E

User-Agent: Cisco-SIPGateway/IOS-12.x

Max-Forwards: 70

Timestamp: 1388672884

CSeq: 4 REGISTER

Contact: <901>

Expires:  3600

Supported: path

Content-Length: 0

Jan  2 14:28:04.879: //51/000000000000/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 503 Service Unavailable - registrar unavail or not enabled

Via: SIP/2.0/UDP 172.22.1.51:5060;branch=z9hG4bK62467

From: <901>;tag=652E4-216E

To: <901>;tag=42F4BB5C-D6C

Date: Thu, 02 Jan 2014 13:51:59 GMT

Call-ID: F307A93-72F011E3-8002C222-F14BE05E

Server: Cisco-SIPGateway/IOS-15.2.4.M3

Timestamp: 1388672884

CSeq: 4 REGISTER

Content-Length: 0

Jan  2 14:28:08.667: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

OPTIONS sip:172.22.1.51:5060 SIP/2.0

Via: SIP/2.0/UDP 62.140.159.226:5060;branch=z9hG4bK3F1B21AD1

From: <62.140.159.226>;tag=42F4CA2C-1A14

To: <172.22.1.51>

Date: Thu, 02 Jan 2014 13:52:02 GMT

Call-ID: E4A0F55B-72EB11E3-B23DD474-C3882D2E@62.140.159.226

User-Agent: Vodafone-NL-SIP-Gateway-V1.0

Max-Forwards: 70

CSeq: 101 OPTIONS

Contact: <62.140.159.226:5060>

Content-Length: 0

Jan  2 14:28:08.671: //52/EF79772E803E/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 62.140.159.226:5060;branch=z9hG4bK3F1B21AD1

From: <62.140.159.226>;tag=42F4CA2C-1A14

To: <172.22.1.51>;tag=661B8-F5C

Date: Thu, 02 Jan 2014 14:28:08 GMT

Call-ID: E4A0F55B-72EB11E3-B23DD474-C3882D2E@62.140.159.226

Server: Cisco-SIPGateway/IOS-12.x

CSeq: 101 OPTIONS

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIF

Y, INFO, REGISTER

Allow-Events: telephone-event

Accept: application/sdp

Supported: 100rel,timer,resource-priority,replaces,sdp-anat

Content-Type: application/sdp

Content-Length: 166

v=0

o=CiscoSystemsSIP-GW-UserAgent 3073 3407 IN IP4 172.22.1.51

s=SIP Call

c=IN IP4 172.22.1.51

t=0 0

m=audio 0 RTP/AVP 18 0 8 9 4 2 15 3

c=IN IP4 172.22.1.51

Jan  2 14:28:09.655: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

OPTIONS sip:172.22.1.51:5060 SIP/2.0

Via: SIP/2.0/UDP 62.140.159.226:5060;branch=z9hG4bK3F1B38C9

From: <62.140.159.226>;tag=42F4CE08-F67

To: <172.22.1.51>

Date: Thu, 02 Jan 2014 13:52:03 GMT

Call-ID: E537B92C-72EB11E3-B23ED474-C3882D2E@62.140.159.226

User-Agent: Vodafone-NL-SIP-Gateway-V1.0

Max-Forwards: 70

CSeq: 101 OPTIONS

Contact: <62.140.159.226:5060>

Content-Length: 0

Jan  2 14:28:09.659: //53/F010389D803F/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 62.140.159.226:5060;branch=z9hG4bK3F1B38C9

From: <62.140.159.226>;tag=42F4CE08-F67

To: <172.22.1.51>;tag=66594-16BD

Date: Thu, 02 Jan 2014 14:28:09 GMT

Call-ID: E537B92C-72EB11E3-B23ED474-C3882D2E@62.140.159.226

Server: Cisco-SIPGateway/IOS-12.x

CSeq: 101 OPTIONS

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIF

Y, INFO, REGISTER

Allow-Events: telephone-event

Accept: application/sdp

Supported: 100rel,timer,resource-priority,replaces,sdp-anat

Content-Type: application/sdp

Content-Length: 166

v=0

o=CiscoSystemsSIP-GW-UserAgent 2096 2958 IN IP4 172.22.1.51

s=SIP Call

c=IN IP4 172.22.1.51

t=0 0

m=audio 0 RTP/AVP 18 0 8 9 4 2 15 3

c=IN IP4 172.22.1.51

Jan  2 14:28:09.667: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

OPTIONS sip:172.22.1.51:5060 SIP/2.0

Via: SIP/2.0/UDP 62.140.159.225:5060;branch=z9hG4bK3F1B4CEB

From: <62.140.159.225>;tag=42F4CE14-511

To: <172.22.1.51>

Date: Thu, 02 Jan 2014 13:52:03 GMT

Call-ID: E5398E3D-72EB11E3-B23FD474-C3882D2E@62.140.159.225

User-Agent: Vodafone-NL-SIP-Gateway-V1.0

Max-Forwards: 70

CSeq: 101 OPTIONS

Contact: <62.140.159.225:5060>

Content-Length: 0

Jan  2 14:28:09.671: //54/F0120DAE8040/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 62.140.159.225:5060;branch=z9hG4bK3F1B4CEB

From: <62.140.159.225>;tag=42F4CE14-511

To: <172.22.1.51>;tag=665A0-11

Date: Thu, 02 Jan 2014 14:28:09 GMT

Call-ID: E5398E3D-72EB11E3-B23FD474-C3882D2E@62.140.159.225

Server: Cisco-SIPGateway/IOS-12.x

CSeq: 101 OPTIONS

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIF

Y, INFO, REGISTER

Allow-Events: telephone-event

Accept: application/sdp

Supported: 100rel,timer,resource-priority,replaces,sdp-anat

Content-Type: application/sdp

Content-Length: 165

v=0

o=CiscoSystemsSIP-GW-UserAgent 7454 235 IN IP4 172.22.1.51

s=SIP Call

c=IN IP4 172.22.1.51

t=0 0

m=audio 0 RTP/AVP 18 0 8 9 4 2 15 3

c=IN IP4 172.22.1.51

Jan  2 14:28:10.755: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

OPTIONS sip:172.22.1.51:5060 SIP/2.0

Via: SIP/2.0/UDP 62.140.159.225:5060;branch=z9hG4bK3F1B5214B

From: <62.140.159.225>;tag=42F4D254-D25

To: <172.22.1.51>

Date: Thu, 02 Jan 2014 13:52:05 GMT

Call-ID: E5DF95C5-72EB11E3-B240D474-C3882D2E@62.140.159.225

User-Agent: Vodafone-NL-SIP-Gateway-V1.0

Max-Forwards: 70

CSeq: 101 OPTIONS

Contact: <62.140.159.225:5060>

Content-Length: 0

Jan  2 14:28:10.759: //55/F0B811668041/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 62.140.159.225:5060;branch=z9hG4bK3F1B5214B

From: <62.140.159.225>;tag=42F4D254-D25

To: <172.22.1.51>;tag=669E4-32E

Date: Thu, 02 Jan 2014 14:28:10 GMT

Call-ID: E5DF95C5-72EB11E3-B240D474-C3882D2E@62.140.159.225

Server: Cisco-SIPGateway/IOS-12.x

CSeq: 101 OPTIONS

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIF

Y, INFO, REGISTER

Allow-Events: telephone-event

Accept: application/sdp

Supported: 100rel,timer,resource-priority,replaces,sdp-anat

Content-Type: application/sdp

Content-Length: 166

v=0

o=CiscoSystemsSIP-GW-UserAgent 7723 2893 IN IP4 172.22.1.51

s=SIP Call

c=IN IP4 172.22.1.51

t=0 0

m=audio 0 RTP/AVP 18 0 8 9 4 2 15 3

c=IN IP4 172.22.1.51

can anyone shed some light on this ?

New Member

Need some Help configuring sip

ok .. i figured out the register ,

so i have configured 5 phones , which are reachable from the outside ,

trying to dial myself back is not working .. i think it has something to do with the dial rules

Re: Need some Help configuring sip

Hi Vincent.
My question was if you can upload here the router config after changes that I suggested.

Thanks

Carlo

Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
New Member

Re: Need some Help configuring sip

ok.. here goes

Building configuration...

Current configuration : 9721 bytes

!

! Last configuration change at 15:26:14 CET Thu Jan 2 2014

! NVRAM config last updated at 15:26:14 CET Thu Jan 2 2014

! NVRAM config last updated at 15:26:14 CET Thu Jan 2 2014

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

clock timezone CET 1 0

network-clock-participate wic 0

network-clock-participate wic 1

network-clock-select 1 E1 0/0/0

network-clock-select 2 E1 0/0/1

!

dot11 syslog

ip source-route

!

!

ip cef

!

!

ip dhcp pool VOICE

network 172.22.100.0 255.255.255.0

option 150 ip 172.22.1.150

default-router 172.22.100.1

!

ip dhcp pool DATA

network 172.22.101.0 255.255.255.0

default-router 172.22.101.1

!

!

no ip domain lookup

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

!

!

voice service voip

ip address trusted list

  ipv4 172.22.1.50

  ipv4 172.22.1.51

  ipv4 172.22.100.1

  ipv4 172.22.101.1

  ipv4 62.140.159.225

callmonitor

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

sip

  registrar server expires max 3600 min 3600

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

codec preference 4 g729br8

!

!

voice register global

!

!

!

voice translation-rule 1

rule 1 /5123781291/ /601/

rule 2 /5123781290/ /600/

!

voice translation-rule 2

rule 1 /^112$/ /112/

!

voice translation-rule 3

rule 1 /^.*/ /0262610290/

!

voice translation-rule 4

rule 2 /600/ /5123788000/

rule 3 /601/ /5123788001/

rule 4 /^2(..)$/ /51237812\1/

!

!

voice translation-profile CUE_Voicemail/AutoAttendant

translate called 1

!

voice translation-profile PSTN_CallForwarding

translate redirect-target 4

translate redirect-called 4

!

voice translation-profile PSTN_Outgoing

translate calling 3

translate called 2

translate redirect-target 4

translate redirect-called 4

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

!

!

!

!

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-31

!

controller E1 0/0/1

framing NO-CRC4

pri-group timeslots 1-31

!

ip ftp username cisco

ip ftp password cisco123

ip tftp source-interface GigabitEthernet0/0.1

!

!

!

!

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

no keepalive

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 1 native

ip address 172.22.1.51 255.255.255.0

!

interface GigabitEthernet0/0.20

encapsulation dot1Q 20

ip address 172.22.101.1 255.255.255.0

!

interface GigabitEthernet0/0.100

encapsulation dot1Q 100

ip address 172.22.100.1 255.255.255.0

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex full

speed 100

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial0/0/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface BRI0/1/0

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

!

interface BRI0/1/1

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

!

ip forward-protocol nd

!

ip http server

ip http authentication local

no ip http secure-server

ip http max-connections 16

ip http path flash:gui

!

ip route 0.0.0.0 0.0.0.0 172.22.1.50

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

tftp-server flash:7941/apps41.8-4-1-23.sbn alias apps41.8-4-1-23.sbn

tftp-server flash:7941/cnu41.8-4-1-23.sbn alias cnu41.8-4-1-23.sbn

tftp-server flash:7941/dsp41.8-4-1-23.sbn alias dsp41.8-4-1-23.sbn

tftp-server flash:7941/jar41sccp.8-4-1-23.sbn alias jar41sccp.8-4-1-23.sbn

tftp-server flash:7941/cvm41sccp.8-4-1-23.sbn alias cvm41sccp.8-4-1-23.sbn

tftp-server flash:7941/SCCP41.8-4-2S.loads alias SCCP41.8-4-2S.loads

tftp-server flash:7941/term41.default.loads alias term41.default.loads

tftp-server debug

!

control-plane

!

!

voice-port 0/0/0:15

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/0/1:15

!

voice-port 2/0/0

!

voice-port 2/0/1

!

voice-port 2/0/2

!

voice-port 2/0/3

!

voice-port 2/0/4

!

voice-port 2/0/5

!

voice-port 2/0/6

!

voice-port 2/0/7

!

voice-port 2/0/8

!

voice-port 2/0/9

!

voice-port 2/0/10

!

voice-port 2/0/11

!

voice-port 2/0/12

!

voice-port 2/0/13

!

voice-port 2/0/14

!

voice-port 2/0/15

!

voice-port 2/0/16

!

voice-port 2/0/17

!

voice-port 2/0/18

!

voice-port 2/0/19

!

voice-port 2/0/20

!

voice-port 2/0/21

!

voice-port 2/0/22

!

voice-port 2/0/23

!

!

!

mgcp profile default

!

!

dial-peer voice 1 voip

description **Incomming Call from SIP Trunk**

translation-profile incoming CUE_Voicemail/AutoAttendant

session protocol sipv2

session target ipv4:172.22.1.50

incoming called-number .%

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

dtmf-relay rtp-nte

no vad

!

dial-peer voice 2 voip

description **Outgoing Call to SIP Trunk**

translation-profile outgoing PSTN_Outgoing

destination-pattern 9........

session protocol sipv2

session target ipv4:172.22.1.50

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

dtmf-relay rtp-nte

no vad

!

dial-peer voice 3 voip

description **Outgoing Call to SIP Trunk **

translation-profile outgoing PSTN_Outgoing

destination-pattern 9[2-9]..[2-9]......

session protocol sipv2

session target ipv4:172.22.1.50

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

dtmf-relay rtp-nte

no vad

!

dial-peer voice 4 voip

description **Outgoing Call to SIP Trunk**

translation-profile outgoing PSTN_Outgoing

destination-pattern 9[0-1][2-9]..[2-9]......

session protocol sipv2

session target ipv4:172.22.1.50

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

dtmf-relay rtp-nte

no vad

!

dial-peer voice 5 voip

description **911 Outgoing Call to SIP trunk**

translation-profile outgoing PSTN_Outgoing

destination-pattern 911

session protocol sipv2

session target ipv4:172.22.1.50

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

dtmf-relay rtp-nte

no vad

!

dial-peer voice 6 voip

description **Emergency Outgoing Call to SIP Trunk**

translation-profile outgoing PSTN_Outgoing

destination-pattern 9911

session protocol sipv2

session target ipv4:172.22.1.50

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

dtmf-relay rtp-nte

no vad

!

dial-peer voice 7 voip

description **911/411 Outgoing Call to SIP Trunk**

translation-profile outgoing PSTN_Outgoing

destination-pattern 9[2-9]11

session protocol sipv2

session target ipv4:172.22.1.50

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

dtmf-relay rtp-nte

no vad

!

dial-peer voice 8 voip

description **International Outgoing Call to SIP Trunk**

translation-profile outgoing PSTN_Outgoing

destination-pattern 9011T

session protocol sipv2

session target ipv4:172.22.1.50

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

dtmf-relay rtp-nte

no vad

!

dial-peer voice 9 voip

description **Star Code to SIP Trunk**

destination-pattern *..

session protocol sipv2

session target ipv4:172.22.1.50

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

dtmf-relay rtp-nte

no vad

!

dial-peer voice 10 voip

description **CUE Voicemail**

translation-profile outgoing PSTN_CallForwarding

destination-pattern 600

b2bua

session protocol sipv2

session target ipv4:172.22.1.155

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 11 voip

description **CUE Auto Attendant**

translation-profile outgoing PSTN_CallForwarding

destination-pattern 601

b2bua

session protocol sipv2

session target ipv4:172.22.1.155

dtmf-relay sip-notify

codec g711ulaw

no vad

!

!

sip-ua

authentication username 0262610290 password 7 15020A1F173D24362C realm 62.140.1

59.225

authentication username 0262610290 password 7 021605481811003348

no remote-party-id

retry invite 2

retry register 10

timers connect 100

registrar ipv4:62.140.159.225 expires 3600

sip-server ipv4:62.140.159.224

host-registrar

!

!

telephony-service

max-ephones 58

max-dn 192

ip source-address 172.22.100.1 port 2000

calling-number initiator

system message testing

cnf-file location TFTP tftp://172.22.1.150/

load 7960-7940 P00307020200.loads

load 7941 SCCP41.8-4-2S.loads

load 7941GE SCCP41.8-4-2S

time-format 24

dialplan-pattern 1 26261029.. extension-length 3 extension-pattern 9..

voicemail 600

max-conferences 12 gain -6

call-forward pattern 9.T

moh music-on-hold.au

web admin system name admin password password

dn-webedit

time-webedit

transfer-system full-consult

secondary-dialtone 9

directory entry 1 101 name 101

create cnf-files version-stamp 7960 Jan 02 2014 08:40:49

!

!

ephone-dn  1

number 290 secondary 0262610290

name Phone 1

hold-alert 30 originator

!

!

ephone-dn  2

number 291 secondary 0262610291

name phone 2

hold-alert 30 originator

!

!

ephone-dn  3

number 292 secondary 0262610292

name Phone 3

hold-alert 30 originator

!

!

ephone-dn  4

number 293 secondary 0262610293

name Phone 4

hold-alert 30 originator

!

!

ephone-dn  5

number 294 secondary 0262610294

label Phone 5

hold-alert 30 originator

!

!

ephone  1

mac-address 0019.E88F.3BDD

button  1:1

!

!

!

ephone  2

mac-address 001E.4A92.0A27

type 7961

button  1:2

!

!

!

ephone  3

mac-address 0012.43F5.03AF

button  1:3

!

!

!

ephone  4

mac-address 000F.F7AC.502A

button  1:4

!

!

!

ephone  5

mac-address 0019.E851.090A

button  1:5

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

ntp master

end

Re: Need some Help configuring sip

Hi Vincent

As I suggested, to receive calls, you should add this configuration line under sip-ua section.

sip-ua

credentials number 0262610290 username 0262610290 password 7 021605481811003348 realm 62.140.159.225

Than post again a show sip-ua register status

HTH

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
New Member

Re: Need some Help configuring sip

i am able to receive calls , i am unable to call something

i have added additional ephones to my setup

0262610291

0262610292

0262610293

and they all can recieve calls , but i cannot place calls to an outside line ..

i will add the setup cfg u proposed

New Member

Re: Need some Help configuring sip

Router#show sip-ua register status
Line                             peer       expires(sec) registered P-Associ-URI

================================ ========== ============ ========== ============

0262610290                       20009      170          no
0262610291                       20011      89           no
0262610292                       20013      140          no
0262610293                       20015      135          no
0262610294                       20017      139          no
290                              20008      21           no
291                              20010      89           no
292                              20012      139          no
293                              20014      135          no
294                              20016      139          no

Need some Help configuring sip

Hi Vincent.

From the output it seems that you are still unable to receive calls on that numbers.

Can you please post a debug ccsip messages to see why?

Thanks

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
New Member

Need some Help configuring sip

Hi carlo ,

i am ABLE to recieve calls on all the numbers , i am unable to make calls

Need some Help configuring sip

Vincent, can you please post a debug ccsip during a failnig call?

Thanks

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
New Member

Need some Help configuring sip

SIP Call statistics tracing is enabled

Router#

Jan  3 09:28:47.099: //8371/46C07F7392FC/SIP/Call/sipSPICallInfo:

The Call Setup Information is:

Call Control Block (CCB) : 0x4A9C2800

State of The Call        : STATE_DEAD

TCP Sockets Used         : NO

Calling Number           : 0262610290

Called Number            : 0065152305

Source IP Address (Sig  ): 172.22.1.51

Destn SIP Req Addr:Port  : 172.22.1.50:5060

Destn SIP Resp Addr:Port : 172.22.1.50:5060

Destination Name         : 172.22.1.50

Jan  3 09:28:47.099: //8371/46C07F7392FC/SIP/Call/sipSPIMediaCallInfo:

Number of Media Streams: 1

Media Stream             : 1

Negotiated Codec         : No Codec

Negotiated Codec Bytes   : 0

Nego. Codec payload      : 255 (tx), 255 (rx)

Negotiated Dtmf-relay    : 0

Dtmf-relay Payload       : 0 (tx), 0 (rx)

Source IP Address (Media): 172.22.1.51

Source IP Port    (Media): 17324

Destn  IP Address (Media):  -

Destn  IP Port    (Media): 0

Orig Destn IP Address:Port (Media): [ - ]:0

Jan  3 09:28:47.099: //8371/46C07F7392FC/SIP/Call/sipSPICallInfo:

Disconnect Cause (CC)    : 127

Disconnect Cause (SIP)   : 200

hmmz

Need some Help configuring sip

Hi Vincent.

I need a complete trace during an outgoing call to verify the issue.

What you posted is not so complete.

Thanks

Carlo

Please rate all helpful posts "The more you help the more you learn"
New Member

Need some Help configuring sip

Hi carlo ,

since i am unable to make a call , what setting u want me use ? using debug ccsip all is alot to paste

Re: Need some Help configuring sip

Hi Vincent.

Because you have a problem dialing out, a complete trace would be usefull to investigate your issue.

You can log your session with debug activated, put the result in a file (you can also zip it) and upload here using "attach file" on bottom of post editor.

Thanks again

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
New Member

Need some Help configuring sip

after looking @ the debug log i noticed an configuration error

- my ipv4 was 172.22.1.51 and it should have pointed to the external ip

once i edited the dial-peer voice 3 and 4 i was able to make calls to the outside world

what still bothers me is that the

show sip-ua register status command

does not show ANY registered peers

Need some Help configuring sip

Hi Vincent

Once again, without any output of a debug ccsip messages, we cannot investigate further on your issue.

If you can, please post the debug output as suggested.

Thanks

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
New Member

Re: Need some Help configuring sip

Morning

this morning i placed a call from my Cisco Ephone to a cellphone , with "debug ccsip messages"

so maybe u can have a clue why my sip works , but my peers do not register

743
Views
0
Helpful
25
Replies