Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Network MoH

Hi

I am having problem with MoH, it works fine for everything except for when transferring a call that came from the PSTN, internal calls when transferred to another extension works fine. The operator presses transfer, and music plays on the calling party side, the number gets entered and when the transfer button is pushed again, there is no ringing sound or anything (Only if the calling party is internal), callers then think they have been cut off and then put the phone down.

Is there anything I need to do on the gateway to enable this, or is it a setting on the CCM 5.1?

16 REPLIES
Cisco Employee

Re: Network MoH

make sure the GW has a MRGL with MOH servers in it so it can access the resources

HTH

javalenc

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Re: Network MoH

How would I do this?

Thanks

Cisco Employee

Re: Network MoH

go into the GW and check the MRGL assigned, then go to the MRGL and see the MRG assigned, then go thru each MRG and see if there's a MOH server

HTH

javalenc

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Re: Network MoH

Sorry not following you.

Cisco Employee

Re: Network MoH

all that i mentioned is on the CUCM, all you need to do is device -> gateway and so on

HTH

javalenc

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
Cisco Employee

Re: Network MoH

Based on this problem description:

'The operator presses transfer, and music plays on the calling party side...the number gets entered and when the transfer button is pushed again, there is no ringing sound...'

Is it possible the issue is really one of 'no ringback on transfer', as opposed to being a MOH issue?

Regards,

Michael.

New Member

Re: Network MoH

Okay, got you. I have created sip trunks to the gateway, a non mgcp gateway. Have checked Mrgl and all that, but still no luck, so yes it is a problem with the ringing sound that people can't hear while being trasferred, not MoH, my apologies... any other ideas I can try?

Cisco Employee

Re: Network MoH

Shaun,

I believe the Annunciator resource is used to provide the ringback tone over the SIP trunk. Could you ensure that the trunk's MRGL has access to the annunciator and test again?

Regards,

Michael.

New Member

Re: Network MoH

Hi Michael

Checked under device>>trunk, the mrgl is configured to a group list I have created, and in that list is ann 2 and ann 3. Tried again, nothing. It works internally but not from outside.

Cisco Employee

Re: Network MoH

Hi Shaun,

Could you please post here the detailed CCM traces collected while replicating the problem?

Please also note and elaborate on the extensions and sequence of recreating it.

Thanks,

Michael.

New Member

Re: Network MoH

announcement network locale not found id55

kannaudioundefinedlocale - unknown ANN locale locale identifier 55

Seems to be a propblem with the locale, where do I change this? It was set as South Africa, but when you go into any device and try select it form the drop down, it is not there, so I have changed it back toi the default USA. HELP!!!

Cisco Employee

Re: Network MoH

Hi Shaun,

Check and see what Device Pool the SIP Trunk is configured for. Go to 'Device -> Trunk' from CCMAdmin, to see the SIP trunk and then look at it to see its Device Pool setting.'

Next, see what the 'Network Locale" setting is for that Device Pool (seen in 'System -> Device Pool')

Regards,

Michael.

New Member

Re: Network MoH

Hi Michael

Have checked and the locale for the device pool that the trunk is in, is US, it was South Africa, but that wasnt working earlier so I changed it back to US. Also in Enterprise Parameters under localization, it was also set to south africa but i have changed it back to US, still doesnt work. Here are the full trace logs relating to the ringback:

05/26/2008 13:43:47.055 VoiceStrm|kANNAudioUndefinedLocale - Unknown ANN Locale Locale identifier:55 App ID:Cisco IP Voice Media Streaming App Cluster ID:StandAloneCluster Node ID:TridentCM2|<:STANDALONECLUSTER><:172.16.0.190><:ALARM><:ALL><:FFFF>

05/26/2008 13:43:47.055 VoiceStrm| CPlayWavFilesMgr::Play aid(18) cid(29848848) Unknown ANN resource. Locale(1) AnnID(36)|<:STANDALONECLUSTER><:172.16.0.190><:ERROR><:2000>

05/26/2008 13:43:51.077 VoiceStrm| [ANN][172.16.0.190] DeviceMgr::recvStationStopMediaTransmissionMsg *ERROR* Conference ID is invalid!, passThruPartyID=16806099|<:STANDALONECLUSTER><:172.16.0.190><:ERROR><:2000>

05/26/2008 13:44:11.527 VoiceStrm| CANNAudio::GetAnnouncement() *ERROR* Announcement network locale not found ID(55)|<:STANDALONECLUSTER><:172.16.0.190><:ERROR><:2000>

Cisco Employee

Re: Network MoH

Hi Shaun,

One more item on the check list.

Please check the Device Pool used by the annunciator resources. Ensure that that the Device Pools they are using also have the locale set to United States, English. Reset the annunciator and test again.

Regards,

Michael.

New Member

Re: Network MoH

Howzit Michael

Checked and it is all set to United States - English, anything else it could be?

So the annunciater and MRG and MRGL are set correctly, and in device pool the locales are set to US - En, the phones are set to US. What else could it be? Do you think there is something missing on the gateway or does that not come into the equasion?

Re: Network MoH

Hi javalenc and hope you are in a good heath.

i have a MOH issue and still can`t solve it........


i`m using cisco cucm-BE with mgcp protocol with the gateways,

When someone called form the pstn to the cucm and after he hear the autoattendant:

the    MOH only works when i press 0 (the operator) and when i press an    internal extension i hear a ring back tone and sometimes i hear the MOH  for one second but when i dial 0 i hear the   MOH Normally after "wait  while i transfer your call"

how i can hear the MOH too after i dial the internal extension normally?

the following is done:

-am using unicast MOH

- that media resource is enabled. Media Resource->MoH Server and verify that the run flag is set to YES.

- Restart the Cisco IP Voice Media Stream App service.

- Check if G711,G729 is enabled for MoH in Service Parameters->Call Manager->Cisco IP Voice Media Stream App service.

- the IP Phones or Gateways has assigned the MRGL that include the MOH resource.

thanks

546
Views
5
Helpful
16
Replies
CreatePlease to create content