Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

New Background Image Problem - CME

I am having an odd issue with CME background image. I have created the correct directories, XML file, sized thumbnail and full size. When you go to images menu on the 7961, the thumbnail is there to "select" but is blank, you can't see the image on the thumbnail, just a blank square box. When you click to select, the error message "File not found" is displayed and it obviously can't be selected. I have the exact same configuration working on 7975 phones - I merely changed images and file names for the 7961. Config is as follows:

Directory of flash:/

    1  drw-           0   Apr 1 2012 16:29:14 +10:00  GUI

   55  drw-           0   Apr 1 2012 15:23:54 +10:00  ATA

   58  drw-           0   Apr 6 2012 12:10:08 +10:00  Rings

   74  drw-           0  May 26 2012 22:42:30 +10:00  Desktops

Directory of flash:/Desktops/

   75  drw-           0  Sep 27 2012 00:50:00 +10:00  320x216x16

  79  drw-           0  Sep 27 2012 00:50:18 +10:00  320x196x4

   86  -rw-       23167  Sep 27 2012 01:36:06 +10:00  OP-Color-7975.png

   88  -rw-        4027  Sep 27 2012 01:38:02 +10:00  TN-OP-Color.png

  89  -rw-       20983  Sep 27 2012 01:38:34 +10:00  OP-BW.png

   90  -rw-        3541  Sep 27 2012 01:39:00 +10:00  TN-OP-BW.png

Directory of flash:/Desktops/320x196x4/

  193  -rw-         132  Sep 21 2013 07:47:44 +10:00  7961-List.xml

7961-List.xml

<CiscoIPPhoneImageList>

<ImageItem Image="TFTP:/Desktops/TN-OP-BW.png"

URL="TFTP:/Desktops/OP-BW.png"/>

</CiscoIPPhoneImageList>

TFTP Bindings

tftp-server flash:/Desktops/TN-OP-BW.png alias Desktops/TN-OP-BW.png

tftp-server flash:/Desktops/OP-BW.png alias Desktops/OP-BW.png

tftp-server flash:/Desktops/320x196x4/7961-List.xml alias Desktops/320x196x4/List.xml

____________________

Suggestions?

Nic.

5 REPLIES

New Background Image Problem - CME

Hi,

You need to put your png files and the list xml file inside flash:/Desktops/320x196x4

then in your xml file

320x196x4/TN-OP-BW.png"

URL="TFTP:/Desktops/320x196x4/OP-BW.png"/>

and no need for alias commands then,

Or you can use alias while the files on the root flash directly

Regards

Haitham

Community Member

New Background Image Problem - CME

Hi Haitham,

I understand that is the default procedure for adding backgrounds, however as mentioned my 7975 deployment is setup as I have shown above, with the images in the desktops folder, and it works perfectly. I have aliased for both locating the file, and the fact that each List.xml has a different file name dependant on the phone, so multiple phones can have XML lists on the router without a name confusion.

It is my understanding the alias command should prevent any issue as to not being able to locate the file. If it works for our 7975's on this router why wouldn't it work for the 7961's?

Nic.

New Background Image Problem - CME

Hi NIC,

I don't know if your IP Phone will know the new List.xml file name by itself !!

So you create a directory for each phone. The directory will contain the photos [big and small sizes] beside the List.xml file

And on configuration

tftp-server flash:Desktops/320x212x16/List.xml

tftp-server flash:Desktops/320x212x16/Large.png

tftp-server flash:Desktops/320x212x16/Small.png

you point to each file

But if you need to use alias,,

You can put the files on root flash but you should use the directory in the alias command not as you used above

So please try the first method and feed back

Regards

Haitham

Community Member

New Background Image Problem - CME

Enable the debug this can help in troubleshooting the problem

debug tftp event

Community Member

Have you read this post? Hope

Have you read this post? Hope it can help you solve your background image inserting issue.

 

https://supportforums.cisco.com/discussion/11363836/cme-and-phone-background-images

454
Views
0
Helpful
5
Replies
CreatePlease to create content