Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

newbie: need help with SIP trunk on cme 4.1

cisco 2651XM router

cme 4.1

several 7940G ip phones

I've managed to get a small network of ip phones working on my cisco router but I need help configuring a SIP trunk so a phone (or phones) can make outside calls to PSTN landlines. I've got an account with a sip provider and they've supplied me with a list of settings. It's down to me to configure the router but i'm having difficulty. The router is connected to the internet on fastethernet0/1.

The settings the sip provider have given are:

Domain: sip.mysipprovider.com

Proxy Server Address: sip.mysipprovider.com

Proxy Server Port: 5060

Registrar Server: sip.mysipprovider.com

Registrar Server Port: 5060

Outbound Proxy: sip.mysipprovider.com

Outbound Proxy Port: 5060

SIP Signalling Port: 5060

User ID / Authentication Name: 010101010101 (my sip phone number)

Authentication Password: xxxxxxxxx (my sip password)

I tried following the cisco docs to enter the commands for sip trunking but I can't get it to work.

Firstly, I expect I'd have to press a certain button on the phone to get an outside line - I tried to configure button 9 but this doesn't work. For the moment I'm not worried about voicemail or call forwarding or any extras, I just want to get an outside connection going.

Attached is the running-config of my router.

Thanks for any help.

  • IP Telephony
11 REPLIES

Re: newbie: need help with SIP trunk on cme 4.1

A quick look showed these two problems:

Dial peer 2 should have a pattern of 9.T instead of 9.

You also do not have a name server defined to do a lookup on the sip provider's DNS.

hth,

nick

New Member

Re: newbie: need help with SIP trunk on cme 4.1

nick thankyou for your response. I altered the dial peer 2 and now when I press 9 on the phone it asks 'Enter number' which is good. But when I dial a PSTN number nothing happens.

My sip provider did not provide a name server in the settings they sent me (see first post). They only sent me 'sip.mysipprovider.com' and I can't enter that as a name server in the cli. Under sip-ua I do have:

registrar dns:sip.mysipprovider.com expires 3600

sip-server dns:sip.mysipprovider.com

but maybe this is not enough (?).

Should I ask the sip provider for their DNS details?

Thanks for any further advice.

Re: newbie: need help with SIP trunk on cme 4.1

Your ISP should be able to give you a DNS IP address.

Alternatively, you can use a public DNS server. Here's a list:

http://theos.in/windows-xp/free-fast-public-dns-server-list/

You should be able to ping sip.myprovider.com when it's done. If they don't allow pings, you should at least see the ping resolving to an IP address.

hth,

nick

New Member

Re: newbie: need help with SIP trunk on cme 4.1

I see what you mean now, yes it was easy putting in dns addresses of my isp, but this sip trunk still does not work. The internet connection worked fine on what it had before anyway. I don't know what I'm doing wrong or what I'm missing.

I can ping my sip provider from a PC and I get 4 replies so there's no problem there. If I ring my sip number from a pstn phone I get a message saying my number is 'unavailable' so I don't think my router is even registering with my sip provider. I can ping the sip provider from both a PC and the cli and success is 100%.

Are there any tests one can do to test a sip trunk? Thanks if you can help any further.

Re: newbie: need help with SIP trunk on cme 4.1

You can do some of these steps:

Try setting a translation profile out to make sure that the number that they want to see is shown as the calling number. You can also use the sip-ua command 'calling-info sip-to-pstn number '.

Make sure that the number you're trying to register is a defined number in CME or a pots dial peer. You can use 'show sip register status' or 'show sip status registrar' to see which numbers are trying to register. I don't recall which one of those is the one you're working on, since the last two words just flip :)

debug ccsip messages - this will show you what's going on between you and the provider.

From here - there are more than a dozen reasons why calls may not work and it's not something that can be easily speculated upon.

hth,

nick

New Member

Re: newbie: need help with SIP trunk on cme 4.1

ok thanks. I don't know how to set a translation profile. I did 'calling-info sip-to-pstn number ' and after that I did 'show sip register status':

cme#show sip register status

Line --- peer --- expires(sec) --- registered

==== ===== ======== =======

01 ------ 20001 ---- 64 -------- no

02 ------ 20002 ---- 110 ------- no

03 ------ 20003 ---- 178 ------- no

cme#

I then tried 'show sip status registrar' but all I got was this:

cme#show sip status registrar

Line destination expires(sec) contact

--------call-id

--------peer

=============================================

cme#

anyway above it's clearly showing me that my phones are not registered. So I need to register a 'phone', is that right? if so, what is the command to do that?

I also did:

cme#debug ccsip messages

SIP Call messages tracing is enabled

so how do I look at any results generated by the above command?

thanks for any further advice.

Re: newbie: need help with SIP trunk on cme 4.1

ephone-dn x

number

To see the debugs:

term mon

conf t

logg mon

Translation profiles:

voice translation-rule 1

rule 1 /.*/ /555/

voice translation-profile 1

translated calling 1

dial-peer voice 1 voip

description outgoing sip dial peer

session protocol sipv2

session target sip-server

translation-profile outgoing 1

hth,

nick

New Member

Re: newbie: need help with SIP trunk on cme 4.1

thanks for those commands, I put them in but still no improvement. sip register status still shows 'no' under registered: I need to get one thing sorted out: do I press 9 to get an outside line? at the moment if I press 9 I get a delay of a few seconds and then an engaged tone. If I press 9 and then dial a number I get the same thing. If I press 9 am I supposed to hear a different dial tone? I need to establish what it is I'm supposed to do on the phone to use the sip trunk.

Re: newbie: need help with SIP trunk on cme 4.1

Secondary dialtone is not there by default. This is something configured manually. Since you have 9.T as your destination pattern it will take 10 seconds to dial. If you'd like to fix this, I would do a Cisco.com search on dial peers and look at SRNDs on voice design to get a better idea of how it works.

Other than that, you will need to look at the sip messaging to see if the SIP messaging is getting out, if the provider is receiving it, if the provider is responding, if the provider is sending the response to you, if the response is correct, and if you are sending the right information in your SIP messaging.

Basically - lots of IFs - can't speculate.

287
Views
0
Helpful
11
Replies
This widget could not be displayed.