Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

No Audio between IP Phones and PSTN using codec g729

Hi Everyone,

I working with a CUCM 4.1.3 with a MGCP  gateway with access to PSTN,  i have a region using codec g729 and when i try to call to pstn from that site the call is established but no audio in both ways, even when the DP have a transcoder and it's registered in the cucm, but if i put on hold the call the party can hear the music, i changed the codec to g711 and every works fine, but i really need to use g729 because of lack of bandwith of the remote site.

Please Help.

Thanks in advance

Oscar

5 REPLIES
Cisco Employee

No Audio between IP Phones and PSTN using codec g729

Oscar, Please clarify on following points..

1. Is the caller & MGCP gateway at different sites or same ?

2. For the calling user, Is the CUCM acting as MOH source or the gateway ?

GP.

New Member

No Audio between IP Phones and PSTN using codec g729

Hi Gajanan,

The caller and MGCP Gw are on different sites, We have only one CUCM so it acts as MOH too.

Thanks

Oscar

Cisco Employee

No Audio between IP Phones and PSTN using codec g729

Thanks.

1. Do you have any CAC ( call admission control ) in place between those 2 sites ? Did you configure Location for those 2 sites ?

2. Did you try making a PSTN call, when there are absolutely no calls in progress between 2 sites ? Is the observation different ?

3. Otherwise also, does this issue occur to every PSTN call made from that remote site ?

4. What does the remote site IP Phone show when " i " or " ? " button pressed after the call gets established ? The transmitted & received packet count should give some hint.

5. Finally, is the phone running with latest firmware ?

GP.

New Member

No Audio between IP Phones and PSTN using codec g729

Hi Gajanan,

     I could solve my problem by doing this, it is suppose to be a bug

#Symptoms: Calls on an MGCP gateway negotiating the g729br8 codec may fail to have audio in one or both directions.

#Conditions: This occurs on MGCP gateways with the fix for CSCsu66759 when the g729br8 codec is being negotiated.

#Workaround: Any of the following will be sufficient to get around this issue:

#1. Configure the gateway for static payload type using the following commands on the gateway:

#mgcp behavior g729-variants static-pt

mgcp behavior dynamically-change-codec-pt disable

Now I can hear audio in both directions.

Thanks

Oscar

Cisco Employee

No Audio between IP Phones and PSTN using codec g729

Oscar,


Thanks for posting back the resolution to the forum. (+5)

GP.

982
Views
5
Helpful
5
Replies
CreatePlease login to create content