Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

no audio on inbound pri calls transfered across wan

scenario:

inbound call to gateway1 via PRI circuit. call is answered by attendant, then transferred to remote location. remote ip phone rings, but when remote ip iphone answers call, there is NO AUDIO on either end (dead air). call was normal until transfer.

if call is placed by remote ip phone through gateway1 across wan(same call path, different direction), call has audio in BOTH directions and is normal.

issue is only with inbound calls from gateway1 to remote ip phone.

all routing has been tested and working. seems to be some rtp issue. any help would be great.

gateway1 is a 2821-v using mgcp. point to point t1 and pri interface cards. ip phones are 7940.

5 REPLIES
New Member

Re: no audio on inbound pri calls transfered across wan

These documents will help you to troubleshoot one-way voice issue. In the past, I had used "voice rtp send-recei" to resolve my issue. You might want to doublecheck that H232 is bound to the interface.

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a0080115a52.shtml

http://www.cisco.com/en/US/tech/tk652/tk698/technologies_tech_note09186a008009484b.shtml

HTH,

hieu

New Member

Re: no audio on inbound pri calls transfered across wan

gateway is using MGCP, not h323. also, does not appear to be only a one-way voice issue, but no voice is heard from either party. only stuff i can find is regarding 'mgcp bind' commands. not really sure what these command would do. thanks!

New Member

Re: no audio on inbound pri calls transfered across wan

Can you post the configs of both the local and remote router(without the sensitive info)?

hieu

New Member

Re: no audio on inbound pri calls transfered across wan

local 2821 config

Current configuration : 5870 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

!

boot-start-marker

boot system flash:c2800nm-ipvoicek9-mz.124-11.T.bin

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

clock timezone CST -6

network-clock-participate wic 0

!

!

ip cef

no ip dhcp use vrf connected

!

ip dhcp pool VOICE

!

ip dhcp pool PCPOOL

!

!

no ip domain lookup

multilink bundle-name authenticated

!

isdn switch-type primary-ni

!

voice-card 0

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

controller T1 0/0/0

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

!

class-map match-any AutoQoS-VoIP-RTP-Trust

match ip dscp ef

class-map match-any AutoQoS-VoIP-Control-Trust

match ip dscp cs3

match ip dscp af31

!

!

policy-map AutoQoS-Policy-Trust

class AutoQoS-VoIP-RTP-Trust

priority percent 70

class AutoQoS-VoIP-Control-Trust

bandwidth percent 5

class class-default

fair-queue

!

!

!

!

!

interface GigabitEthernet0/0

description "VLAN 1"

ip address 192.168.0.253 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

description "VLAN 100"

ip address 10.0.2.254 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial0/1/0

ip address 10.10.1.1 255.255.255.0

auto qos voip trust

service-policy output AutoQoS-Policy-Trust

!

ip route 0.0.0.0 0.0.0.0 192.168.0.251

ip route 10.0.3.0 255.255.255.0 10.10.1.2

ip route 192.168.2.0 255.255.255.0 10.10.1.2

!

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

!

control-plane

!

rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS

!

!

voice-port 0/0/0:23

!

voice-port 0/2/0

no echo-cancel enable

timing hookflash-out 500

!

voice-port 0/2/1

signal groundStart

no echo-cancel enable

timing hookflash-out 500

!

ccm-manager redundant-host TSWCCM1

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.0.2.200 10.0.2.201

ccm-manager config

!

mgcp

mgcp call-agent TSWCCM2 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

no mgcp explicit hookstate

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

dial-peer voice 999020 pots

service mgcpapp

port 0/2/0

!

dial-peer voice 999021 pots

service mgcpapp

port 0/2/1

!

!

!

call-manager-fallback

max-conferences 8 gain -6

transfer-system full-consult

!

line con 0

login local

line aux 0

!

scheduler allocate 20000 1000

!

end

New Member

Re: no audio on inbound pri calls transfered across wan

*******************************

*******************************

***

remote 2610 config(for this scenario only involved in routing, not call endpoint)

version 12.3

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname 261001

!

boot-start-marker

boot system flash:c2600-ipvoice-mz.123-8.T4.bin

boot-end-marker

!

!

no network-clock-participate slot 1

no network-clock-participate wic 0

voice-card 1

!

no aaa new-model

ip subnet-zero

ip cef

ip tcp synwait-time 13

!

!

!

ip dhcp pool DATA

!

ip dhcp pool VOICE

!

!

no ftp-server write-enable

isdn switch-type primary-5ess

isdn voice-call-failure 0

!

!

voice call send-alert

voice rtp send-recv

!

!

!

!

!

!

!

!

!

!

ccm-manager fallback-mgcp

ccm-manager redundant-host TSWCCM1

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.0.2.200 10.0.2.201

ccm-manager config

!

!

controller T1 1/0

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

!

controller T1 1/1

framing sf

linecode ami

!

class-map match-any AutoQoS-VoIP-RTP-Trust

match ip dscp ef

class-map match-any AutoQoS-VoIP-Control-Trust

match ip dscp cs3

match ip dscp af31

!

!

policy-map AutoQoS-Policy-Trust

class AutoQoS-VoIP-RTP-Trust

priority percent 70

class AutoQoS-VoIP-Control-Trust

bandwidth percent 5

class class-default

fair-queue

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

description VLAN 1

encapsulation dot1Q 1 native

ip address 192.168.2.254 255.255.255.0

!

interface FastEthernet0/0.100

description VLAN 100

encapsulation dot1Q 100

ip address 10.0.3.254 255.255.255.0

!

interface Serial0/0

ip address 10.10.1.2 255.255.255.0

service-policy output AutoQoS-Policy-Trust

auto qos voip trust

!

interface Serial1/0:23

no ip address

no logging event link-status

isdn switch-type primary-5ess

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.1.1

no ip http server

!

!

snmp-server community public RO

snmp-server enable traps tty

!

!

control-plane

!

rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS

rmon alarm 33333 cbQosCMDropBitRate.1059.1061 30 absolute rising-threshold 1 33333 falling-threshold 0 owner AutoQoS

!

call application alternate DEFAULT

!

!

voice-port 1/0:23

echo-cancel coverage 32

!

mgcp

mgcp call-agent TSWCCM2 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

no mgcp explicit hookstate

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

application mgcpapp

destination-pattern 9T

incoming called-number .

direct-inward-dial

port 1/0:23

!

!

call-manager-fallback

max-conferences 4

ip source-address 192.168.2.254 port 2000

max-ephones 36

max-dn 144

keepalive 10

default-destination 304

!

!

line con 0

line aux 0

!

!

end

********************************

******************************

also, another way to duplicate the problem is to dial into remote router pri transfer to local router across wan, if call is placed on hold, no music on hold is heard by calling party.

426
Views
0
Helpful
5
Replies