Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

No Caller ID on H323 PRI

Hello all,

I am having problems with CUCM not displaing any caller ID information. For all calls, I only see "External Call" and "Uknown Number".

I am running CUCM 6.1.4.2000-2. My gateway is an 2811 running H323 on flash:c2800nm-spservicesk9-mz.123-8.T6.bin.

Here is a debug. I don't see any calling party information??

VG-2811#

.Nov 21 21:49:28.952: ISDN Se0/0/0:23 Q931: RX <- SETUP pd = 8  callref = 0x11D4

        Bearer Capability i = 0x8090A2

                Standard = CCITT

                Transer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98381

                Exclusive, Channel 1

        Progress Ind i = 0x8283 - Origination address is non-ISDN

        Called Party Number i = 0x80, '5959'

                Plan:Unknown, Type:Unknown

.Nov 21 21:49:28.964: ISDN Se0/0/0:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x91D4

        Channel ID i = 0xA98381

                Exclusive, Channel 1

.Nov 21 21:49:29.104: ISDN Se0/0/0:23 Q931: TX -> ALERTING pd = 8  callref = 0x91D4

        Progress Ind i = 0x8188 - In-band info or appropriate now available

.Nov 21 21:49:31.180: ISDN Se0/0/0:23 Q931: TX -> CONNECT pd = 8  callref = 0x91D4

.Nov 21 21:49:31.248: ISDN Se0/0/0:23 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x11D4

.Nov 21 21:49:37.248: %ISDN-6-CONNECT: Interface Serial0/0/0:0 is now connected to unknown

.Nov 21 21:49:40.784: %ISDN-6-DISCONNECT: Interface Serial0/0/0:0  disconnected from unknown , call lasted 9 seconds

.Nov 21 21:49:40.788: ISDN Se0/0/0:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x91D4

        Cause i = 0x8090 - Normal call clearing

.Nov 21 21:49:40.948: ISDN Se0/0/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x11D4

.Nov 21 21:49:40.948: ISDN Se0/0/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x91D4

Below is the config:

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VG-2811

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

clock timezone CDT -5

network-clock-participate wic 0

no network-clock-participate aim 0

no network-clock-participate aim 1

no aaa new-model

ip subnet-zero

!

!

ip cef

ip dhcp excluded-address 10.10.3.1 10.10.3.50

ip dhcp excluded-address 10.10.3.250 10.10.3.254

!

ip dhcp pool IP-Phones

   network 10.10.3.0 255.255.255.0

   option 150 ip 10.10.1.3

   default-router 10.10.3.1

   dns-server 10.10.1.250

!

!

ip domain name yourdomain.com

no ftp-server write-enable

isdn switch-type primary-ni

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice call send-alert

voice call carrier capacity active

voice rtp send-recv

!

voice service voip

h323

!

!

!

!

!

!

!

!

!

!

!

!

!

!

controller T1 0/0/0

framing esf

linecode b8zs

pri-group timeslots 1-24

!

!

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$

ip address 10.10.3.1 255.255.255.0

ip route-cache flow

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.10.3.1

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:23

no ip address

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.3.254

ip route 192.168.5.0 255.255.255.0 10.10.1.10

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

!

!

snmp-server enable traps tty

!

!

!

control-plane

!

!

!

voice-port 0/0/0:23

input gain -4

output attenuation 4

echo-cancel coverage 32

!

voice-port 0/1/0

description OUTGOING FAX

!

voice-port 0/1/1

description GERRIES FAX

!

voice-port 0/1/2

description CARDINAL MODEM

!

voice-port 0/1/3

description MEGAN FAX

!

voice-port 0/3/0

!

voice-port 0/3/1

!

voice-port 0/3/2

!

voice-port 0/3/3

!

!

!

!

dial-peer voice 1 pots

preference 1

destination-pattern .T

progress_ind setup enable 3

progress_ind progress enable 1

incoming called-number .

direct-inward-dial

port 0/0/0:23

forward-digits all

!

dial-peer voice 2000 voip

destination-pattern 2...

progress_ind setup enable 3

session target ipv4:10.10.1.3

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 5959 voip

destination-pattern 5959

progress_ind setup enable 3

session target ipv4:10.10.1.3

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 2099 pots

destination-pattern 2099

incoming called-number 3582099

port 0/1/0

forward-digits 0

!

dial-peer voice 2016 pots

destination-pattern 2016

incoming called-number 3582016

port 0/1/1

forward-digits 0

!

dial-peer voice 2098 pots

destination-pattern 2098

incoming called-number 3582098

port 0/1/2

forward-digits 0

!

dial-peer voice 2018 pots

destination-pattern 2018

incoming called-number 3582018

port 0/1/3

forward-digits 0

!

!

call-manager-fallback

max-conferences 8

limit-dn 7910 1

limit-dn 7935 1

limit-dn 7940 2

limit-dn 7960 4

ip source-address 10.10.3.1 port 2000

max-ephones 24

max-dn 48

!

!

line con 0

login local

line aux 0

line vty 0 4

privilege level 15

login

transport input telnet ssh

line vty 5 15

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

ntp clock-period 17180025

!

end

VG-2811#

3 REPLIES
Hall of Fame Super Silver

No Caller ID on H323 PRI

Looks like the carrier is not sending it to you, have you checked with your service provider if they are sending it to you?

Chris

New Member

No Caller ID on H323 PRI

I haven't called them yet. Is this usually an extra service? Why do you think it's this way to begin with? Also, what should I ask for when i call them up?

Thanks Chris!

Cisco Employee

No Caller ID on H323 PRI

what to ask to service provider?

some service provider charge for the caller id facility. tell them that you are not reciving the caller id. inform them that the isdn set up from service provider is only sending called number and not calling number.

324
Views
0
Helpful
3
Replies