Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

no incoming CUCM calls?

Hello, I can make calls from CUCM registered phones out to the PSTN no problem, however I cannot receive incoming calls from the PSTN.

My CUCM is connected to a 2801 router gateway via a SIP trunk and this gateway communicates with my ITSP via SIP.

I have activated all manner of debugging on the gateway router i.e:

- debug ccsip message

- debug ccsip events

- debug voip ccapi

- debug voip dialpeer

However when I make an call into my network, no debugging messages show up at all (yes, I have activated debugging on my terminal)

I just don't understand why I can call out, but no calls arrive in.

nb. under "voice service voip" - "SIP", I was going to add "session transport TCP" but when I did that, I could not call out, so I ommitted it.

Thanks kindly for any help. Here is my gateway config:

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 2801Router

!

boot-start-marker

boot system flash:c2801-ipvoicek9-mz.151-2.T0a.bin

boot-end-marker

aaa new-model

aaa session-id common

clock timezone nzst 13 0

dot11 syslog

ip source-route

ip dhcp pool DATA_SCOPE

   network 192.168.200.0 255.255.255.0

   default-router 192.168.200.1

   dns-server 8.8.8.8

!        

ip dhcp pool VOICE_SCOPE

   network 192.168.100.0 255.255.255.0

   default-router 192.168.100.1

   option 150 ip 192.168.2.115

!        

ip cef   

ip domain name demo.net

ip name-server 4.2.2.2

no ipv6 cef

multilink bundle-name authenticated

!        

voice service voip

no ip address trusted authenticate

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

sip     

  bind control source-interface FastEthernet0/1

  bind media source-interface FastEthernet0/1

!        

voice class codec 1

codec preference 1 g711alaw

!        

voice translation-rule 1

rule 1 /^9/ //

!        

!        

voice translation-profile Strip9ToGetOut

translate called 1

!        

!        

voice-card 0

!        

crypto pki token default removal timeout 0

!        

crypto pki trustpoint TP-self-signed-2995340181

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2995340181

revocation-check none

!        

!        

crypto pki certificate chain TP-self-signed-2995340181

certificate self-signed 01

  3082024B 308201B4 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 32393935 33343031 3831301E 170D3733 30393038 31363435

  30345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 39393533

  34303138 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100C34D C8ECBB53 E01373A3 2E286B78 2D23042B 1C8588B1 A7861899 BA1C6860

  AE1D7868 2A59E3BC 54D0A457 8FFDE27F C09104E5 C7A429F3 74CD9DA8 4A980366

  675CC27C CDB94838 821CC05F 2C0AC2BC D882C132 6CAA1FA6 6DA740E4 562428B1

  12B741F1 A50C9246 4CC35EDA DEE1D038 3883BB35 A91ABF8B 483E4160 F5FA4B5A

  9A570203 010001A3 73307130 0F060355 1D130101 FF040530 030101FF 301E0603

  551D1104 17301582 13323830 31526F75 7465722E 64656D6F 2E6E6574 301F0603

  551D2304 18301680 14721196 40F3396E 1FE41680 86D31D86 190D8337 FF301D06

  03551D0E 04160414 72119640 F3396E1F E4168086 D31D8619 0D8337FF 300D0609

  2A864886 F70D0101 04050003 818100AF E92F8BC4 19F5E0AB B4718F19 0D86B9CC

  74FB352A 55AD288F 0A0BE12F 3E0D43D2 1B52A07A 466BDD33 9041BCAB 96A99FED

  5E3AC098 D29BC1BD 646D16E4 BAE341EC DA7A5323 0F5B34D9 086B31DA CC770A83

  A4A1D333 519982BA AD8A326C 268B3B93 AE75284F ABE1BE0F 2E488858 0E2D140A

  075FE477 E1C9C006 FEA3945D 617CAE

        quit

!        

!        

license udi pid CISCO2801 sn xxxxxxxxxxx

username xxxx privilege 15 password xxxxxxx

username admin privilege 15 secret 5 xxxxxxxxxxxxxxx.

!        

interface FastEthernet0/0

ip address 192.168.3.50 255.255.255.0

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!        

interface FastEthernet0/1

no ip address

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!        

interface FastEthernet0/1.2

encapsulation dot1Q 2

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!        

interface FastEthernet0/1.99

encapsulation dot1Q 99

ip address 192.168.99.1 255.255.255.0

!        

interface FastEthernet0/1.100

description voice_VLAN

encapsulation dot1Q 100

ip address 192.168.100.1 255.255.255.0

!        

interface FastEthernet0/1.200

description data_VLAN

encapsulation dot1Q 200

ip address 192.168.200.1 255.255.255.0

!        

ip forward-protocol nd

!        

!        

no ip http server

ip http authentication local

no ip http secure-server

ip nat inside source static tcp 192.168.2.115 8443 interface FastEthernet0/0 8443

ip nat inside source static tcp 192.168.2.115 443 interface FastEthernet0/0 443

ip route 0.0.0.0 0.0.0.0 192.168.3.1

!        

logging esm config

!        

!        

tftp-server flash:/phone/7940-7960/P00307020200.bin alias P00307020200.bin

tftp-server flash:/phone/7940-7960/P00307020200.loads alias P00307020200.loads

tftp-server flash:/phone/7940-7960/P00307020200.sb2 alias P00307020200.sb2

tftp-server flash:/phone/7940-7960/P00307020200.sbn alias P00307020200.sbn

!        

!        

control-plane

!        

mgcp fax t38 ecm

!        

!        

dial-peer voice 1 voip

description local_7_Digit_Calling

translation-profile outgoing Strip9ToGetOut

destination-pattern 9[2-9]......

session protocol sipv2

session target ipv4:203.184.16.2

incoming called-number .

voice-class codec 1 

!        

dial-peer voice 2 voip

description international_calling

translation-profile outgoing Strip9ToGetOut

destination-pattern 900T

session protocol sipv2

session target ipv4:203.184.16.2

voice-class codec 1 

!        

dial-peer voice 3 voip

description national_calling

translation-profile outgoing Strip9ToGetOut

destination-pattern 90[34679].......

session protocol sipv2

session target ipv4:203.184.16.2

voice-class codec 1 

!        

dial-peer voice 4 voip

description emergency dialling

destination-pattern [91]11

session protocol sipv2

session target ipv4:203.184.16.2

voice-class codec 1 

!        

dial-peer voice 5 voip

description emergency dialling with prefix

translation-profile outgoing Strip9ToGetOut

destination-pattern 9[91]11

session protocol sipv2

session target ipv4:203.184.16.2

voice-class codec 1 

!        

dial-peer voice 6 voip

description CUCMDialPeer

destination-pattern 6495235567

session protocol sipv2

session target ipv4:192.168.2.115

voice-class codec 1 

dtmf-relay h245-alphanumeric

!        

!        

sip-ua   

authentication username 6495235567 password 7 xxxxxxxxxxx

calling-info pstn-to-sip from number set 6495235567

registrar dns:akl.italk.co.nz:5060 expires 180

sip-server ipv4:xxxxxxxxxxxxxxxx

!        

banner motd ^C

**********************************************

UNAUTHORISED ACCESS IS PROHIBITED

WELCOME TO THE 2801 CME ROUTER

**********************************************

^C       

!        

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

privilege level 15

transport input telnet ssh

!        

scheduler allocate 20000 1000

ntp server 195.43.74.123

end  

1 ACCEPTED SOLUTION

Accepted Solutions

no incoming CUCM calls?

Hi.

This happens probably because you authenticate yoursefl with your provider during an outgoing call, but you are not registering your telephone number correctly

Try to add the following lines and see if it helps:

sip-ua

credentials number 6495235567 username 6495235567 password 7 XXXXXX realm akl.italk.co.nz/6495235567

After that post the output of a show sip-ua register status

HTH

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
2 REPLIES
New Member

Re: no incoming CUCM calls?

Hi Fran,

first of all, does the inbound call arrive at the GW?

Please check with an debug isdn q931

I just quickly checked the config, there are missing some parts:

- you need an inbound dial-peer with direct-inward-dial

- you maybe also need to manipulate your inbound called numbers with an translation rule?

- you also need an dial-peer to send the calls to the CUCM

Can you provide an debug isdn q931 and the extensions on your cucm?

Best regards

Ben

      

PS: some helpful links:

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a008010ae1c.shtml

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080147524.shtml

no incoming CUCM calls?

Hi.

This happens probably because you authenticate yoursefl with your provider during an outgoing call, but you are not registering your telephone number correctly

Try to add the following lines and see if it helps:

sip-ua

credentials number 6495235567 username 6495235567 password 7 XXXXXX realm akl.italk.co.nz/6495235567

After that post the output of a show sip-ua register status

HTH

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
841
Views
0
Helpful
2
Replies
CreatePlease to create content