Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

No outgoing calls on an MGCP gateway

Hi, can anyone please guide me as to what a fault this could be.

I have installed a gateway which is accessed from the voice vlan via a routed link. The router has 2 E1 (Vwic 2MFT G703) connections, one to a remote site, and the other to the PSTN for voice calls. I am getting the same error message when trying to make a voice call ?Resource Unavailable?. If I put the same gateway on the voice vlan with the remote site connections on another router, all work well( this was only carried out for testing purposes to check hardware)

The debug isdn q931 output is below:-

Config on next post

*Dec 6 23:54:58.983: ISDN Se0/1/0:15 Q931: TX -> SETUP pd = 8 callref = 0x0001

Sending Complete

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Calling Party Number i = 0x0081, '01534814831'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '123'

Plan:Unknown, Type:Unknown

*Dec 6 23:54:59.155: ISDN Se0/1/0:15 Q931: RX <- CALL_PROC pd = 8 callref = 0x8001

Channel ID i = 0xA98381

Exclusive, Channel 1

*Dec 6 23:54:59.167: ISDN Se0/1/0:15 Q931: TX -> DISCONNECT pd = 8 callref = 0x0001

Cause i = 0x80AF - Resource unavailable, unspecified

*Dec 6 23:54:59.315: ISDN Se0/1/0:15 Q931: RX <- RELEASE pd = 8 callref = 0x8001

*Dec 6 23:54:59.335: ISDN Se0/1/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x0001

4 REPLIES
New Member

Re: No outgoing calls on an MGCP gateway

Building configuration...

Current configuration : 6762 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname bedjesy2821vg1

!

boot-start-marker

boot system flash:c3845-spservicesk9-mz.124-10a.bin

boot-end-marker

!

card type e1 0 3

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

clock timezone GMT 0

clock summer-time BST recurring last Sun Mar 1:00 last Sun Oct 1:00

network-clock-participate wic 1

network-clock-participate wic 3

ip subnet-zero

!

!

ip cef

!

!

ip domain name xxxxxx

ip host ZJCM01 172.31.1.250

ip host ZJCM02 172.30.1.250

isdn switch-type primary-net5

!

voice-card 0

dspfarm

!

!

voice rtp send-recv

!

!

!

!

!

!

!

!

!

!

!

!

!

controller E1 0/1/0

framing NO-CRC4

pri-group timeslots 1-31 service mgcp

description Connection to PSTN

!

controller E1 0/3/0

channel-group 0 unframed

!

controller E1 0/3/1

shutdown

!

!

!

!

interface GigabitEthernet0/0

description Private LAN

ip address 172.16.2.12 255.255.255.0

duplex auto

speed auto

no keepalive

!

interface Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/1

ip address 192.168.12.1 255.255.255.252

duplex full

speed 10

no keepalive

!

interface FastEthernet0/2/0

switchport access vlan 5

duplex half

speed 10

!

interface FastEthernet0/2/1

!

interface FastEthernet0/2/2

switchport access vlan 150

duplex full

speed 100

!

interface FastEthernet0/2/3

switchport access vlan 150

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial0/3/0:0

description ** London Megastream **

bandwidth 2048

ip address 192.168.11.1 255.255.255.252

!

interface Vlan1

no ip address

!

interface Vlan5

ip address 192.168.12.5 255.255.255.252

delay 150

!

interface Vlan150

ip address 192.168.150.1 255.255.255.248

!

router eigrp 12

redistribute connected

redistribute static

passive-interface GigabitEthernet0/0

passive-interface Serial0/3/0:0

network 10.0.0.0

network 192.168.12.0 0.0.0.3

network 192.168.12.4 0.0.0.3

no auto-summary

!

ip classless

ip route 10.10.0.0 255.255.0.0 172.16.2.253

ip route 10.11.0.0 255.255.0.0 192.168.11.2

ip route 172.30.1.0 255.255.255.0 192.168.150.2

ip route 172.31.1.0 255.255.255.0 192.168.150.2

ip route 192.168.100.0 255.255.255.0 172.16.2.253

ip route 192.168.100.59 255.255.255.255 192.168.150.2

!

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 5 life 86400 requests 10000

!

access-list 10 permit 192.168.100.0 0.0.0.255

access-list 10 permit 10.10.0.0 0.0.255.255

access-list 10 permit 172.16.2.0 0.0.0.255

access-list 10 permit 192.168.12.0 0.0.0.255

access-list 10 permit 10.11.0.0 0.0.255.255

access-list 10 permit any

access-list 11 permit 172.16.2.239

!

!

!

control-plane

!

!

!

voice-port 0/1/0:15

cptone GB

!

ccm-manager redundant-host 172.31.1.250

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 172.31.1.250

ccm-manager config

!

mgcp

mgcp call-agent 172.30.1.250 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp default-package fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface Vlan150

mgcp bind media source-interface Vlan150

!

mgcp profile default

!

!

!

gateway

timer receive-rtp 1200

New Member

Re: No outgoing calls on an MGCP gateway

Hey there, if you look at the debug, 0x80AF is an ISDN cause code specifying that the Call Manager is complaining of this. It appears that it went out on channel 15 on the PRI. How many channels do you have allocated on the gateway as I believe E1 is 30 B and 1 D so if it is not busy, the first call should in theory go out on channel 30 as out of the box, CCM selects from the bottom up which is last to first.

Check to make sure your timeslots on the router is in synch with the telco.

pri-group timeslots 1-14,24 service mgcp (fractional example).

Re: No outgoing calls on an MGCP gateway

What does debug isdn q921 say?

New Member

Re: No outgoing calls on an MGCP gateway

Hey Kelvin, Q921 is L2 which where he is getting Q931 output means L2 is up. If he typed "sh isd stat" from CLI, he would see Multiple Frames Established which validates TEI.

459
Views
0
Helpful
4
Replies