Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

No ringback calling from CUCM to H323 GW

Hi everyone,

In a new instalation, configured on the CUCM version 7.1 a H323 gateway to another vendors voice network. It's working ok in terms of everything except for the NO RINGBACK when calling from a Cisco IP phone to any destination through the H323 Gateway. It works fine the other way around.

Already been here:

http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a0080094c33.shtml

And configured the ToSendH225UserInfoMsg -  Use ANN for Ring Back

...still not working.

Any ideas?

Thanks,

Francisco

Everyone's tags (2)
9 REPLIES
New Member

Re: No ringback calling from CUCM to H323 GW

Hi Francisco,

Could you just confirm that you have configured the following parameters on the voice dial-peers on your H323 gateway?

tone ringback alert-no-PI
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8

It should force the gateway to generate the ringback locally.

Regards,

Nick

Re: No ringback calling from CUCM to H323 GW

Hi Nick,

The H323 Gateway is not a cisco IOS Gateway. I configured it being the other vendors phone gateway IP address and i have no access to it's configuration.

Thanks

New Member

Re: No ringback calling from CUCM to H323 GW

Are you sure that CUCM get the alerting message? It could explain why there is no ringback.

By looking in the SDI traces of the callmanager service, you should see this message from the gateway.

Otherwise, you may want to look on the gateway debugs.

Re: No ringback calling from CUCM to H323 GW

From the traces i see the Alerting message received from the gateway.

I've attached the traces in case you wish to take a look.

Cisco Phone extension 7010 – DDI 222642010

Calls 24403  (9.24403)

H323 Gateway 10.250.96.69

New Member

Re: No ringback calling from CUCM to H323 GW

It seems indeed that we receive an alerting here:

11/16/2010 12:56:09.925 CCM|In  Message -- H225AlertMsg -- Protocol= H225Protocol|<:STANDALONECLUSTER><:10.227.32.130><:SIGNIFICANT><:0040>

I would have expected something like:
Progress Ind i = 0x085088 - In-band info or appropriate now available
To indicate that we had inband info.
You've mentionned that you have set the Send H225 User info Message to "Use ANN for Ring Back".
Can this phone reach the ANN ressources? If you change the annunciator partition to none, do you have the same results?
Regards,
Nicolas

Cisco Employee

Re: No ringback calling from CUCM to H323 GW

Francisco,

The h323 gateway is sending it's h245 address in the h225 Alerting Message. This causes CUCM to negotiate the media stream. You'll need to go back and check with the provider to see if they deliver ringback tone inband. If they don't, then they need to remove the h245 address from the Alerting message so that the CUCM tells the phone to play ringback locally.

-Felipe

Excerpt from CUCM traces:

11/16/2010 13:15:00.327 CCM|{
  h323-uu-pdu
  {
    h323-message-body alerting :
      {
        protocolIdentifier { 0 0 8 2250 0 2 },
        destinationInfo
        {
          vendor
          {
            vendor
            {
              t35CountryCode 61,
              t35Extension 0,
              manufacturerCode 1010
            },
            productId '416C636174656C204F6D6E695043583434 ...'H,
            versionId '31342E32352020'H
          },
          mc FALSE,
          undefinedNode FALSE
        },
        h245Address ipAddress :
          {
            ip '0AFA6045'H,
            port 31000

          },
        callIdentifier
        {
          guid '80FFE420C47521CE05001B020AE3210D'H
        }
      },
    h245Tunneling FALSE
  }|<:STANDALONECLUSTER><:10.227.32.130><:STATE transition=""><:0100>

Re: No ringback calling from CUCM to H323 GW

Thanks Felipe,

Do you know if there's anyway to configure on the CallManager side to ignore that IP information or to force it to play the ringback locally?

Regards,

Francisco

Cisco Employee

Re: No ringback calling from CUCM to H323 GW

I'm not aware of a method in CUCM to do it. Can you check on the h323 gateway/PBX?

-Felipe

New Member

No ringback calling from CUCM to H323 GW

Hi All

I got the same issue, i have resolved this by enabling Outbound FastStart on H323 GW.

Regds

$

3849
Views
0
Helpful
9
Replies
CreatePlease login to create content