Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

No ringbacktone for inbound calls with cucm 8.6

Hi,

we have this problem from many days...

we have two branches with cucm cluster(Publisher and Subscriber) at Head office and cisco untiy.The branches are connected to Head office through MPLS vpn and all the ip phones are registred to publisher located at headoffice.

our setup is like below

                            unity.jpg

HO and BR2 having SIP lines and BR1 has PSTN Lines.

we implement greetings for head office and 2 branches at Headoffice Unity.

when any call comes to headoffice gateway the greetings will be played and call will be diverted to the appropriate extension.everything is fine.

But the problem is when the call comes to Branch gateway and the greetings will be played and the call gets diverted to the IP phone to which the caller dialed the extension. but the caller is not hearing the ringback tone while the extension is ringing. and the caller cannot know whether the extension is ringing or the call got disconnected.

i tried to change the " Send h225 User Information Message"  in service parameters from "Use ANN for Ring Back" to H225 Info for call Progress Tone"

whenever i am changing to  "H225 Info for call Progress Tone" then the branches problem getting solved but Headoffice getting the same problem.

please can anyone help............................


13 REPLIES

No ringbacktone for inbound calls with cucm 8.6

Hi Mohammed.

Can you please share a show run of one of your branches router?

Thanks

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"

No ringbacktone for inbound calls with cucm 8.6

Hi Carlo,

Thankyou for the Response...

here is the Runn config for BR1 Connected to PSTN lines....

------------------------------------------------------------------------------------------------------------


!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
h323
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
codec preference 4 g729br8
!
!
!
voice class h323 1
h225 timeout tcp establish 3
!
!
!
!
!
!
!
!
!
!
!
!

!
!
interface Tunnel100
description " Tunnel JED-RYD "
bandwidth 2048
ip address 10.10.0.1 255.255.255.252
tunnel source 172.31.217.202
tunnel destination 172.31.3.18
!
interface FastEthernet0/0
description DAMMAM Local LAN
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.20
description JEDDAH Local LAN
encapsulation dot1Q 20
ip address 192.168.20.5 255.255.255.0
!
interface FastEthernet0/0.21
description JEDDAH VOICE VLAN
encapsulation dot1Q 21
ip address 192.168.21.5 255.255.255.0
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.21.5
!
interface FastEthernet0/1
ip address 172.31.217.202 255.255.255.252
duplex auto
speed auto
!
router eigrp 200
network 10.10.0.0 0.0.0.3
network 192.168.20.0
network 192.168.21.0
no auto-summary
!
router bgp 65412
no synchronization
bgp log-neighbor-changes
neighbor 172.31.217.201 remote-as 65000
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.20.1
ip route 192.168.20.50 255.255.255.255 192.168.20.1
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
!
!
control-plane
!
!
!
voice-port 0/0/0
supervisory disconnect dualtone mid-call
no battery-reversal
input gain -3
output attenuation -3
echo-cancel coverage 32
cptone BE
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 500
timing guard-out 300
timing sup-disconnect 50
connection plar opx 2050
impedance complex2
description STC
caller-id alerting dsp-pre-allocate
!
voice-port 0/0/1
supervisory disconnect dualtone mid-call
no battery-reversal
input gain -3
output attenuation -3
echo-cancel coverage 32
cptone BE
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 500
timing guard-out 300
timing sup-disconnect 50
connection plar opx 2050
impedance complex2
description STC
caller-id alerting dsp-pre-allocate
!
voice-port 0/0/2
supervisory disconnect dualtone mid-call
no battery-reversal
input gain -3
output attenuation -3
echo-cancel coverage 32
cptone BE
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 500
timing guard-out 300
timing sup-disconnect 50
connection plar opx 2050
impedance complex2
description STC
caller-id alerting dsp-pre-allocate
!
voice-port 0/0/3
supervisory disconnect dualtone mid-call
no battery-reversal
input gain -3
output attenuation -3
echo-cancel coverage 32
cptone BE
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 500
timing guard-out 300
timing sup-disconnect 50
connection plar opx 2050
impedance complex2
description STC
caller-id alerting dsp-pre-allocate
!
voice-port 0/2/0
no battery-reversal
input gain -3
output attenuation -3
echo-cancel coverage 32
cptone BE
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
connection plar 2022
shutdown
impedance complex2
description STC
!
voice-port 0/2/1
no battery-reversal
input gain -3
output attenuation -3
echo-cancel coverage 32
cptone BE
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
shutdown
impedance complex2
description STC
!
voice-port 0/3/0
supervisory disconnect dualtone mid-call
no battery-reversal
input gain -3
output attenuation -3
echo-cancel coverage 32
cptone BE
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 500
timing guard-out 300
timing sup-disconnect 50
connection plar opx 2050
impedance complex2
description STC
caller-id alerting dsp-pre-allocate
!
voice-port 0/3/1
supervisory disconnect dualtone mid-call
no battery-reversal
input gain -3
output attenuation -3
echo-cancel coverage 32
cptone BE
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 500
timing guard-out 300
timing sup-disconnect 50
connection plar opx 2050
impedance complex2
description STC
caller-id alerting dsp-pre-allocate
!
voice-port 0/3/2
supervisory disconnect dualtone mid-call
no battery-reversal
input gain -3
output attenuation -3
echo-cancel coverage 32
cptone BE
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 500
timing guard-out 300
timing sup-disconnect 50
connection plar opx 2050
impedance complex2
description STC
caller-id alerting dsp-pre-allocate
!
voice-port 0/3/3
supervisory disconnect dualtone mid-call
no battery-reversal
input gain -3
output attenuation -3
echo-cancel coverage 32
cptone BE
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 500
timing guard-out 300
timing sup-disconnect 50
connection plar opx 2050
impedance complex2
description STC
caller-id alerting dsp-pre-allocate
!
!
!
sccp local FastEthernet0/0.21
sccp ccm 192.168.12.190 identifier 1 priority 1 version 5.0.1
sccp ccm 192.168.12.189 identifier 2 priority 2 version 5.0.1
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 1 register CONFJEDRAW
associate profile 2 register TRNJED
associate profile 3 register MTPJED
switchover method immediate
switchback method immediate
switchback interval 15
!
dspfarm profile 2 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
maximum sessions 2
associate application SCCP
!
dspfarm profile 1 conference
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
shutdown
!
dspfarm profile 3 mtp
codec g729r8
maximum sessions software 250
associate application SCCP
shutdown
!
!
dial-peer voice 1 pots
!
dial-peer voice 1000 voip
description To CallManager - SBWPMPUB
destination-pattern [1-5]...
progress_ind progress enable 8
voice-class codec 1
voice-class h323 1
session target ipv4:192.168.12.190
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 9001 pots
description ** 02-6140294(outgoing) **
destination-pattern [^2].T
port 0/0/1
!
dial-peer voice 9002 pots
description ** 02-6140295(outgoing) **
destination-pattern [^2].T
port 0/0/2
!
dial-peer voice 9003 pots
description ** 02-6140296(outgoing) **
destination-pattern [^2].T
port 0/0/3
!
dial-peer voice 9004 pots
description ** 02-6140293(outgoing) **
destination-pattern [^2].T
port 0/0/0
!
dial-peer voice 290 pots
incoming called-number .
direct-inward-dial
!
dial-peer voice 9006 pots
description ** 02-6529323(local) **
destination-pattern [^0].T
port 0/3/0
!
dial-peer voice 9010 pots
description ** 02-6578249(local) **
destination-pattern [^0].T
port 0/3/1
!
dial-peer voice 9011 pots
description "to pstn service"
shutdown
destination-pattern 0.T
port 0/3/3
!
dial-peer voice 9009 pots
description "to pstn service"
shutdown
destination-pattern [^0].T
port 0/3/2
!
dial-peer voice 9005 pots
destination-pattern .T
!
dial-peer voice 1001 voip
description To CallManager - Subscriber
destination-pattern [1-5]...
progress_ind progress enable 8
voice-class codec 1
voice-class h323 1
session target ipv4:192.168.12.189
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 1002 voip
description " TO Unity Greetings"
destination-pattern 2050
progress_ind progress enable 8
voice-class codec 1
voice-class h323 1
session target ipv4:192.168.12.190
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 1003 voip
description " TO Unity Greetings"
destination-pattern 2050
progress_ind progress enable 8
voice-class codec 1
voice-class h323 1
session target ipv4:192.168.12.189
dtmf-relay h245-alphanumeric
no vad

No ringbacktone for inbound calls with cucm 8.6

Hello Mohamed

Please try first:-

On gateway

dial-peer voice 1001 voip

progress_ind setup enable 3

Then

* In Cisco CallManager Administration, select Service > Service

Parameter.

* Select the correct server from the drop-down list.

* Set the service to Cisco CallManager.

* In the Send H225 User Info Message field, under the Cluster Wide

Parameters (Device - H323) section, select H225 Info for Ring Back.

* Reset the H.323 voice gateway.

Thank you

please rate all useful infomration

No ringbacktone for inbound calls with cucm 8.6

Hi Islam,

i tried with that but no luck, the problem is same.

My BR2 branch gateway is configured as SIP trunk and that is also having the same issue.

whenever i am changing Send h225 User Information Message  to H225 Info for call Progress Tone from Use ANN for Ring Back then the caller calling to branch can hear the ringback tone but the caller calling to headoffice cannot hear the ringback.

VIP Super Bronze

No ringbacktone for inbound calls with cucm 8.6

Mohammed,

1. Do you get ringback for normal calls from BR2 to ip phones

2. Are you seeing this issue only to BR2 when calls go to Unity and then to IP Phones?

I dont see how that paremeter  will help you. Its for H323 protocol and wont affect sip calls..

Does your BR2 has ANN i its MRGL?

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

No ringbacktone for inbound calls with cucm 8.6

Hi aokanlawon,

Thankyou for reply,

i am getting the ringback for internal calls, i.e IP to IP

the issue is with BR1 and BR2 both branches, call goes to untiy and diverted to extension dialed, but no ringback to caller

yes the issue is with h323 gateway and siptrunk both but not headoffice.

yes BR2 is having ANN configured in MRGL

VIP Super Bronze

No ringbacktone for inbound calls with cucm 8.6

Can you send me a sh run og BR2 gateway. Can you also send me debug ccsip messages from BR2..include calling called number

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Re: No ringbacktone for inbound calls with cucm 8.6

sh run and cdebug ccsip messages are attached

calling number 0542014824

called number 8062300

Re: No ringbacktone for inbound calls with cucm 8.6

justnow i tried to collect ccsip for onemore call , i got the ringbacktone but previous calls didn't gave me ringback           

attaching ccsip for the call in which i got ringbacktone...

VIP Super Bronze

No ringbacktone for inbound calls with cucm 8.6

Can you get the CUCM trace for the two calls? Use RTMT to collect the trace for the period you placed these two calls. To do this you first of all need to ensure your trace setting is set to detailed..

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Re: No ringbacktone for inbound calls with cucm 8.6

Attaching CUCM traces for two calls

calling number 0542014824

called number 8062300 ext 1200

                      8062300 ext 1252

but both calls i received ringback...

VIP Super Bronze

No ringbacktone for inbound calls with cucm 8.6

OK...The last three calls you have ringback. We need CUCM traces for calls that you dont get ringback on..

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Re: No ringbacktone for inbound calls with cucm 8.6

Hi aokanlawon,

here are the traces attached of the calls with no ringback,but these calls are made to br1 which is h323 gateway.

512
Views
0
Helpful
13
Replies