Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Not Peering Cisco 2911 Router as IP PBX with Non Cisco (Grandstreem) IP PBX.

Hi

I have Cisco 2911 router as a IP PBX. 4 IP Phones 7960 are registered on it with CME. I would like to peer this Cisco 2911 router with Non Cisco (Grandstreem) non modular IP PBX. Both side I am using broadband internet with static IP address. I have done dial-peer configuration both side by targeting ip address of each other.  Non Cisco IP PBX is connected with dsl home router and port is forwarded on it to access pbx from outside LAN. Cisco 2911 router is connected directly with broadband by installing adsl card on it. 

The following configurations are done on Cisco router. Can anyone suggest me anything why cisco router is not peering with another PBX? Dial peer configuration is mentioned below.

 

 


!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.1.1 10.10.1.10
ip dhcp excluded-address 10.15.1.1 10.15.1.10
!
ip dhcp pool DATA
 network 10.10.1.0 255.255.255.0
 default-router 10.10.1.1 
!
ip dhcp pool VOICE
 network 10.15.1.0 255.255.255.0
 default-router 10.15.1.1 
 option 150 ip 10.15.1.1 
!
!
no ip domain lookup
ip name-server 78.143.192.10
ip name-server 78.143.192.20
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type basic-net3
!
!
trunk group ext
!
crypto pki token default removal timeout 0
!
!
voice-card 0
 codec complexity high
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 redirect ip2ip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  h225 timeout ntf 500
  call preserve 
  h245 caps mode restricted
 modem passthrough nse codec g711ulaw
 sip
  bind control source-interface GigabitEthernet0/1.15
  bind media source-interface GigabitEthernet0/1.15
  registrar server expires max 3600 min 3600
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g729r8
 codec preference 4 g722-64
 codec preference 5 g722-56
 codec preference 6 g722-48
 codec preference 7 clear-channel
!
voice class h323 1
  h225 timeout tcp establish 3
!
!
voice register global
 mode cme
 source-address 10.15.1.1 port 5060
 max-dn 20
 max-pool 10
 load 7960-7940 P0S3-08-9-00
 authenticate register
 authenticate realm all
 call-forward system redirecting-expanded
 tftp-path flash:
 create profile sync 0004723960543943
 network-locale GB
 network-locale 1 GB
 network-locale 2 GB
!
voice register dn  1
 number 5000
 call-forward b2bua busy 5002  
 allow watch
 name SIP 1
!
voice register dn  3
 number 5002
 call-forward b2bua busy 5003  
 allow watch
 name SIP 3
!
voice register dn  4
 number 5003
 call-forward b2bua busy 5000  
 allow watch
 name SIP 4
!
voice register pool  1
 id mac 0003.6B54.BCD9
 type 7960
 number 1 dn 1
 dtmf-relay sip-notify
 username 5000 password 123abc!
 no call-waiting
 codec g711ulaw
!
voice register pool  3
 id mac 0002.B9AF.C0F7
 type 7960
 number 1 dn 3
 dtmf-relay sip-notify
 username 5002 password 123abc!
 no call-waiting
 codec g711ulaw
!
voice register pool  4
 id mac 0003.6B75.A91C
 type 7960
 number 1 dn 4
 dtmf-relay sip-notify
 username 5003 password 123abc!
 no call-waiting
 codec g711ulaw
!
voice hunt-group 1 sequential
 final 5003
 list 5000,5002
 timeout 20 
 pilot 5900 
!
!
!
!
!
license udi pid CISCO2911/K9 sn FCZ163379BR
license boot module c2900 technology-package securityk9
license boot module c2900 technology-package uck9
license boot module c2900 technology-package datak9
hw-module pvdm 0/0
!
!
!
username redoq privilege 15 secret 4 RItztkF0kItnl6GrGfyp9UBfMwc6PeNSfVkMYePCEkY
!
redundancy
!
!
!
!
controller VDSL 0/1/0
!

!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 1.1.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.1
 encapsulation dot1Q 1
 ip address 10.1.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/1.10
 encapsulation dot1Q 10 native
 ip address 10.10.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/1.15
 encapsulation dot1Q 15
 ip address 10.15.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface BRI0/0/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn calling-number RedoQ
 isdn supp-service name calling
 isdn static-tei 0
!
interface BRI0/0/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn supp-service name calling
 isdn static-tei 0
!
interface ATM0/1/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no atm ilmi-keepalive
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface Ethernet0/1/0
 no ip address
 no fair-queue
!
interface Dialer0
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname xxxxxxx@hg70.btclick.com
 ppp chap password 0 redoqinfinity1
 no cdp enable
!
!
!
router eigrp 100
 network 1.0.0.0
 network 10.0.0.0
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 36000 requests 10000
ip http path flash:
!
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source list 2 interface Dialer0 overload
ip nat inside source list 3 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 1 permit 1.0.0.0 0.255.255.255
access-list 2 permit 10.0.0.0 0.255.255.255
access-list 3 permit any
!
!
!
!
!
tftp-server flash:OS79XX.txt
tftp-server flash:P003-08-9-00.bin
tftp-server flash:P003-08-9-00.sbn
tftp-server flash:P0S3-08-9-00.loads
tftp-server flash:P0S3-08-9-00.sb2
!
control-plane
!
!
voice-port 0/0/0
 input gain 4
 compand-type a-law
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar 5900
 bearer-cap Speech
!
voice-port 0/0/1
 input gain 4
 compand-type a-law
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar 5900
 bearer-cap Speech
!
voice-port 0/2/0
 supervisory disconnect dualtone pre-connect
 supervisory answer dualtone sensitivity high
 no battery-reversal
 soft-offhook
 input gain 4
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar opx 5000
 impedance complex2
 bearer-cap Speech
 caller-id enable
!
voice-port 0/2/1
 supervisory disconnect dualtone pre-connect
 supervisory answer dualtone sensitivity high
 no battery-reversal
 soft-offhook
 input gain 4
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar opx 5000
 impedance complex2
 bearer-cap Speech
 caller-id enable
!
!
!
mgcp profile default
!
!
dial-peer voice 1 pots
 description *** emergency 999 ***
 destination-pattern 999
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 port 0/0/0
 forward-digits all
!
dial-peer voice 3 pots
 description ** E1 PRI pots dial-peer **
 destination-pattern 07412626634
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 incoming called-number .
 no digit-strip
 direct-inward-dial
 port 0/0/0
!
dial-peer voice 11 pots
 description *** emergency 999 ***
 destination-pattern 999
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 port 0/0/1
 forward-digits all
!
dial-peer voice 31 pots
 description ** E1 PRI pots dial-peer **
 destination-pattern 07412626634
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 incoming called-number .
 no digit-strip
 direct-inward-dial
 port 0/0/1
!
dial-peer voice 100 pots
 description *** Services ***
 destination-pattern 0[1-6]T
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/0
!
dial-peer voice 101 pots
 description *** Services ***
 destination-pattern 0[1-6]T
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/1
!
dial-peer voice 5999 voip
 description ** cue voicemail pilot number **
 destination-pattern 5999
 session protocol sipv2
 session target ipv4:10.15.1.2
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 9281 pots
 destination-pattern [2-8].....
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/1
!
dial-peer voice 9282 pots
 destination-pattern [2-8].....
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/0
!
dial-peer voice 800 pots
 description *** Customer Care Services ***
 destination-pattern 08.........
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/0
!
dial-peer voice 801 pots
 description *** Customer Care Services Services ***
 destination-pattern 08.........
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/1
!
dial-peer voice 1000 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.1
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 2001 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.11:5060
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 2002 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.1:5060
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 2003 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.12:5060
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 2004 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.13:5060
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 2006 voip
 voice cut-through alert
 destination-pattern 5...
 b2bua
 session protocol sipv2
 session target ipv4:122.163.9.151
 dtmf-relay sip-notify
 dtmf-interworking standard
 codec g722-64
 no vad
!
dial-peer voice 2005 voip
 destination-pattern 1...
 session protocol sipv2
 session target ipv4:122.163.9.151
 dtmf-relay sip-notify
 codec g722-64
 no vad

!
!
presence
 presence call-list
!
!
!
gatekeeper
 shutdown
!

 

 

 

SH IP INT BRIEF
!
Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down    
GigabitEthernet0/0         1.1.1.1         YES NVRAM  up                    up      
GigabitEthernet0/1         unassigned      YES NVRAM  up                    up      
GigabitEthernet0/1.1       10.1.1.1        YES NVRAM  up                    up      
GigabitEthernet0/1.10      10.10.1.1       YES NVRAM  up                    up      
GigabitEthernet0/1.15      10.15.1.1       YES NVRAM  up                    up      
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down    
BRI0/0/0                   unassigned      YES unset  up                    up      
BRI0/0/1                   unassigned      YES unset  up                    up      
ATM0/1/0                   unassigned      YES NVRAM  up                    up      
Ethernet0/1/0              unassigned      YES NVRAM  down                  down    
BRI0/0/0:1                 unassigned      YES unset  down                  down    
BRI0/0/0:2                 unassigned      YES unset  down                  down    
BRI0/0/1:1                 unassigned      YES unset  down                  down    
BRI0/0/1:2                 unassigned      YES unset  down                  down    
Dialer0                    86.169.2.159    YES IPCP   up                    up      
NVI0                       1.1.1.1         YES unset  up                    up      
Virtual-Access1            unassigned      YES unset  up                    up      
Virtual-Access2            unassigned      YES unset  up                    up      

 

Regards
 

8 REPLIES

Hi.Please activate a debug

Hi.

Please activate a debug ccsip messages and try to call a Grandstream extension from a Cisco Phone.

After that please post the output.

 

 

Thanks

 

 

Regards

 

 

Carlo

 

Please rate all helpful posts "The more you help the more you learn"
New Member

I have got extension 1001 on

I have got extension 1001 on grandstreem PBX. Please fing debug ccsip log below

.Aug 28 16:01:17.675: //-1/xxxxxxxxxxxx/SIP/Info/HandleUdpIPv4SocketReads: Msg enqueued for SPI with IP addr: [10.15.1.12]:50144, local_address:[10.15.1.1]
.Aug 28 16:01:17.675: //-1/xxxxxxxxxxxx/SIP/Info/ccsip_process_sipspi_queue_event: ccsip_spi_get_msg_type returned: 2 for event 1
.Aug 28 16:01:17.675: //-1/xxxxxxxxxxxx/SIP/Transport/sipTransportProcessNWNewConnMsg: context=0x0
.Aug 28 16:01:17.675: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received: 
INVITE sip:1001@10.15.1.1 SIP/2.0
Via: SIP/2.0/UDP 10.15.1.12:5060;branch=z9hG4bK1875a3a0
From: "SIP 3" <sip:5002@10.15.1.1>;tag=0002b9afc0f70004418f2896-6742faf0
To: <sip:1001@10.15.1.1>
Call-ID: 0002b9af-c0f70004-4c6b0c1f-0c0428cd@10.15.1.12
Max-Forwards: 70
CSeq: 101 INVITE
User-Agent: Cisco-CP7960G/8.0
Contact: <sip:5002@10.15.1.12:5060;user=phone;transport=udp>
Expires: 180
Accept: application/sdp
Allow: ACK,BYE,CANCEL,INVITE,NOTIFY,OPTIONS,REFER,REGISTER,UPDATE
Content-Length: 295
Content-Type: application/sdp
Content-Disposition: session;handling=optional
 
 

Hi.In your config, dial-peer

Hi.

In your config, dial-peer voice 2005 voip is selecting g722 as preferred codec while calling phone is using g711.

Please modify that dialpeer with codec g711ulaw and see if it makes the difference.

 

HTH

 

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
New Member

Hi,I did it. Still same. I

Hi,

I did it. Still same. I think packets are not out to public IP. On the phone screen "Proceeding (in 100)" and few second redirecting. 

Find debug message after codec change.  

 

 
.Aug 28 16:52:59.575: //-1/xxxxxxxxxxxx/SIP/Transport/sipInstanceHandleConnAgeing: Holder=0x31F9412C Connection=0x3140BE30, addr=10.15.1.11, port=5060, connid=2 has been REFRESHED
.Aug 28 16:52:59.575: //-1/xxxxxxxxxxxx/SIP/Transport/sipTransportSetAgeingTimer: Aging timer initiated for holder=0x31F9412C,addr=10.15.1.11
.Aug 28 16:53:00.595: //-1/xxxxxxxxxxxx/SIP/Info/HandleUdpIPv4SocketReads: Msg enqueued for SPI with IP addr: [10.15.1.12]:50144, local_address:[10.15.1.1]
.Aug 28 16:53:00.595: //-1/xxxxxxxxxxxx/SIP/Info/ccsip_process_sipspi_queue_event: ccsip_spi_get_msg_type returned: 2 for event 1
.Aug 28 16:53:00.595: //-1/xxxxxxxxxxxx/SIP/Transport/sipTransportProcessNWNewConnMsg: context=0x0
.Aug 28 16:53:00.595: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received: 
INVITE sip:1001@10.15.1.1 SIP/2.0
Via: SIP/2.0/UDP 10.15.1.12: 296
Content5060;branch=z9hG4bK0abb24e8
From: "SIP 3" <sip:5002@10.15.1.1>;tag=0002b9afc0f70005613060f7-08e58cd4
To: <sip:1001@10.15.1.1>
Call-ID: 0002b9af-c0f70005-55aac6b7-059109f9@10.15.1.12
Max-Forwards: 70
CSeq: 101 INVITE
User-Agent: Cisco-CP7960G/8.0
Contact: <sip:5002@10.15.1.12:5060;user=phone;transport=udp>
Expires: 180
Accept: application/sdp
Allow: ACK,BYE,CANCEL,INVITE,NOTIFY,OPTIONS,REFER,REGISTER,UPDATE
Content-Length:-Type: application/sdp
Content-Disposition: session;handling=optional
 
v=0
o=Cisco-SIPUA 14144 0 IN IP4 10.15.1.12
s=SIP Call
t=0 0
m=audio 18846 RTP/AVP 0 8 13 18 101
c=IN IP4 10.15.1.12
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:13 CN/8000
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=sendrecv
 
 
 
 
Regards
New Member

Hi In the above debug ccsip

Hi 

In the above debug ccsip log, call is going to 1001@10.15.1.1. It should go to 1001@122.163.84.55 as 1001 extension is available on remote IP PBX (grandsim ). 

 

 

Regards

New Member

Hii just found that I am not

Hi

i just found that I am not able to ping the ip of non cisco PBX. but it is pinging from non cisco pbx to cisco 2911 router dialer0 interface public ip address. 

If I try to do extended ping from dialer0 interface to other public ip address then it shows success rate 0. But I am able to access internet through this router

Any anyone suggest the solutio  of it plz?

 

Regards

 

New Member

Hi Now it has completed

Hi 

Now it has completed peering each other. Pinging each others public ip was successful. The mistake was the following:

sip
  bind control source-interface GigabitEthernet0/1.15
  bind media source-interface GigabitEthernet0/1.15

As soon as I negate above commands on Cisco 2911 as PBX it started peering with remote Grandsim PBX.  

Can Anyone discuss how the bind interface command was stoping it to peer with another PBX?

 

Regards

New Member

HiI found solution of it.

Hi

I found solution of it. Bind port was on fastethernet 0/1.15. It was supposed to be on  Dialer0 interface coz it has public ip address

 

Thank You Guys

 

Regards.

 

349
Views
0
Helpful
8
Replies
CreatePlease login to create content