Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

One-way-Audio, What should the RTP source address be set as?

We have a Callmanager 6.x deployment performed by an engineer that struggled with the task, so all is suspect.

We have a problem with frequent one-way audio when calling an external number.

Packet captures reveal that we are sending our voice GW’s internal address in the RTP header.

This seems in keeping with the “h323-gateway voip bind srcaddr 172.0.1.252” statement in the FA 0/0 int (internal LAN)

The question is: What should the header contain as the source address? The External address of the GW I am thinking?

If not this statement is there a missing NAT function?

Thanks in advance!

Ken

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname ISS_2811_voice_gw

!

boot-start-marker

boot system flash:c2800nm-spservicesk9-mz.124-15.T9.bin

boot-end-marker

!

! card type command needed for slot/vwic-slot 0/0

logging buffered 51200 warnings

!

no aaa new-model

clock timezone Pacific -8

clock summer-time Pacific date Apr 6 2003 2:00 Oct 26 2003 2:00

dot11 syslog

!

!

ip cef

!

!

ip domain name xxxx.com

multilink bundle-name authenticated

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service h450.3

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

h323

  h225 h245-address on-connect

!

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw

!

!

!

voice class h323 222

h225 timeout tcp establish 3

  h225 h245-address on-connect

  no h225 h245-address on-progress

  no h225 h245-address on-alert

  h225 h245-address facility

  h225 h245-address progress

  h225 h245-address sync

  no h225 h245-address listen-on-setup

  no h225 h245-address on-setup

  telephony-service ccm-compatible

  ccm-compatible

!

!

!

!

!

!

!

!

!

!

!

!

crypto pki trustpoint TP-self-signed-3792167899

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3792167899

revocation-check none

rsakeypair TP-self-signed-3792167899

!

!

crypto pki certificate chain TP-self-signed-3792167899

certificate self-signed 01

-    SNIP -

!

!

username administrator privilege 15 secret 5 xxxxxxxxxxxxxxxxxxxxxxxxx

archive

log config

  hidekeys

!

!

!

class-map match-any SDM-Transactional-1

match  dscp af21

match  dscp af22

match  dscp af23

class-map match-any SDM-Signaling-1

match  dscp cs3

match  dscp af31

class-map match-any SDM-Routing-1

match  dscp cs6

class-map match-any SDM-Voice-1

match  dscp ef

class-map match-any SDM-Management-1

match dscp cs2

!

!

policy-map SDM-QoS-Policy-1

class SDM-Voice-1

  priority percent 50

class SDM-Signaling-1

  bandwidth percent 5

class SDM-Routing-1

  bandwidth percent 5

class SDM-Management-1

  bandwidth percent 5

class SDM-Transactional-1

  bandwidth percent 5

class class-default

  fair-queue

  random-detect

!

!

!

!

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$

ip address 172.0.1.252 255.255.255.0

ip accounting output-packets

ip nat inside

no ip virtual-reassembly

duplex full

speed 100

h323-gateway voip interface

h323-gateway voip bind srcaddr 172.0.1.252

service-policy output SDM-QoS-Policy-1

!

interface FastEthernet0/1

description $ETH-WAN$

bandwidth 4000

bandwidth receive 20000

ip address 75.151.xxx.xxx 255.255.255.240

ip accounting output-packets

ip nat outside

no ip virtual-reassembly

duplex auto

speed auto

service-policy output SDM-QoS-Policy-1

!

router eigrp 255

network 172.0.1.0 0.0.0.255

auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 75.151.115.142 permanent

ip route 216.82.224.202 255.255.255.255 75.151.115.142

ip route 216.82.225.202 255.255.255.255 75.151.115.142

!

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat pool VOICE 75.151.xxx.xxx 75.151.xxx.xxx netmask 255.255.255.0

ip nat inside source list 1 pool VOICE overload

ip nat inside source static 172.0.1.1 75.151.115.130

!

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 10.1.0.0 0.0.0.255

access-list 1 permit 10.0.1.0 0.0.0.255

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 permit 192.168.0.0 0.0.0.255

access-list 1 permit 172.0.1.0 0.0.0.255

access-list 1 permit 172.0.2.0 0.0.0.255

access-list 1 permit 172.0.254.0 0.0.0.255

access-list 1 permit 10.0.2.0 0.0.0.255

access-list 2 remark SDM_ACL Category=2

access-list 2 permit 192.168.0.0 0.0.0.255

access-list 2 permit 172.0.1.0 0.0.0.255

access-list 23 remark SDM_ACL Category=16

access-list 23 permit 10.1.0.0 0.0.0.255

access-list 23 permit 10.10.10.0 0.0.0.7

access-list 23 permit 172.0.1.0 0.0.0.255

access-list 23 permit 10.0.1.0 0.0.0.255

access-list 100 remark Auto generated by SDM Management Access feature

access-list 100 remark SDM_ACL Category=1

access-list 100 permit tcp 10.1.0.0 0.0.0.255 host 172.0.1.252 eq telnet

access-list 100 permit tcp 10.0.1.0 0.0.0.255 host 172.0.1.252 eq telnet

access-list 100 permit tcp 10.1.0.0 0.0.0.255 host 172.0.1.252 eq 22

access-list 100 permit tcp 10.0.1.0 0.0.0.255 host 172.0.1.252 eq 22

access-list 100 permit tcp 10.1.0.0 0.0.0.255 host 172.0.1.252 eq www

access-list 100 permit tcp 10.0.1.0 0.0.0.255 host 172.0.1.252 eq www

access-list 100 permit tcp 10.1.0.0 0.0.0.255 host 172.0.1.252 eq 443

access-list 100 permit tcp 10.0.1.0 0.0.0.255 host 172.0.1.252 eq 443

access-list 100 permit tcp 10.1.0.0 0.0.0.255 host 172.0.1.252 eq cmd

access-list 100 permit tcp 10.0.1.0 0.0.0.255 host 172.0.1.252 eq cmd

access-list 100 deny   tcp any host 172.0.1.252 eq telnet

access-list 100 deny   tcp any host 172.0.1.252 eq 22

access-list 100 deny   tcp any host 172.0.1.252 eq www

access-list 100 deny   tcp any host 172.0.1.252 eq 443

access-list 100 deny   tcp any host 172.0.1.252 eq cmd

access-list 100 deny   udp any host 172.0.1.252 eq snmp

access-list 100 permit ip any any

access-list 101 remark SDM_ACL Category=1

access-list 101 permit ip 10.1.0.0 0.0.0.255 any

access-list 101 permit ip 10.10.10.0 0.0.0.7 any

access-list 101 permit ip 172.0.1.0 0.0.0.255 any

access-list 101 permit ip 10.0.1.0 0.0.0.255 any

access-list 102 remark SDM_ACL Category=1

access-list 102 permit ip 10.1.0.0 0.0.0.255 any

access-list 102 permit ip 10.10.10.0 0.0.0.7 any

access-list 102 permit ip 172.0.1.0 0.0.0.255 any

access-list 102 permit ip 10.0.1.0 0.0.0.255 any

!

!

!

control-plane

!

!

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

ring frequency 50

!

voice-port 0/2/0

timing hookflash-out 50

connection plar 8250

caller-id enable

!

voice-port 0/2/1

timing hookflash-out 50

connection plar 8250

caller-id enable

!

voice-port 0/2/2

timing hookflash-out 50

connection plar 8250

caller-id enable

!

voice-port 0/2/3

timing hookflash-out 50

connection plar 8250

caller-id enable

!

voice-port 0/3/0

!

voice-port 0/3/1

!

voice-port 0/3/2

!

voice-port 0/3/3

!

ccm-manager fallback-mgcp

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 172.0.1.1 

ccm-manager config

!

mgcp

mgcp call-agent 172.0.1.1 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface FastEthernet0/0

mgcp bind media source-interface FastEthernet0/0

!

mgcp profile default

!

sccp local FastEthernet0/0

sccp ccm 172.0.1.1 identifier 1 priority 1

sccp ip precedence 1

sccp

!

sccp ccm group 1

bind interface FastEthernet0/0

associate ccm 1 priority 1

associate profile 2 register CFB0022900cc0a0

associate profile 1 register MTP0022900cc0a0

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 4

associate application SCCP

!

!

dial-peer voice 999010 pots

service mgcpapp

port 0/1/0

!

dial-peer voice 999011 pots

service mgcpapp

port 0/1/1

!

dial-peer voice 999012 pots

service mgcpapp

port 0/1/2

!

dial-peer voice 999013 pots

service mgcpapp

port 0/1/3

!

dial-peer voice 1 pots

description ** incoming dial peer **

incoming called-number .%

direct-inward-dial

port 0/2/0

!

dial-peer voice 2 pots

description ** incoming dial peer **

incoming called-number .%

direct-inward-dial

port 0/2/1

!

dial-peer voice 3 pots

description ** incoming dial peer **

incoming called-number .%

direct-inward-dial

port 0/2/2

!

dial-peer voice 4 pots

description ** incoming dial peer **

incoming called-number .%

direct-inward-dial

port 0/2/3

!

dial-peer voice 4251 pots

description ** FXO pots dial-peer **-Emergency dial-peer

destination-pattern 9911

port 0/2/0

forward-digits 3

!

dial-peer voice 4252 pots

description ** FXO pots dial-peer **-Emergency dial-peer

preference 1

destination-pattern 9911

port 0/2/1

forward-digits 3

!

dial-peer voice 4253 pots

description ** FXO pots dial-peer **-Emergency dial-peer

preference 2

destination-pattern 9911

port 0/2/2

forward-digits 3

!

dial-peer voice 4254 pots

description ** FXO pots dial-peer **-Emergency dial-peer

preference 2

destination-pattern 9911

port 0/2/3

forward-digits 3

!

dial-peer voice 4255 pots

description ** FXO pots dial-peer **-Emergency dial-peer

destination-pattern 911

port 0/2/0

forward-digits 3

!

dial-peer voice 4256 pots

description ** FXO pots dial-peer **-Emergency dial-peer

preference 1

destination-pattern 911

port 0/2/1

forward-digits 3

!

dial-peer voice 4257 pots

description ** FXO pots dial-peer **-Emergency dial-peer

preference 2

destination-pattern 911

port 0/2/2

forward-digits 3

!

dial-peer voice 4258 pots

description ** FXO pots dial-peer **-Emergency dial-peer

preference 2

destination-pattern 911

port 0/2/3

forward-digits 3

!

dial-peer voice 4259 pots

description ** FXO pots dial-peer **

destination-pattern 91[2-9].........

port 0/2/0

forward-digits 11

!

dial-peer voice 4260 pots

description ** FXO pots dial-peer **

preference 1

destination-pattern 91[2-9].........

port 0/2/1

forward-digits 11

!

dial-peer voice 4261 pots

description ** FXO pots dial-peer **

preference 2

destination-pattern 91[2-9].........

port 0/2/2

forward-digits 11

!

dial-peer voice 4262 pots

description ** FXO pots dial-peer **

preference 2

destination-pattern 91[2-9].........

port 0/2/3

forward-digits 11

!

dial-peer voice 8250 voip

preference 1

destination-pattern 8250

voice-class h323 222

session target ipv4:172.0.1.1

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 4263 pots

description ** FXO pots dial-peer **

destination-pattern 9425.......

port 0/2/0

forward-digits 7

!

dial-peer voice 4264 pots

description ** FXO pots dial-peer **

preference 1

destination-pattern 9425.......

port 0/2/1

forward-digits 7

!

dial-peer voice 4265 pots

description ** FXO pots dial-peer **

preference 2

destination-pattern 9425.......

port 0/2/2

forward-digits 7

!

dial-peer voice 4266 pots

description ** FXO pots dial-peer **

preference 3

destination-pattern 9425.......

port 0/2/3

forward-digits 7

!

dial-peer voice 4267 pots

description ** FXO pots dial-peer **

destination-pattern 9011T

port 0/2/0

forward-digits all

prefix 011

!

dial-peer voice 4268 pots

description ** FXO pots dial-peer **

preference 1

destination-pattern 9011T

port 0/2/1

forward-digits all

prefix 011

!

dial-peer voice 4269 pots

description ** FXO pots dial-peer **

preference 2

destination-pattern 9011T

port 0/2/2

forward-digits all

prefix 011

!

dial-peer voice 4270 pots

description ** FXO pots dial-peer **

preference 2

destination-pattern 9011T

port 0/2/3

forward-digits all

prefix 011

!

dial-peer voice 4271 pots

description ** FXO pots dial-peer **

destination-pattern 9T

port 0/2/0

forward-digits all

!

dial-peer voice 4272 pots

description ** FXO pots dial-peer **

preference 1

destination-pattern 9T

port 0/2/1

forward-digits all

!

dial-peer voice 4273 pots

description ** FXO pots dial-peer **

preference 2

destination-pattern 9T

port 0/2/2

forward-digits all

!

dial-peer voice 4274 pots

description ** FXO pots dial-peer **

preference 3

destination-pattern 9T

port 0/2/3

forward-digits all

!

dial-peer voice 999020 pots

service mgcpapp

port 0/2/0

!

dial-peer voice 999021 pots

service mgcpapp

port 0/2/1

!

dial-peer voice 999030 pots

service mgcpapp

port 0/3/0

!

dial-peer voice 999031 pots

service mgcpapp

port 0/3/1

!

!

gateway

timer receive-rtp 600

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 8 gain -6

transfer-system full-consult

timeouts interdigit 3

ip source-address 172.0.1.252 port 2000

max-ephones 42

max-dn 125

system message primary CallManager Fallback

!

banner login _C

-----------------------------------------------------------------------

This is a private system. Use by unathorized persons is prohibited.

All accesses to this service are logged. Anyone found using this

device or its information for any unauthorized purpose will be subject

to prosecution.

-----------------------------------------------------------------------_

!

line con 0

login local

line aux 0

line vty 0 4

access-class 101 in

exec-timeout 120 0

privilege level 15

login local

transport input telnet ssh

line vty 5 15

access-class 102 in

exec-timeout 120 0

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

!

end

4 REPLIES

Re: One-way-Audio, What should the RTP source address be set as?

The config with binding to the internal interface is pretty standard.  So, I would ask to dig into the details a bit more to work on this.  Some more call details would help.  Such as:

1) Is this a standard call to an "external" number - i.e., call to PSTN via gateway (PRI and/or POTS)

2) Same number everytime or doesn't matter - in other words, do you get one way audio on calls the same number frequently or just on PSTN calls in general

Hailey

Please rate helpful posts!

New Member

Re: One-way-Audio, What should the RTP source address be set as?

1) Is this a standard call to an "external" number - i.e., call to PSTN via gateway (PRI and/or POTS)

The problem only occurs when a call is placed through the gateway and when connecting to another (3rd party) VOIP carrier yes"external".

Our service is 100% Internet based, all calls are carried via our TCP/IP ISP (Docsis) & Internet VIOP Provider, so our gateway is to the Internet.

I agree an internal address would be "standard" for a deployment using say a PRI or POTS for instance, but does still hold true for an "external" IP VOIP Peer scenario?

2) Same number everytime or doesn't matter - in other words, do you get one way audio on calls the same number frequently or just on PSTN calls in general

It's not so much the same number as it is the same carriers, There are multiple carriers that we have the problem with.

Packet captures show that the SIP exchange is OK, however the RTP Stream fails either outbound or both ways.

New Member

Re: One-way-Audio, What should the RTP source address be set as?

I have located : One-way audio on calls placed across the PIX Firewall with NAT or PAT

This seems to describe our issue, would an expert care to comment please?

Thanks again in advance!

Ken

Re: One-way-Audio, What should the RTP source address be set as?

Good info regarding the various VoIP ISP's as opposed to standard PRI/POTS gateways attached to the local router.  I don't think it could hurt to add the workaroudn command to your config (I'd go with after hours) and then do some testing to/from the various carriers.  Just make plenty of test calls with decent duration (e.g., 30 seconds) before you determine whether or not things have cleared up.

Hailey

5229
Views
4
Helpful
4
Replies
CreatePlease to create content