Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

One way voice problem on h.323 gateway BRI

Hello,

There is a branch office in France having oneway voice issues. They can dial-out and place calls, but they cannot hear the person external on the line. Internal digit dialling works ok.

I have tried to play with the codec settings, trying G729r8, and setting that one aswell in the Call Manager, this didn't change anything.

Am i missing something?

show network-clock:

BORV001#show network-clock
  Network Clock Configuration
  ---------------------------
  Priority      Clock Source    Clock State     Clock Type

     1          BRI0/1/0        GOOD            BRI
     2          BRI0/1/1        GOOD            BRI
     3          BRI0/2/0        GOOD            BRI
     4          BRI0/2/1        GOOD            BRI
    11          Backplane       GOOD            PLL

  Current Primary Clock Source
  ---------------------------
  Priority      Clock Source    Clock State     Clock Type

     1          BRI0/1/0        GOOD            BRI

sh run from the VG:

BORV001#sh run
Building configuration...

Current configuration : 11049 bytes
!
! Last configuration change at 10:29:58 GMT+2 Wed Aug 14 2013 by administrator
!
version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname BORV001
!
boot-start-marker
boot system flash:c2800nm-spservicesk9-mz.124-22.T.bin
boot-end-marker
!
logging message-counter syslog
logging buffered 64000
no logging console
enable secret 5 $1$VawE$JejW8IdQLmyHEWMFjAlb41
!
no aaa new-model
clock timezone GMT+1 1
clock summer-time GMT+2 recurring last Sun Mar 2:00 last Sun Oct 2:00
network-clock-participate wic 1
network-clock-participate wic 2
network-clock-select 1 BRI0/1/0
network-clock-select 2 BRI0/1/1
network-clock-select 3 BRI0/2/0
network-clock-select 4 BRI0/2/1
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 10.250.11.1 10.250.11.10
!
ip dhcp pool IPPhones
   network 10.250.11.0 255.255.255.0
   default-router 10.250.11.1
   option 150 ip 10.251.0.11 10.251.0.13
   lease 7
!
!
ip cef
no ip domain lookup
ip domain name puratos.com
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
isdn switch-type basic-net3
!
!
voice rtp send-recv
!
voice service pots
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
!
!
voice class codec 10
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g729r8
!
!
!
!
voice class h323 1
  h225 timeout tcp establish 5
  call preserve
!
!
!
!
!
!
!
!
!
!
voice translation-rule 1
rule 1 /^00033/ /00/ type any unknown
rule 2 // // type any unknown
!
voice translation-rule 10
rule 1 /^2116\(..$\)/ /5577706\1/
rule 2 /.*/ //
!
voice translation-rule 11
rule 1 // /000/ type international international
rule 2 // /00/ type national national
!
!
voice translation-profile AddLeading0
translate calling 11
!
voice translation-profile changeNumPlan&CLI
translate calling 10
translate called 1
!
!
voice-card 0
dsp services dspfarm
!
!
!
!
!
username administrator secret 5 $1$STZV$OVsmEcIHYFUBeuK6yr1Aj0
archive
log config
  hidekeys
!
!
!
!
!
!
interface Loopback1
description === Used for Multicast MoH config ===
ip address 172.16.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 10.22.9.10 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 10.250.11.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.250.11.1
!
interface Service-Engine0/0
ip unnumbered FastEthernet0/0.2
service-module ip address 10.250.11.2 255.255.255.0
service-module ip default-gateway 10.250.11.1
no keepalive
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface BRI0/1/0
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
isdn static-tei 0
!
interface BRI0/1/1
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
isdn static-tei 0
!
interface BRI0/2/0
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
isdn static-tei 0
!
interface BRI0/2/1
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
isdn static-tei 0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.22.9.200
ip route 10.250.11.2 255.255.255.255 Service-Engine0/0 permanent
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0
compand-type a-law
cptone FR
!
voice-port 0/0/1
compand-type a-law
cptone FR
!
voice-port 0/0/2
compand-type a-law
cptone FR
!
voice-port 0/0/3
compand-type a-law
cptone FR
!
voice-port 0/1/0
compand-type a-law
cptone FR
!
voice-port 0/1/1
compand-type a-law
cptone FR
!
voice-port 0/2/0
compand-type a-law
cptone FR
!
voice-port 0/2/1
compand-type a-law
cptone FR
!
ccm-manager fax protocol cisco
ccm-manager music-on-hold
!
mgcp fax t38 ecm
!
!
!
dial-peer voice 1000 voip
description *** DEFAULT VoIP Incoming Peer ***
preference 1
destination-pattern 211...
progress_ind setup enable 3
voice-class codec 10
voice-class h323 1
session target ipv4:10.251.0.12
incoming called-number .
dtmf-relay cisco-rtp h245-alphanumeric
fax-relay ecm disable
fax rate disable
no vad
!
dial-peer voice 1001 voip
description *** DEFAULT VoIP Incoming Peer ***
preference 2
destination-pattern 211...
progress_ind setup enable 3
voice-class codec 10
voice-class h323 1
session target ipv4:10.251.0.13
incoming called-number .
dtmf-relay cisco-rtp h245-alphanumeric
fax-relay ecm disable
fax rate disable
no vad
!
dial-peer voice 1 pots
description === outgoing calls with digit strip ===
translation-profile incoming AddLeading0
translation-profile outgoing changeNumPlan&CLI
preference 4
destination-pattern 0T
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
incoming called-number T
direct-inward-dial
port 0/1/0
!
dial-peer voice 2 pots
description === outgoing calls with digit strip ===
translation-profile incoming AddLeading0
translation-profile outgoing changeNumPlan&CLI
preference 3
destination-pattern 0T
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
incoming called-number T
direct-inward-dial
port 0/1/1
!
dial-peer voice 3 pots
description === outgoing calls with digit strip ===
translation-profile incoming AddLeading0
translation-profile outgoing changeNumPlan&CLI
preference 2
destination-pattern 0T
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
incoming called-number T
direct-inward-dial
port 0/2/0
!
dial-peer voice 4 pots
description === outgoing calls with digit strip ===
translation-profile incoming AddLeading0
translation-profile outgoing changeNumPlan&CLI
preference 1
destination-pattern 0T
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
incoming called-number T
direct-inward-dial
port 0/2/1
!
dial-peer voice 11 pots
description === emergency ===
translation-profile incoming AddLeading0
translation-profile outgoing changeNumPlan&CLI
preference 4
destination-pattern 1[578]
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
incoming called-number T
no digit-strip
direct-inward-dial
port 0/1/0
!
dial-peer voice 12 pots
description === emergency ===
translation-profile incoming AddLeading0
translation-profile outgoing changeNumPlan&CLI
preference 3
destination-pattern 1[578]
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
incoming called-number T
no digit-strip
direct-inward-dial
port 0/1/1
!
dial-peer voice 13 pots
description === emergency ===
translation-profile incoming AddLeading0
translation-profile outgoing changeNumPlan&CLI
preference 2
destination-pattern 1[578]
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
incoming called-number T
no digit-strip
direct-inward-dial
port 0/2/0
!
dial-peer voice 14 pots
description === emergency ===
translation-profile incoming AddLeading0
translation-profile outgoing changeNumPlan&CLI
preference 1
destination-pattern 1[578]
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
incoming called-number T
no digit-strip
direct-inward-dial
port 0/2/1
!
dial-peer voice 211999 voip
description ### Local CUE VoiceMail ###
destination-pattern 211999
session protocol sipv2
session target ipv4:10.250.11.2
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 211998 voip
description ### IVR Reception ###
destination-pattern 211998
session protocol sipv2
session target ipv4:10.250.11.2
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 211900 voip
description ### Local CUE AA ###
destination-pattern 211900
session protocol sipv2
session target ipv4:10.250.11.2
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 211901 voip
description ### Local CUE AA ###
destination-pattern 211901
session protocol sipv2
session target ipv4:10.250.11.2
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 211902 voip
description ### Local CUE AvT ###
destination-pattern 211902
session protocol sipv2
session target ipv4:10.250.11.2
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 21 pots
description === emergency ===
translation-profile incoming AddLeading0
translation-profile outgoing changeNumPlan&CLI
preference 4
destination-pattern 11[2579]
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
incoming called-number T
no digit-strip
direct-inward-dial
port 0/1/0
!
dial-peer voice 22 pots
description === emergency ===
translation-profile incoming AddLeading0
translation-profile outgoing changeNumPlan&CLI
preference 3
destination-pattern 11[2579]
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
incoming called-number T
no digit-strip
direct-inward-dial
port 0/1/1
!
dial-peer voice 23 pots
description === emergency ===
translation-profile incoming AddLeading0
translation-profile outgoing changeNumPlan&CLI
preference 2
destination-pattern 11[2579]
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
incoming called-number T
no digit-strip
direct-inward-dial
port 0/2/0
!
dial-peer voice 24 pots
description === emergency ===
translation-profile incoming AddLeading0
translation-profile outgoing changeNumPlan&CLI
preference 1
destination-pattern 11[2579]
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
incoming called-number T
no digit-strip
direct-inward-dial
port 0/2/1
!
!
num-exp 06.. 2116..
!
call-manager-fallback
secondary-dialtone 0
max-conferences 8 gain -6
transfer-system full-consult
user-locale FR
ip source-address 10.250.11.1 port 2000
max-ephones 20
max-dn 40 dual-line
system message primary Callmanager SRST Mode
transfer-pattern 0.T
transfer-pattern .T
voicemail 211999
moh music-on-hold.au
multicast moh 239.1.1.1 port 16384 route 10.250.11.1 172.16.1.1
time-zone 27
time-format 24
date-format dd-mm-yy
!
!
vm-integration
!
banner exec ^CCC
^C
banner motd ^C

purator bordeaux
voice-gateway

^C
!
line con 0
exec-timeout 15 0
login local
line aux 0
login local
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output all
line vty 0 4
exec-timeout 120 0
logging synchronous
login local
!
scheduler allocate 20000 1000
ntp server 10.1.0.40
end

Everyone's tags (3)
17 REPLIES
New Member

One way voice problem on h.323 gateway BRI

Just did a reload of the router incase it was DSP issues, but that didn't work

VIP Super Bronze

One way voice problem on h.323 gateway BRI

One way audio is usually a routing issue. You need to check routing between your gateway and your ip phones. When you  make an outbound call, rtp stream is setup between your phones ad the pstn gateway. Looks like there is a routing problem between the subnets

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

One way voice problem on h.323 gateway BRI

I can ping an IP phone from the router.

VIP Super Bronze

One way voice problem on h.323 gateway BRI

Can you ping router from ip phone subnet...

do a test call and then when the call is connected...enter this command

show voip rtp connection

post the output here

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

One way voice problem on h.323 gateway BRI

Hi,

Going to test this, i'm not at this office so i'm going to have an end-user test this.

The subnet from the phones is directly connected to fa0/0.2, the VG is also the DHCP for the phones

New Member

Re: One way voice problem on h.323 gateway BRI

Output show voip rtp

VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP                                RemoteIP
1   16         15         17504    19352  10.250.11.1                            10.250.11.26
Found 1 active RTP connections

BORV001#show voip rtp connection
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP                                RemoteIP
1   16         15         17504    19352  10.250.11.1                            10.250.11.26
Found 1 active RTP connections

BORV001#show voip rtp connection

VoIP RTP active connections :

No. CallId     dstCallId  LocalRTP RmtRTP LocalIP                                RemoteIP

1   18         17         16704    16386  10.250.11.1                            10.250.11.2

Found 1 active RTP connections

New Member

One way voice problem on h.323 gateway BRI

The routing seems ok

I have resetted the BRI's, but that didn't do the trick.

Anyone else have some options? Could this be a telco problem somewhere?

VIP Super Bronze

One way voice problem on h.323 gateway BRI

So from the output you have this..

10.250.11.26-----------rtp-----10.250.11.1

Looks like they are in the same subnet..So looks pretty straight forward...I suggest you upgrade your ios and try again

Do you have two gateways between the phone and the pstn?

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

One way voice problem on h.323 gateway BRI

Hello,

No it's one VG with a CUE module on it.

The VG is also the DHCP for the phones, and has a fastethernet in the same subnet yes. I was wondering if this could be a DSP issue. I gave the router a reload but that didn't do anything.

Seims weird that this problem just pops up on an IOS that has been working fine for the last time.

Hall of Fame Super Gold

Re: One way voice problem on h.323 gateway BRI

Update IOS and check again.

Other than that you may have a problem with VPN, firewall, etc.

New Member

One way voice problem on h.323 gateway BRI

Seems weird that the IOS would be the problem here as this worked fine probably yesterday on the same IOS.

I've thought about firewall, but i was thinking. This is an office with VG and a direct connection to the PSTN on 4 BRI interfaces.

It's also that only the external caller's voice is not heard, i can hear their voice. so for some reason my stream isn't getting there.

One way voice problem on h.323 gateway BRI

To narrow down this a little bit, you can make a test call and hit the ? mark twice on the phone. This will tell you what codec is being used and if the phone is receiving/sending RTP packets.

Please rate helpful answers!

New Member

One way voice problem on h.323 gateway BRI

Updated the IOS to flash:c2801-spservicesk9-mz.124-24.T8.bin

This did not solve the problem

Hall of Fame Super Gold

One way voice problem on h.323 gateway BRI

Then check the second possibility I've mentioned above.

New Member

One way voice problem on h.323 gateway BRI

I no longer have a test person on site, but when i look in the region settings of the call manager they should dial internal with G711.

The following codec configuration resides on the voice gateway:

!

voice class codec 10

codec preference 1 g711alaw

codec preference 2 g711ulaw

codec preference 3 g729r8

!

Thanks,

VIP Super Bronze

One way voice problem on h.323 gateway BRI

If this was working before and it suddenly stopped, then you need to investigate if there was any change made to your setup..Is there a firewall anywhere in the setup? Do you have a spare BRI card, you can remove the existing one and test again

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

One way voice problem on h.323 gateway BRI

Yannick,

I didnt read through the entire thread in a lot of detail but one-way voice is 99% of the time a Network routing issue. If you can make an outbound call, and the outside caller can hear you but you cannot hear them, then this means that the phone can make connectivity to the BRI connected to the router, except the BRI (subnet) cannot reach the phones.

When you said you can ping the phones from the router, are you sure that the source of the PING is from the subnet that the BRI is on?

Try doing a Ping with the source set as fa0/0.2 - this should indicate if routing is up.

You could also try removing the bind command from fa0/0.2 and re-apply it...

As already mentioned if there is a fw anywhere in between then this would be a big concern.

HTH

CR

714
Views
0
Helpful
17
Replies
CreatePlease login to create content