Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323 Gateway

Im using a SIP provider (voip.ms) to a H323 gateway (2801) and from there go to my CUCM 8.6 server.  Inbound calls work fine, i get ringback and outbound calls connect and work fine, i just hear no ringback on my outbound calls via my SIP provider.

Attached are my debug ccsip messages, debug ccsip calls and debug ccapi inout as well as my running config

Here is also a link to another thread for other stuff ive tried:

http://www.techexams.net/forums/ccnp-voice/78494-outbound-ringback-issues.html

If anyone could solve this, you would be my hero!!!!                  

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323

Yes. On cucm setup a sip trunk, the detsination address will be your cube gateway. Assign MRGL with ANN to the sip trunk.

2. On your gateway configure the ff:

voice servie voip

sip

  bind control source-interface "xxxx"-----xxxx= your inerface eg gig0/0 of fa0/0

  bind media source-interface "xxxx"   

options-ping 60

early-offer forced.......................If you want to use early offer otherwise you can remove this

voice class codec 1---------------------------------to advertise different codecs, change preference as you want

codec preference 1 g729r8

codec preference 2 g711ulaw

codec preference 3 g711alaw

dial-peer voice 1 voip---------------------------------This will be your default dial-peer for incoming calls from cucm and sip provider

session portocol sipv2

incoming called-number .

voice-class codec 1 

dtmf-relay rtp-nte

I believe you already have a dial-peer with sip protocl going to your ITSP.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
27 REPLIES
VIP Super Bronze

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323

  Hi John,

By default, Cisco Unified Communications Manager  will signal the calling phone to play local ringback if SDP is not  received in the 180 or 183 response. If SDP is included in the 180 or  183 response, instead of playing ringback locally, Cisco Unified  Communications Manager will connect media, and the calling phone will  play whatever the called device is sending (such as ringback or busy  signal). If you do not receive ringback, the device to which you are  connecting may be including SDP in the 180 response, but it is not  sending any media before the 200OK response. In this case

The log you sent does not contain the debug ccsip messages, so I am unable to determine if you receive 183 with SDP. If your provider is sending 183 without SDP, then cucm should be teliing the phone to play ringback locally. However CUCM uses Annunciator to play ringback for sip trunks. So you need to ensure that you have ANNunciator in your MRG and assign this MRG to a MRGL and inturn assign the MRGL to your phones and cube gateway

If you are receiving 183 with SDP but still not getting ringback, then try you can use a feature called disable early media to force cucm to play ringback locally..(dont forget to enable Annunciator and assign to phones and cube gateway)

disable-early-media 180

To specify which call treatment, early media or local ringback, is provided for 180 responses with 180

responses with Session Description Protocol (SDP), use the disable-early-media 180 command in

sip-ua configuration mode. To enable early media cut-through for 180 messages with SDP, use the no

form of this command. disable-early-media 180

config t

sip-ua

disable-early-media 180

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Re: Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H

I added the disable-early-media 180 with no luck.  attached is a copy of debug ccsip messages.  What do i need to do to enable Annunciator and assign it to phones/gateway?  Ive never done that before.

New Member

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323

OK i have ANN_2 and ANN_3 under Announciator, i put them in a group then put them in a list.  On my gateway i applied the list and checked MTPR checkbox.  I selected the Media Resource Group list under my phones and device pool.  I also went to Service Parameters and set

Any more ideas or debugs you guys want?

VIP Super Bronze

Re: Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H

You dont need to check MTP box. Please uncheck otherwise you may create additional problems..

Can you do a test call and send me a

show voip rtp connection  (this will show us if the annunciator is been called upon to provide ringback)

NB: to see the annuciator in the voip rtp connection command to need to be refreshing the command. Dont just call and type the command once. Because the ann is called when its time to provide ringback.

also please send a full debug ccsip messages. The one you sent, the call did not complete

Do oyu know how to collect cucm traces? If you can send that will be great.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
VIP Super Bronze

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323

John,

Have you made any progress with this? Did you see my last post

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323

Havent had a chance to run through this yet.  Will tonight and post results that you requested.  Im not too familiar with CUCM traces

New Member

Hi All,

Hi All,

Even i have the same issue . There will be one ring then then a fax tone then it will give a message" We are sorry your call cannot be completed this time, please hang up and dial after sometime" this message will play twice in quick session of two times and then the call will disconnect. The call is reaching the gateway .

Working calls are receiving 183 message with SDP but the failing calls from this location does not have 183 instead it have 180 without any SDP message in it  and getting a 200 OK message soon.

Is it ok for us to involve ITSP.

Regards,

Shinaj cm 

VIP Super Bronze

You should engage your ITSP

You should engage your ITSP and I hope it is not TATA. Provide traces to them and push them to look at why you are seeing this behaviour

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Hi Ayodeji,

Hi Ayodeji,

Customer is asking why it is service provider issue as all the numbers are going to the same provider and it is working.

this is occurring only for a set or block of DID.

Regards,

Shinaj cm

New Member

Re: Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H

Here is the requested output.  Anytime you see the output of show voip rtp connection it is when the outbound call should be providing ringback, and the number i am calling is ringing on the other end.

      

In the mean time i have also tried this:

System > Service Parameters > Under Clusterwide Parameters (Device - H323) set Check Progress Indicator Before Establishing Media to True (False as default) and setting Send H323 User Info Message to H225 Info for Call Progress Tone, restarted callmanager service, reset the gateway, all with no luck.

VIP Super Bronze

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323

John,

Looking at your trace I dont see the communication with CUCM. I dont see your gateway receiving an invite from cucm or sending sip trying or 200 ok to cucm. If the call originated from cucm then this must happen.

Did you omit this traces?

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323

No those were from the router and nothing was omitted.  Were those suppose to come from CUCM traces?

VIP Super Bronze

Re: Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H

John,

I know why I dont see the trace, its beacise the leg to cucm is h323 leg, its not sip.

May I ask, why are you not using SIP all the way.? i.e. configure your sip trunk from cucm to your gateway. Have you tried this.

Let me know if you want to try with the sip trunk setup. Otherwise please do another test call and send

debug voip ccapi inout.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Re: Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H

I would try converting it to SIP the whole way.  How do i go about configuring that in CUCM and on the router>?

New Member

Re: Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H

Just kidding, it looks like i just need to switch the session protocol to sipv2 then setup a trunk instead of a gateway on CUCM

VIP Super Bronze

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323

Yes. On cucm setup a sip trunk, the detsination address will be your cube gateway. Assign MRGL with ANN to the sip trunk.

2. On your gateway configure the ff:

voice servie voip

sip

  bind control source-interface "xxxx"-----xxxx= your inerface eg gig0/0 of fa0/0

  bind media source-interface "xxxx"   

options-ping 60

early-offer forced.......................If you want to use early offer otherwise you can remove this

voice class codec 1---------------------------------to advertise different codecs, change preference as you want

codec preference 1 g729r8

codec preference 2 g711ulaw

codec preference 3 g711alaw

dial-peer voice 1 voip---------------------------------This will be your default dial-peer for incoming calls from cucm and sip provider

session portocol sipv2

incoming called-number .

voice-class codec 1 

dtmf-relay rtp-nte

I believe you already have a dial-peer with sip protocl going to your ITSP.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323

problem im running into now, is that when i bind the sip source interface to the internal FA port rather than the external, now my sip trunk does not register

how can i bind it to the external AND internal interface so it will register and work as a cucm trunk?

VIP Super Bronze

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323

John,

What do you mean by your sip trunk does not register? Are you talking about cucm trunk? or the sip trunk to your provider?

CUCM sip trunk does not register and as far as I know, your ITSP trunk does not register. Most ITSP use authentication.

Can you send a sh run of your router...

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323

The show run is attached in the zip file in the first post

when i do a show sip-ua register status it shows up as registered: YES

if i bind sip to the internal interface it shows registered: NO and no calls work in or out

when i did a debug ccsip messages, its sending the SIP provider my internal IP address, which obviously isnt going to work (when bound to the inside interface)

VIP Super Bronze

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323

John,

OK I get you now. I did not know you were using a registrar.

Can you leave your bind on your external interface...Try and send a call to the cube..Let me know what happens. CUCM trunk does not need registration.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323

OK.  I bound SIP to the internal interface and setup the SIP traffic to route out my ASA gateway and setup static statements on the ASA to map the SIP traffic to the router behind it and viola, everything is working once i converted cucm to the sip trunk.

Thanks for the help aokanlawon

Re: Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323

Make sure the annunciator is inside the MRG of the SIP trunks. I left my ANN inside a not-used MRG, and after put it in the MRG of the SIP trunk, I got the ringback.

New Member

Hi Ayodeji, I had the same

Hi Ayodeji,

 

I had the same problem that JZergers06 had and I disabled the early media 180, as you said on pots above and everything worked fine. Thanks a lot!!!

New Member

Hello Ayodeji,

Hello Ayodeji,

I always enjoy reading your posts..Very very informative and i admire your passion on the SIP technology.

Regarding "If you are receiving 183 with SDP but still not getting ringback,", 

1. what can cause this issue ? 

2. What is the side effect of disabling early media on other call flows ?

3. Is it a good idea or valid idea to translate 183 with sdp to 180 ringing on the SBC to do the same ?

Thanks,Padhu

VIP Super Bronze

Thank you for your kind words

Thank you for your kind words..

1. It is usually a problem on the service provider side. So there is nothing much you can do other than contacting them

2. You will typically not get announcements that are played before media connects. Anything that is sent as media before 200 OK or ACK is early media and if you disable it, then you don't get it

3. It is advisable to let SBC/service provider do it. It is not recommended practice..

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Thank you Ayodeji.

Thank you Ayodeji.

Disabling early media didn't seem to fix but some interesting things in the cm traces and sdp.

(Sip trunk set for early offer with insert MTP if reqd)

when phones have g711 ahead of g729 in ACPL ( same in SDP), the ring back works but ringback fails when G729 is chosen first. CCm Traces indicate a SW_MTP being allocated eventhough MRGL has MRGs with HW_IOS_MTP higher up in the order...So that brings up an anamoly where a G711 based SW MTP being invoked for a G729 call and ring back fails.

we are investigating more on this choice of MTP.

New Member

Hi,

Hi,

I am having the exact same issue. When G729 is negotiated the ringback fails (though the call succeeds).

Did you find any solution to it?

11494
Views
11
Helpful
27
Replies