Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Outgoing calls fail

Hi guys.

I ran into some issues with one of our brach sites where all outgoing calls fail.

We use a standard config across all brach sites wiht MGCP gateways, and works perfectly except this one site.

It used to work and recently had some power failures. After the power failures all out going calls started to fail.

Incoming calls work fine.

I've had the telco take a look at their equipment and they came back saying everything is fine on their side.

I ran a debug isdn q931 on the gateway while making outgoing calls, please see the attached file.

I can see that the telco is sending me the disconect message, but it is interesting to see the messages before the diconnect.

It seems that the gateway is complaining about missing information

A status message of "message not complatible with call state or not implemented" and another message "Mandatory information element missing"

It looks to me that there is a signaling issue between the Telco and the brach site when making outgoing calls, but I have no idea where to start troubleshooting this.

Any assitance will be much appreciated.

10 REPLIES

Outgoing calls fail

sh isdn status?

have you rebooted your gw?

Voice CCIE #37771
New Member

Outgoing calls fail

Thanks for all the prompt responses

I can confirm the gateway was rebooted, and that sh isdn stat shows all BRIs up and multiple frame established, and that the switch type is matching with the provider's switch type.

I will ask the provider to look into the RELEASE_COMP message.

Outgoing calls fail

you are receiving "Cause i = 0x82D100000000 - Invalid call reference value" from provider.

please crosscheck your isdn switch type. If the configuration looks good, have a word with your provider.

//Suresh Please rate all the useful posts.
New Member

Outgoing calls fail

Would that invalid call reference value message not be because of the "0x80E2 - Message not compatible with call state or not implemented" and "0x80E0 - Mandatory information element missing" message transmitted from the gateway?

It looks to me that the gateway is complaining that it is not receiving all information if I look at the order of the call ref#

Cisco Employee

Outgoing calls fail

This is more likely an issue on provider side since immediately after SETUP message, we are recieving RELEASE_COMP from provider end.

001791: Dec 12 10:52:09.791 GMT: ISDN BR0/2/1 Q931: TX -> SETUP pd = 8  callref = 0x11

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0x8A

                Exclusive, B2

        Calling Party Number i = 0x0081, '0112516401'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x80, '0716009662'

                Plan:Unknown, Type:Unknown

001792: Dec 12 10:52:09.843 GMT: ISDN BR0/2/0 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x91

        Cause i = 0x82D100000000 - Invalid call reference value

Ask the provider why they are sending this RELEASE_COMP ??


Br,
Nadeem 

Please rate all useful post.

Br, Nadeem Please rate all useful post.
New Member

Outgoing calls fail

Hi Nadeem.

The debug output I've attached is only the last bit, but below is the full debug.

When calling a number the GW tries to push the call out, but fails on the first attempt and then immediatly tries to push out a call again.

The RELEASE_COMPLETE message you see straight after the SETUP message looks like it is from the previous call that failed. This would explain why you see the message.

In the debug output above you dont see the RELEASE COMPLETE straig after the SETUP message.

Thanks for your help.

001783: Dec 12 10:52:09.187 GMT: ISDN BR0/2/0 Q931: TX -> SETUP pd = 8  callref = 0x11

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0x8A

                Exclusive, B2

        Calling Party Number i = 0x0081, '0112516401'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x80, '0716009662'

                Plan:Unknown, Type:Unknown

001784: Dec 12 10:52:09.439 GMT: ISDN BR0/2/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0x91

        Channel ID i = 0x8A

                Exclusive, B2

001785: Dec 12 10:52:09.443 GMT: ISDN BR0/2/0 Q931: TX -> STATUS pd = 8  callref = 0x11

        Cause i = 0x80E2 - Message not compatible with call state or not implemented

        Call State i = 0x01

001786: Dec 12 10:52:09.539 GMT: ISDN BR0/2/0 Q931: RX <- CALL_PROC pd = 8  callref = 0x91

001787: Dec 12 10:52:09.543 GMT: ISDN BR0/2/0 Q931: TX -> STATUS pd = 8  callref = 0x11

        Cause i = 0x80E0 - Mandatory information element missing

        Call State i = 0x01

001788: Dec 12 10:52:09.643 GMT: ISDN BR0/2/0 Q931: RX <- DISCONNECT pd = 8  callref = 0x91

        Cause i = 0x82E500000000 - Message not compatible with call state

        Progress Ind i = 0x8288 - In-band info or appropriate now available

001789: Dec 12 10:52:09.647 GMT: ISDN BR0/2/0 Q931: TX -> RELEASE pd = 8  callref = 0x11

001790: Dec 12 10:52:09.743 GMT: ISDN BR0/2/0 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x91

        Cause i = 0x82E500000000 - Message not compatible with call state

001791: Dec 12 10:52:09.791 GMT: ISDN BR0/2/1 Q931: TX -> SETUP pd = 8  callref = 0x11

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0x8A

                Exclusive, B2

        Calling Party Number i = 0x0081, '0112516401'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x80, '0716009662'

                Plan:Unknown, Type:Unknown

001792: Dec 12 10:52:09.843 GMT: ISDN BR0/2/0 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x91

        Cause i = 0x82D100000000 - Invalid call reference value

001793: Dec 12 10:52:10.039 GMT: ISDN BR0/2/1 Q931: RX <- SETUP_ACK pd = 8  callref = 0x91

        Channel ID i = 0x8A

                Exclusive, B2

001794: Dec 12 10:52:10.043 GMT: ISDN BR0/2/1 Q931: TX -> STATUS pd = 8  callref = 0x11

        Cause i = 0x80E2 - Message not compatible with call state or not implemented

        Call State i = 0x01

001795: Dec 12 10:52:10.139 GMT: ISDN BR0/2/1 Q931: RX <- CALL_PROC pd = 8  callref = 0x91

001796: Dec 12 10:52:10.143 GMT: ISDN BR0/2/1 Q931: TX -> STATUS pd = 8  callref = 0x11

        Cause i = 0x80E0 - Mandatory information element missing

        Call State i = 0x01

001797: Dec 12 10:52:10.243 GMT: ISDN BR0/2/1 Q931: RX <- DISCONNECT pd = 8  callref = 0x91

        Cause i = 0x82E500000000 - Message not compatible with call state

        Progress Ind i = 0x8288 - In-band info or appropriate now available

001798: Dec 12 10:52:10.247 GMT: ISDN BR0/2/1 Q931: TX -> RELEASE pd = 8  callref = 0x11

001799: Dec 12 10:52:10.343 GMT: ISDN BR0/2/1 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x91

        Cause i = 0x82E500000000 - Message not compatible with call state

001800: Dec 12 10:52:10.443 GMT: ISDN BR0/2/1 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x91

        Cause i = 0x82D100000000 - Invalid call reference value

absa-2902-0241strydo-ce-1#

Outgoing calls fail

Hi Eugene,

Simple question, is it the ISDN 2 B boxes you have from Telkom? They should have 2 ports one which you can connect an analog phone to and see if you can make an external call over the BRI. This will give you more or less an Idea what is going on.

Your BRI shows multi frame so that is fine, I can see you sent telkom only 10 digits as they expect.

So start from the beginning and lets make sure that BRI can take a voice call.

Do you have another BRI card you can test with?

Voice CCIE #37771
New Member

Outgoing calls fail

Hi Hermanus.

I have 4 BRI ports on site, and none of them seems to be working.

This was a working solution for months, but as I mentioned after some power issues on site all outgoing calls started to fail.

They did connect a trent test (disconected the BRI's from the gateway and connected them directly to their equipment) and were able to make calls.

Its only outgoing calls that are failing, incoming calls work fine.

I think there is a signaling issue, but confirmed that the switch type Im matches with that of telkom.

Here are is the BRI configs

interface BRI0/2/0

no ip address

isdn switch-type basic-net3

isdn incoming-voice voice

isdn bind-l3 ccm-manager service mgcp

no isdn outgoing ie progress-indicator

isdn outgoing display-ie

isdn outgoing ie redirecting-number

!

interface BRI0/2/1

no ip address

isdn switch-type basic-net3

isdn incoming-voice voice

isdn bind-l3 ccm-manager service mgcp

no isdn outgoing ie progress-indicator

isdn outgoing display-ie

isdn outgoing ie redirecting-number

!

interface BRI0/3/0

no ip address

isdn switch-type basic-net3

isdn incoming-voice voice

isdn bind-l3 ccm-manager service mgcp

isdn send-alerting

no isdn outgoing ie progress-indicator

isdn outgoing display-ie

isdn outgoing ie redirecting-number

!

interface BRI0/3/1

no ip address

shutdown

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn bind-l3 ccm-manager service mgcp

isdn send-alerting

no isdn outgoing ie progress-indicator

isdn outgoing display-ie

isdn outgoing ie redirecting-number

And my MGCP config

ccm-manager fallback-mgcp

ccm-manager redundant-host x.x.x.x

ccm-manager mgcp

no ccm-manager fax protocol cisco

!

mgcp

mgcp call-agent x.x.x.x 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode nte-ca

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp ip qos dscp af11 signaling

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp package-capability fm-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 ecm

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface GigabitEthernet0/1.302

mgcp bind media source-interface GigabitEthernet0/1.302

Outgoing calls fail

Hi Eugene,

This is what my BRI config looks like:

interface BRI0/1/0

no ip address

isdn switch-type basic-net3

isdn overlap-receiving

isdn bind-l3 ccm-manager service mgcp

isdn point-to-point-setup

isdn incoming-voice voice

isdn send-alerting

voice-port 0/1/0

compand-type a-law

cptone ZA

bearer-cap Speech

I do my MGCP the manual way:

ccm-manager switchback immediate

ccm-manager fallback-mgcp

ccm-manager redundant-host xxx.xxx.xxx.xxx

ccm-manager mgcp

ccm-manager music-on-hold

!

mgcp

mgcp call-agent xxx.xxx.xxx.xxx service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp ip qos dscp cs3 signaling

mgcp sdp simple

mgcp bind control source-interface FastEthernet0/0.112

mgcp bind media source-interface FastEthernet0/0.112

!

mgcp profile default

Voice CCIE #37771

Outgoing calls fail

Hi Eugene,

You are right. "Invalid call reference value" you are getting is of first setup message BR0/2/0 and the second setup is with BR0/2/1.

Are you meeting the requirements of Telco i.e. calling & called number type and it's plan.

Confirm the same requirement from Telco and configure accordingly and then check it again.

Regards,

Nishant Savalia    

Regards, Nishant Savalia
656
Views
9
Helpful
10
Replies