Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PC Network Issues Behind IP Phone

We have a couple of PCs that won't log onto the Windows domain when connected through a 7940 phone. If we logon directly connected and then switch back to the path through the phone, then the network connectivity for the user is just fine. We've tried different phones and ports and just can't seem to figure out what the root cause is. Any ideas?

13 REPLIES

Re: PC Network Issues Behind IP Phone

Are you getting correct ip information on the workstations? Verify that DNS is showing up correctly on these workstations. Remember if you're running AD, it relies on DNS unless you have WINS enabled. Verify your switchports where the phones are configured correctly.

New Member

Re: PC Network Issues Behind IP Phone

The problem is that I can't get the user access to that information until they can logon which they can't do through the phone. I had them do an ipconfig /release and then /renew after they're signed in and see what DHCP info was and it was all correct. The port config is:

interface FastEthernet1/0/13

switchport access vlan 2

switchport mode access

switchport voice vlan 3

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

no mdix auto

auto qos voip cisco-phone

spanning-tree portfast

Re: PC Network Issues Behind IP Phone

This shouldn't make a difference, but your missing "switchport priority extend cos 0". Other then hat the switchport config looks good. So if the plug directly it works fine. What model switch are you working with? Try this not sure if it will help, but worth a try.

int faste 1/0/13

switchport trunk encap dot1q

switchport trunk native vlan 2

swtichport voice vlan 3

switchport mode trunk

New Member

Re: PC Network Issues Behind IP Phone

What does the "switchport priority extend cos 0" do? We're using 3750 POE switches.

Re: PC Network Issues Behind IP Phone

Anything on the other end of the phone is considered as a untrusted device and is marked at layer to to cos 0.

Re: PC Network Issues Behind IP Phone

On the 3750's the configuration should work with now problems. What version of code are you using on the switch?

New Member

Re: PC Network Issues Behind IP Phone

(C3725-SPSERVICESK9-M), Version 12.4(2)T

Not very current, but the other hosts and phones have worked for 2 years.

Re: PC Network Issues Behind IP Phone

3725 is the IOS for a 3725 router...I was talking about your switches. So your telling me that you have some phones working with the same port config as the ones that don't. Would you by chance have the PC disabled under Call Manager. It is a setting located at device-->Phone-->phone in question--> Product Specific Configuration-->PC Port

Needs to be set to enable Also PC Voice Vlan Access needs to be enabled.

New Member

Re: PC Network Issues Behind IP Phone

Darn, grabbed the wrong show ver. Sorry about that. The switch is (C3750-I9-M), Version 12.2(25)SE.

We're running CallManager Express and as far as I know there is no way to switch off that port in CME. Plus the port works, just not for the initial login.

Re: PC Network Issues Behind IP Phone

You're correct on CME. Sorry Missed that. hmm So can you take a known working phone and plug it up exactly how this one is and see if it experience the problem. Make sure to tell me if it was the same model phone or something different.

New Member

Re: PC Network Issues Behind IP Phone

They've tried three different 7940s all with the same result.

Re: PC Network Issues Behind IP Phone

Did these phones work some where else with no problems?

New Member

Re: PC Network Issues Behind IP Phone

Yes. The weird thing is that the problem supposedly follows the PC, but also supposedly they're putting a PC on the same phone in the same place that also fails, but works elsewhere. (Isn't working through a third party fun?)

313
Views
0
Helpful
13
Replies