Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Phone continues to not register in CME

Hi again Cisco techs,

Me again. 7912 cisco phone fails to register in cme 3.3 via IOS 12.4(25d)(C2691-IPVOICEK9-M),

I reset the phone to factory reset. Then done 

cme_router(config)#telephony-service
cme_router(config-telephony)#load 7912 CP7912060000SCCP050124A.sbin
Updating CNF files
CNF files update complete

cme_router(config-telephony)#reset all
ITS configuration has been changed, selecting sequence-all reset
Reset-All: no active phones
All DNs in DOWN state

Phones MAC address and extension number shows in CME 3.3

Can ping phone OK but not register as below command states

cme_router#sh ephone

ephone-1 Mac:0017.9570.8E67 TCP socket:[-1] activeLine:0 UNREGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1
IP:0.0.0.0 0 Unknown 0  keepalive 0 max_line 0

cme_router#

I know that persistance pays off but this is driving me crazy.

Can someone please advise

18 REPLIES

try no create cnf-filescreate

try no create cnf-files

create cnf-files

see if that gives you anything different

New Member

Thanks Michael. I had tried

Thanks Michael. I had tried that already. Much appreciated though

post the output from "debug

post the output from "debug tftp event/ debug tftp packet", when you reset the phone, and lets see what happened, trust me the above command is very helpful when troublshooting CME phone registration.

VIP Gold

What phone is displaying on

What phone is displaying on its screen ? can you attach cme config (You can remove ip details).

Otherwise try to reconfigure ephone with different ephone tag and attach "debug tftp events"

Suresh

New Member

Phone goes into a constant

Phone goes into a constant loop of:-

Configuring vlan, configuring CM List, then configuring IP

Switch can ping router/tftp(same IP address)

Can ping phone from router ok.

CME configuration is:

cme_router#sh telephony-service
CONFIG (Version=3.3)
=====================
Version 3.3
Cisco CallManager Express
For on-line documentation please see:
www.cisco.com/univercd/cc/td/doc/product/access/ip_ph/ip_ks/index.htm

ip source-address 192.168.0.12 port 2000
load 7912 CP7912060000SCCP050124A.sbin
max-ephones 4
max-dn 5
max-conferences 4 gain -6
dspfarm units 0
dspfarm transcode sessions 0
hunt-group report delay 1 hours
max-redirect 5
dialplan-pattern 1 0280070300 extension-length 4 extension-pattern 1001
time-format 24
date-format dd-mm-yy
timezone 0 Greenwich Standard Time
keepalive 30
timeout interdigit 10
timeout busy 10
timeout ringing 180
caller-id name-only: enable
web admin system name admin  password TrustNo1
web admin customer name Customer
edit DN through Web:  enabled.
edit TIME through web:  enabled.
Log (table parameters):
     max-size: 150
     retain-timer: 15
create cnf-files version-stamp 7960 Oct 11 2014 02:13:01
local directory service: enabled.

debug tftp events not work after configuring ephone with different tag

HTH :)

it looks like phones do not

it looks like phones do not have ip addresses

sh ip dhcp bin

sh logg

sh ip dhc con

 

New Member

Thanks Tagir for your reply

Thanks Tagir for your reply.

Phone "does get the ip address. Of 192.168.2.1
cme_router#sh ip dhcp bin
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
192.168.2.4         0100.1795.708e.67       Oct 12 2014 01:52 AM    Automatic
cme_router#
 
cme_router#sh logg
Syslog logging: enabled (11 messages dropped, 1 messages rate-limited,
                0 flushes, 0 overruns, xml disabled, filtering disabled)
    Console logging: level debugging, 44 messages logged, xml disabled,
                     filtering disabled
    Monitor logging: level debugging, 0 messages logged, xml disabled,
                     filtering disabled
    Buffer logging: disabled, xml disabled,
                    filtering disabled
    Logging Exception size (4096 bytes)
    Count and timestamp logging messages: disabled
    Trap logging: level informational, 48 message lines logged
cme_router#
cme_router#sh ip dhc con
IP address        Detection method   Detection time          VRF
192.168.2.1       Ping               Feb 28 2002 03:29 AM                       
cme_router#
 
Incidentally..
cme_router#sh clock
01:51:51.319 AEST Sat Oct 11 2014
 
HTH. Thanks in advance :) 
 
 
 

switch on logging conf tlogg

switch on logging

 

conf t

logg buff deb 100000

exi

wr

clea logg

disconnect and connect phones

sh logg

 

is this phones supported?

is this phone supported?

 

conf t

telephony-serv

ephone 10

type ?

 

New Member

Sorry for the late reply.

Sorry for the late reply. Didn't see your second post.

Used your commands but ephone command not available under telephony-service.

Ephone goes under global

Ephone goes under global config not telephony-service. Try removing your load command and see if that helps. If you are not seeing any TFTP events then there is a communication issue between the phone and TFTP server. I would recommend posting the full running config if you want to get this problem resolved.

New Member

Removed load commandStrange

Removed load command

Strange about your communication issue between TFTP and phone as phone gets IP address and is pingable from router

Anyway. Attached is full running config

Thanks again Michael. Much appreciated :)

ip dhcp pool Voice_Scope

ip dhcp pool Voice_Scope
   network 192.168.2.0 255.255.255.0
   default-router 192.168.0.12
 must be     default-router 192.168.2.2

 

I also do foolprof config

I do add option 150 to data network to

Here are some changes I would

Here are some changes I would suggest making:

!(removed .sbin on the alias)

tftp-server flash:CP7912060000SCCP050124A.sbin alias CP7912060000SCCP050124A

!(changed source address to your voice VLAN and specified load with new alias)

telephony-service
no ip source-address 192.168.0.12 port 2000
 ip source-address 192.168.2.2 port 2000
 load 7912 CP7912060000SCCP050124A

!(Recommend to specify this interface as the h323 gateway)

interface FastEthernet0/0.2
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 192.168.2.2

 

Also make sure your files are available with tftp-server which looks like this for a different phone model:

tftp-server flash:apps42.9-2-1TH1-13.sbn
tftp-server flash:cnu42.9-2-1TH1-13.sbn
tftp-server flash:cvm42sccp.9-2-1TH1-13.sbn
tftp-server flash:dsp42.9-2-1TH1-13.sbn
tftp-server flash:jar42sccp.9-2-1TH1-13.sbn
tftp-server flash:SCCP42.9-2-1S.loads

New Member

Evening Michael,Thanks for

Evening Michael,

Thanks for your reply.

Changed settings as requested.

cme_router#debug tftp events
TFTP Event debugging is on
cme_router#

cme_router#sh ephone registered

No ephone in specified type/condition.

cme_router#

cme_router#sh ephone unregistered


ephone-1 Mac:0017.9570.8E67 TCP socket:[-1] activeLine:0 UNREGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
IP:0.0.0.0 0 Unknown 0  keepalive 0 max_line 0

cme_router#

HTH :) Thanks again

Did you change default-router

Did you change default-router and option 150 ip in your DHCP config yet? Still showing as 0.12

New Member

Hi Michael,That has worked.

Hi Michael,

That has worked. This is so "cool". The phone has "finally" registered. Wow. What an awesome moment. Tried to make a phone call. Has a tone on the line but called local number to nothing. Have to troubleshoot.

New Member

Sorry Tagir, I didn't see the

Sorry Tagir, 

I didn't see the last entry

log buffered deb 100000 gives invalid input 

Tried 

log buffered def 100000 gives invalid input

And log buffered 100000 gives Ambiguous command

610
Views
0
Helpful
18
Replies