Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Phone keys not triggering any action when prompted by any external IVR

                

       

Hi everyone,

Please I have a Voip network that has a CME Router 2921. Calling out and receiving through the PSTN works fine but I notice that whenever any of the phone calls an outside number that is using IVR (eg calling help lines that has auto-attendant saying press 1 for xxx, press 2 for yyy, and so on) and being prompted to press different keys for various options. Non of the keys would give any response. These non-response is the same for any IVR enabled public number that I call from the phones in the network. When I use my GSM phone to call such numbers my call was directed appropriately after pressing the keys as prompted by the voice prompt. Is there any special configuration that has to be done on CME to allow this to work?

Here is an excerpt of the CME router config

hostname CME

!

boot-start-marker

boot-end-marker

!

!

card type e1 0 0

!

!

no ipv6 cef

ip source-route

ip cef

!

!

no ip domain lookup

ip domain name yourdomain.com

multilink bundle-name authenticated

!

isdn switch-type primary-net5

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-

revocation-check none

rsakeypair TP-self-signed-

!

voice-card 0

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service h225-notify cid-update

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

sip

  bind control source-interface GigabitEthernet0/1

  bind media source-interface GigabitEthernet0/1

  registrar server expires max 3600 min 120

!

!

voice register global

mode cme

source-address 10.19.0.2 port 5060

max-dn 4

max-pool 2

load 9971 sip9971.9-1-1SR1.loads

load 9951 sip9951.9-1-1SR1.loads

authenticate register

authenticate realm all

time-format 24

date-format D/M/Y

tftp-path flash:

create profile sync 0008765166362568

ntp-server 64.209.210.20 mode directedbroadcast

!

voice register dn  1

number 3814

name User1

label User1

!

voice register dn  2

number 3850

name User2

label User2

!

voice register pool  1

id mac D911.BDF1.6430

type 9951

number 1 dn 1

cor incoming loc-mob default

dtmf-relay sip-notify

username cisco password cisco

codec g711ulaw

no vad

!

voice register pool  2

id mac A321.30BB.4E7D

type 9971

number 1 dn 2

cor incoming all default

dtmf-relay sip-notify

username cisco password cisco

codec g711ulaw

no vad

!

!

!

voice translation-rule 1

rule 1 /3333850/ /3850/

rule 2 /013333850/ /3850/

rule 3 /3333851/ /3851/

rule 4 /013333851/ /3851/

rule 5 /3333852/ /3852/

rule 6 /013333852/ /3852/

!

voice translation-rule 2

rule 1 /3850/ /013333850/

rule 2 /3852/ /013333852/

rule 3 /380[1-9]/ /013333851/

rule 4 /381[0-5]/ /013333851/

rule 5 /3851/ /013333851/

!

!

voice translation-profile IN

translate called 1

!

voice translation-profile OUT

translate calling 2

!

!

hw-module pvdm 0/0

!

!

redundancy

!

!

controller E1 0/0/0

pri-group timeslots 1-10,16

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.19.0.2 255.255.255.252

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/2

ip address a.b.c.d 255.255.255.224

ip access-group OUTSIDE in

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bchan-number-order ascending

isdn outgoing display-ie

no cdp enable

!

router rip

version 2

network 10.0.0.0

default-information originate

no auto-summary

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source list 1 interface GigabitEthernet0/2 overload

ip route 0.0.0.0 0.0.0.0 a.b.c.e

!

ip access-list extended OUTSIDE

deny   tcp any any eq 1720

deny   tcp any any eq 5060

deny   udp any any eq 5060

deny   tcp any any eq 5061

permit ip any any

!

access-list 1 permit 10.0.0.0 0.255.255.255

!

!

tftp-server flash:flash/dkern9951.100609R2-9-1-1SR1.sebn alias dkern9951.100609R2-9-1-1SR1.sebn

tftp-server flash:dkern9951.100609R2-9-1-1SR1.sebn

tftp-server flash:kern9951.9-1-1SR1.sebn

tftp-server flash:rootfs9951.9-1-1SR1.sebn

tftp-server flash:sboot9951.031610R1-9-1-1SR1.sebn

tftp-server flash:sip9951.9-1-1SR1.loads

tftp-server flash:skern9951.022809R2-9-1-1SR1.sebn

tftp-server flash:dkern9971.100609R2-9-1-1SR1.sebn

tftp-server flash:kern9971.9-1-1SR1.sebn

tftp-server flash:rootfs9971.9-1-1SR1.sebn

tftp-server flash:sboot9971.031610R1-9-1-1SR1.sebn

tftp-server flash:sip9971.9-1-1SR1.loads

tftp-server flash:skern9971.022809R2-9-1-1SR1.sebn

!

control-plane

!

voice-port 0/0/0:15

translation-profile incoming IN

!

mgcp profile default

!

dial-peer cor custom

name local

name mobile

name intern

!

dial-peer cor list mobile

member mobile

!

dial-peer cor list local

member local

!

dial-peer cor list intern

member intern

!

dial-peer cor list all

member local

member mobile

member intern

!

dial-peer cor list loc-mob

member local

member mobile

!

dial-peer voice 100 pots

incoming called-number .

direct-inward-dial

!

dial-peer voice 200 pots

corlist outgoing local

translation-profile outgoing OUT

destination-pattern 9[2-9]......

port 0/0/0:15

forward-digits 7

!

dial-peer voice 300 pots

corlist outgoing mobile

translation-profile outgoing OUT

destination-pattern 90..........

port 0/0/0:15

forward-digits 11

!

dial-peer voice 400 pots

corlist outgoing intern

translation-profile outgoing OUT

destination-pattern 900T

port 0/0/0:15

prefix 00

!

gatekeeper

shutdown

!

telephony-service

no auto-reg-ephone

max-ephones 13

max-dn 30

ip source-address 10.19.0.2 port 2000

system message

time-format 24

date-format dd-mm-yy

max-conferences 8 gain -6

call-forward pattern 3...

web admin system name admin password password

dn-webedit

time-webedit

transfer-system full-consult

transfer-pattern 3...

create cnf-files version-stamp 7960 Nov 28 2012 18:24:35

!

ephone-dn  1  dual-line

number 3801

label U1

name U1

corlist incoming loc-mob

!

ephone-dn  2  dual-line

number 3802

label U2

name Soa U2

corlist incoming loc-mob

!

ephone-dn  3  dual-line

number 3803

label U3

name U3

corlist incoming loc-mob

!

ephone-dn  4  dual-line

number 3804

label U4

name U4

corlist incoming loc-mob

!

ephone-dn  5  dual-line

number 3805

label U5

name U5

corlist incoming loc-mob

!

ephone-dn  6  dual-line

number 3806

label U6.

name 6U

corlist incoming loc-mob

!

ephone-dn  7  dual-line

number 3852

label U7

name U7

corlist incoming loc-mob

!

ephone-dn  8  dual-line

number 3808

label U8

name U8

corlist incoming loc-mob

!

ephone-dn  9  dual-line

number 3809

label U9

name U9

corlist incoming loc-mob

!

ephone-dn  10  dual-line

number 3810

label U10

name U10

corlist incoming loc-mob

!

ephone-dn  11  dual-line

number 3851

label U11

name U11

corlist incoming loc-mob

!

ephone-dn  12  dual-line

number 3812

label U12

name U12

corlist incoming loc-mob

!

ephone-dn  13  octo-line

number 3813

label U13

name U13

corlist incoming loc-mob

!

ephone  1

mac-address D76A.EA99.51BD

type 7911

button  1:1

!

ephone  2

mac-address D76A.EA99.025E

type 7911

button  1:2

!

ephone  3

mac-address D76A.EA99.0212

type 7911

button  1:3

!

ephone  4

mac-address D76A.EA99.8AE8

type 7962

button  1:4

!

ephone  5

mac-address D76A.EA99.1849

type 7962

button  1:5

!

ephone  6

mac-address D76A.EA99.1705

type 7962

button  1:6

!

ephone  7

mac-address D76A.EA99.8AF4

type 7962

button  1:7

!

ephone  8

mac-address D76A.EA99.54D3

type 7911

button  1:8

!

ephone  9

mac-address D76A.EA99.4A68

type 7911

button  1:9

!

ephone  10

mac-address D76A.EA99.50DF

type 7911

button  1:10

!

ephone  11

mac-address D76A.EA99.50D4

type 7911

button  1:11

!

ephone  12

mac-address D76A.EA99.50DE

type 7911

button  1:12

!

ephone  13

mac-address D76A.EA99.A567

button  1:13

1 REPLY

Phone keys not triggering any action when prompted by any extern

Hi Jacob,

instead of 'dtmf-relay sip-notify', could you please try 'dtmf-relay rtp-nte' under voice register pool 1&2 and let me know how it works?

//Suresh Please rate all the useful posts.
211
Views
0
Helpful
1
Replies
CreatePlease to create content