Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Phone registering with gateway - how to reregister ?

Hi Everone,

I am running out a problem.

One of my user complained that his phone 7941 (sccp) is showing "SRST Mode - Limited Access" on the display and he is not able to make or receive calls. When I verified in the cucm (ver 8.5) i couldn't find the phone. Then after verifying I could see that the phone is registered with the gateway (wscmm-i6s-mz.124-15.T14.bin).

xxxgw001-cmm#sh ephone summary

hairpin_block:

ephone-9 Mac:0022.1111.2222 TCP socket:[1] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 debug:019.111.11.101 7941   keepalive 6275  1:1  CM Fallback

Max 240, Registered 1, Unregistered 3, Deceased 5, Sockets 1
ephone_send_packet process switched 0


Max Conferences 16 with 0 active (16 allowed)
Skinny Music On Hold Status
Active MOH clients 0 (max 600), Media Clients 0, B-ACD Clients 0
No MOH file loaded


xxxgw001-cmm#sh ephone registered


ephone-9 Mac:0022.1111.2222 TCP socket:[1] activeLine:0 REGISTERED in SCCP ver 17 and Server in ver 8
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:19.111.11.101 14847 7941   keepalive 6309 max_line 2
button 1: dn 1  number 1234567  CM Fallback CH1   IDLE

Could any one help me

1. To reregister this phone with the CUCM

2. Why it is showing registered with gateway and it is not in the cucm.

3. do I have to configure the phone in CUCM ?

thanks,

Karthik

3 REPLIES

Re: Phone registering with gateway - how to reregister ?

Soory this phone is configured on CUCM?

Only this phone is presenting this issue?

Try to disconnect and connect the network cable...

VIP Super Bronze

Re: Phone registering with gateway - how to reregister ?

I have seen this when the ITL - used with the TVS service - is messed up. The phone had a previous TFTP configuration file (which is the only way it knows about the SRST reference) but is now rejecting the TFTP servers and proceeds down the list to SRST which has no certificate. If you registered this phone to another CUCM 8.0+ cluster this would also cause this behavior.

The short answer is that you can try clearing the ITL from the phone (Settings > Security Settings > CTL/ITL List > **# > Erase > Restart. This will tell it to blindly accept whatever ITL the TFTP server attempts to give it again. As long as the ITL correctly generated the phone will register back to CUCM then.

Before doing that though you should make sure this is not suggesting a larger problem. When I saw this in the past it followed a DRS restore to move the cluster from MCS to UCS hardware. In that situation the first cluster subscriber that was restored uploaded all of the nodes' certificates into Informix, not just it's own. This broke the ITL file and essentially prevented any changes that impacted the TFTP configuration files of phones from taking place. To test this you can run 'show itl' from the CLI of each CUCM node. If it reports back normal and complete you're likely in the clear. If it reports an error you should call TAC. The real resolution is to delete certificates that got restored to the wrong nodes and then restart the Change Notification and TVS services. I'm only saying to call TAC so they can ensure you don't delete the wrong certs (i.e. do NOT regenerate certificates!) Once the ITL is back in order the phone should accept TFTP configs and register to CUCM.

New Member

Re: Phone registering with gateway - how to reregister ?

Hi Everyone..thanks for the reply. I sorted out the issue.

Actually the phone was deleted from the CUCM and the user tried to connect it. since it was in older firmware and there was no entry, the phone tried to register and failed. I re-added the phone to the cucm and did a reset on the gateway to re-register the phone back. The phone got rest and started upgrading to sccp41.9-2... and the phone is up and working.

Thanks again for your time.

Regards,

Karthik

619
Views
0
Helpful
3
Replies
CreatePlease to create content