Cisco Support Community
Community Member

Please save my hair!

I am having an issue getting a 7975 to register with CME 8.8... It worked fine when the phone was directly plugged into a switch module on the router, but now that I have the phone on my desk, and the 2911 is in the DC, the phone is in a registration loop...

If I run "debug voice register events\errors" I am consistantly getting the line "Contact doesn't match any pools" & "auth absent"...

Under the command "show voice register pool X" it show's that there hasn't been any registration attempts to the configured pool:

Pool Tag 3


  Mac address is 108C.CF75.D8B5

  Type is 7975

  Number list 1 : DN 3

  Proxy Ip address is

  DTMF Relay is enabled, sip-notify

  Call Waiting is enabled

  DnD is disabled

  Video is disabled

  Camera is disabled

  Busy trigger per button value is 0

  Description is Hidehoo!

  keep-conference is enabled

  registration expires timer max is 3600 and min is 60

  username 1112 password cisco

  kpml signal is enabled

  Lpcor Type is none

  Transport type is udp

  service-control mechanism is not supported

  Registration method: per line

  Privacy feature is not configured.

  Privacy button is disabled

  conference admin: no

  conference add mode: all

  conference drop mode: never

  Reason for unregistered state:

       No registration request since last reboot/unregister

  paging-dn: config 0 [multicast]  effective 0 [multicast]

Dialpeers created:


  Active registrations  : 0

  Total SIP phones registered: 0

  Total Registration Statistics

    Registration requests  : 0

    Registration success   : 0

    Registration failed    : 0

    unRegister requests    : 0

    unRegister success     : 0

    unRegister failed      : 0

    Attempts to register

Yet I have what appears to be all the requisite commands per my internet browsings:

voice service voip

allow-connections sip to sip

no supplementary-service sip handle-replaces

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none


  bind control source-interface Loopback8

  bind media source-interface Loopback8

  registrar server


voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8



voice register global

mode cme

source-address port 5060

timeouts interdigit 3

max-dn 100

max-pool 50

load 7975 SIP75.9-2-3S

authenticate register

authenticate realm all

timezone 8

tftp-path flash:

file text

create profile sync 0004336253345316

user-locale 1 US load CME-locale-en_US-English-

ntp-server mode directedbroadcast


voice register dn  3

number 1112

name Yehaa! 1112

label Yehaa! 1112


voice register pool  3

id mac 108C.CF75.D8B5

type 7975

number 1 dn 3

dtmf-relay sip-notify

voice-class codec 1

username 1112 password cisco

description Hidehoo!

no vad

What am I doing wrong!?... I came across the Cisco site below that references something similar to what I am experiencing, yet the 7975 doesn't have the ability (that I can see atleast) like the 7960 has to change the username\password via the settings button:

I did scp down the xml file for the phone from the router and the username\password combo are exactly the same as those define in the voice register pool 3...

Via the command "debug ccsip message" I am showing the following:

000679: Jul 12 17:39:54.371: //183/B1ED40A2806E/SIP/Msg/ccsipDisplayMsg:


u SIP/2.0 401 Unauthorized

Via: SIP/2.0/UDP;branch=z9hG4bK1c1abccc

From: <sip:1112@>;tag=108ccf75d8b5000316a4e8f8-a0ab50dc

To: <sip:1112@>;tag=BC5974-1889

Date: Thu, 12 Jul 2012 23:39:54 GMT

Call-ID: 108ccf75-d8b50002-d0eb8ea8-581803ec@

Server: Cisco-SIPGateway/IOS-15.2.3.T


WWW-Authenticate: Digest realm="all",nonce="78DAD3D10012D5BE",algorithm=MD5,qop="auth"

Content-Length: 0

I apprecate any help you can lend!


Please save my hair!


Instead of command under voice reg pool

username 1112 password cisco

try ans use command

username 1112 password 1112

Let me know if it works.


Ronak Patel

Rate helpful posts.

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
Community Member

Please save my hair!

Hey Ronak,

Thanks very much for taking the time to help me out! I apprecate it.

So, I finally got the phones to register with CME and the solution ended up being associated with that fact that I am running a VRF on the 2911... Arrgh... I ended up coming across a document that indicated the need to designate a VRF as a "voice" vrf using the command "voice vrf XXXX". After doing this, the phones registered great.

Thanks for your help!

Hall of Fame Super Gold

Please save my hair!

Beside the issue at hand.. Shy SIP? You loose features, and gain trouble compared to using SCCP..

CreatePlease to create content