Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Posted Config Have Only Two Small SIP Issues CME 4.1

I really got as far as I could with all the research I did, initially not knowing anything about integrating two internet based SIP phone numbers from Flowroute.com into my 1760 CME 4.1 I am only left with two issues. When I call a POTS line from my CME the call is perfect. Am I missin something from this config?

When I call my CME FROM a POTS line, the CME phone rings, you answer it but hear nothing either way. No voice either way.

When I call my CME FROM a POTS line, don't answer the CME and hang up the POTS line, the CME phone does NOT stop ringing.

Here is my config. Any suggestions?

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Call_Manager-B

!

boot-start-marker

boot-end-marker

!

no logging console

enable secret 5 $1$AL1E$eyIJx.a68KVuC1N762Zre/

!

no aaa new-model

clock timezone EST -4

!

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 172.16.3.1 172.16.3.9

ip dhcp excluded-address 172.16.4.1 172.16.4.9

!

ip dhcp pool DATA_SCOPE

network 172.16.4.0 255.255.255.0

default-router 172.16.4.1

!

ip dhcp pool VOICE_SCOPE

network 172.16.3.0 255.255.255.0

default-router 172.16.3.1

option 150 ip 172.16.3.1

!

!

no ip domain lookup

multilink bundle-name authenticated

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip refer

sip

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

!

!

!

archive

log config

hidekeys

!

!

!

translation-rule 1

Rule 0 ^91 1

!

!

interface Ethernet0/0

description Ethernet To Internet Through Linksys

ip address 192.168.6.250 255.255.255.0

full-duplex

!

interface FastEthernet0/0

no ip address

speed auto

!

interface FastEthernet0/0.10

description Router Interface For Voice Vlan

encapsulation dot1Q 10

ip address 172.16.3.1 255.255.255.0

ip helper-address 172.16.4.5

!

interface FastEthernet0/0.50

description Router interface For Data Vlan

encapsulation dot1Q 50

ip address 172.16.4.1 255.255.255.0

!

interface Ethernet1/0

description Telnet Management

ip address 192.168.2.110 255.255.255.0

half-duplex

ntp broadcast client

!

ip forward-protocol nd

ip route 216.115.0.0 255.255.0.0 192.168.6.1

!

ip http server

no ip http secure-server

ip http path flash:/gui

!

tftp-server flash:/phone/7912/CP7912080001SCCP051117A.sbin alias CP7912080001SCCP051117A.sbin

tftp-server flash:/ringtones/RingList.xml alias RingList.xml

tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml

tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw

tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw

tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw

tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw

tftp-server flash:/ringtones/Analog2.raw alias Analog2.raw

tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw

tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw

tftp-server flash:/gui/speeddial.xml alias speeddial.xml

!

control-plane

!

!

dial-peer voice 1 voip

destination-pattern 91..........

translate-outgoing called 1

voice-class codec 1

session protocol sipv2

session target ipv4:216.115.69.144

dtmf-relay sip-notify

!

num-exp 2001 17275652954

num-exp 2002 18134982327

sip-ua

authentication username xxxxxxxx password 7 xxxxxxxxxxxx

no remote-party-id

registrar ipv4:216.115.69.144 expires 3600

!

!

telephony-service

load 7912 CP7912080001SCCP051117A

max-ephones 4

max-dn 12

ip source-address 172.16.3.1 port 2000

max-conferences 4 gain -6

moh music-on-hold.au

multicast moh 239.23.4.10 port 2000

transfer-system full-consult

transfer-pattern 200.

secondary-dialtone 9

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn 1

number 17275652954

label 727-565-2954

name PHONE-3

!

!

ephone-dn 2

number 18134982327

label 813-498-2327

name PHONE-4

!

!

ephone 1

mac-address 0015.C617.CE82

button 1:1

!

!

!

ephone 2

mac-address 0015.63FF.5284

button 1:2

!

7 REPLIES
New Member

Posted Config Have Only Two Small SIP Issues CME 4.1

One Way - No Way Audio more often than not is caused by IP Routing issues. There is no details mentioned about the call flow so would be able to provide much of an input, but one thing which you might want to start checking with is what is the route between the IP Phone and the last IP hop before the call is sent to POTS (TDM) network.

New Member

Posted Config Have Only Two Small SIP Issues CME 4.1

If this router were literally plugged into the network and one phone hanging off of the router, I would say your situation is impossible. But, given I've had a 1760 that only comes with one ethernet port and used a SIP ITSP like you are now, I know there are external factors involved. For example, take a look at the device servicing your internet (NAT device). Is there any Stateful Packet Inspection (SPI firewall) enabled for your 1760? A lot of the newer SOHO routers have two modes of firewall (regular and SPI). You might even have to put the 1760 in the DMZ port just to rule it out. Also, if your NAT router has any type of SIP ALG enabled, turn it off. SIP ALG inserts packets into the SIP traffic that will break phone calls. Lastly, if your phone is hanging off of anything after the 1760 that does any type of routing, make sure the IP routing from the NAT router all the way to the phone and backwards is symmetric. Your 1760 isn't incredibly complex so I'm a firm believer this is something external to the 1760. Once you have two way audio, then you can troubleshoot issues such as MOH, supplementary services, codec negotiation, etc.

New Member

Posted Config Have Only Two Small SIP Issues CME 4.1

I will look into the Linksys part of this very closely. When I make a call form the 1760 to a POTS line, I can hear audio both ways (codecs are working), I can stream hold music to the POTS phone and I can trasfer the call from one CME extension to another. Caller ID works in both dierections too. It's the reverse that has the problem. When I make a call from POTS line to CME, it rings the proper CME phone, displays caller ID but no audio in either direction once you answer. If you don't answer the CME phone and hang up the POTS phone, the CME phone doesn't stop ringing.

New Member

Posted Config Have Only Two Small SIP Issues CME 4.1

I fixed it. Everything works perfect now. Instead of a default route of ip route 216.115.0.0 255.255.0.0 192.168.6.1, I used ip route 0.0.0.0 0.0.0.0 192.168.6.1  I looked at the CCSIP debug messages and saw that ip's were failing for some SIP communications. I thought that just because the flowroute ip address was 216.115.69.144 I could use the 216.215.0.0 in my static route. Obviously not.

New Member

Posted Config Have Only Two Small SIP Issues CME 4.1

Glad everything worked out.

New Member

Posted Config Have Only Two Small SIP Issues CME 4.1

Did this solution also stop your CME phone ringing when you call your CME from POTS and hang up?

New Member

Posted Config Have Only Two Small SIP Issues CME 4.1

After further investigation I was not getting the proper SIP BYE message for the Cisco phone to stop ringing when the POTS line hung up. It was also determined that I wasn't quite registering properly with my SIP provider (Port number among other things I suppose). After researching many configs I put this together and the SIP BYE messages were good and my registration was better and the phone stopped ringing. There isn't just one config out there that works perfectly. I had to experiment and pull statements from one config and another and put this together (and of course looking up what the statements actually did).. A good learning process..

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip refer

redirect ip2ip

sip

registrar server expires max 160 min 160

localhost dns:sip.flowroute.com:5060

dial-peer voice 2 voip

destination-pattern .T

redirect ip2ip

voice-class codec 1

voice-class sip localhost dns:sip.flowroute.com

voice-class sip dtmf-relay force rtp-nte

session protocol sipv2

session target dns:sip.flowroute.com

incoming called-number .%

dtmf-relay rtp-nte

no vad

sip-ua

credentials username xxxxxxxx password 121C2F251F0C2D5D0D2D000000 realm sip.flowroute.com

authentication username xxxxxxxx password 7 121C2F251F0C2D5D0D2D000000

nat symmetric check-media-src

no remote-party-id

retry invite 2

retry register 10

timers connect 100

registrar ipv4:216.115.69.144 expires 60

connection-reuse

host-registrar

ephone-dn 1

number 17275652954 secondary 2001 no-reg both

!

!

ephone-dn 2

number 18134982327 secondary 2002 no-reg both

!

!

1305
Views
0
Helpful
7
Replies
CreatePlease to create content