Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Prefixing 88 on FXS port calls not working

Hi,

I've followed several cisco documents and double checked my translations, but on the FXS voice port the translation-profile is not prefixing 88 on to the number dialed from device on FXS port. I want the calls to hit the 201 dial peer, which then sends the call to call manager. I have a PSTN 91... dial peer for outbound calls so purpose of this to steer calls from FXS ports to hit CUCM first.

Any ideas?

voice translation-rule 1

rule 1 /9/ //

!

voice translation-rule 2

rule 1 /999/ //

!

voice translation-rule 3

rule 1 /\(.*\)/ /88\1/

!

voice translation-rule 4

rule 1 /88/ //

!

!

voice translation-profile Prefix8

translate called 3

!

voice translation-profile Strip88

translate called 4

!

voice-port 0/0/0

translation-profile incoming Prefix8

dial-peer voice 201 voip

destination-pattern 88T

modem passthrough protocol codec g711ulaw

session protocol sipv2

session target ipv4:10.10.10.10

voice-class sip profiles 1

dtmf-relay rtp-nte

codec g711ulaw

fax-relay sg3-to-g3

fax rate 9600

ip qos dscp cs3 signaling

no vad

The test commands shows the translation rule prefixing the 88 

GATEWAY#test voice translation-rule 3 915556667777

Matched with rule 1

Original number: 915556667777   Translated number: 88915556667777

Original number type: none      Translated number type: none

Original number plan: none      Translated number plan: none

7 REPLIES
Hall of Fame Super Gold

Prefixing 88 on FXS port calls not working

Some IOS version have bugs for which translation profiles are not applied, so you have to update.

You can also rewrite the rule more efficently as:

rule 1 // /88/

Prefixing 88 on FXS port calls not working

Do you have a bug id for this behavior?

Were on recent 15.1T IOS and I've gone through all the release notes for 15.1T, 15.2, 15.3 and not seeing anything for FXS ports or translation rules/profiles.

Do you know of an alterate way to do this that doesn't require a bunch of dial peer magic? I also tried the simpler rule earlioer and neither work, and I also tried the old style translation rule command on fxs ports with no success either.

Erick

New Member

Prefixing 88 on FXS port calls not working

I don't see that the rule has been applied to the dial peer. Take a look at the following document:

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080325e8e.shtml

RG

Prefixing 88 on FXS port calls not working

The translation profile is applied to the FXS voice-port directly I want the 88 prefixed to the call on all calls from devices on that FXS port.

so if a FAX machine/etc dials 91XXXYYYZZZZ the voice-port translation adds 88 to it, so it becomes 8891XXXYYYZZZZ then hits the 88T dial peer to go to call manager. Right now, it is not hitting this dial peer and hitting a 91T dial peer and going to PSTN directly.

New Member

Re: Prefixing 88 on FXS port calls not working

Hi ebergquist,

Try a translation rule (old school way of doing it) rather than a voice translation rule and profile.  I've seen this work where the new method does not.  Eg:

!

translation-rule 1

rule 1 . 88

!

!

voice-port 0/0/0

description FXS port

translate called 1

!

Regards,

Jonathan

Prefixing 88 on FXS port calls not working

Thanks, The old style translation rule worked. I had tried that before but forgot the rule syntax was different.

Hall of Fame Super Gold

Prefixing 88 on FXS port calls not working

Which exact IOS are you running? So we know it's broken.

298
Views
0
Helpful
7
Replies
CreatePlease login to create content