Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

PRI (E1) Mexico - MGCP gateway

Has anyone ever configured VWIC MFT 1-Port E1/T1, 2811 router. The router is currently installed in Mexico, and we are trying to connect to PSTN. The provider is Telmex. The gateway is configured via MGCP.

Here is a part of the config:

network-clock-participate wic 0

network-clock-select 1 E1 0/0/0

!

isdn switch-type primary-net5

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-31 service mgcp

!

!

interface Serial0/0/0:15

no ip address

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

voice-port 0/0/0:15

cptone MX

Here is the output of the debug isdn q921

*May 6 20:30:01 CET: ISDN Se0/0/0:15 Q921: L2_EstablishDataLink: sending SABME

*May 6 20:30:01 CET: ISDN Se0/0/0:15 Q921: User TX -> SABMEp sapi=0 tei=0

*May 6 20:30:02 CET: ISDN Se0/0/0:15 Q921: User TX -> SABMEp sapi=0 tei=0

*May 6 20:30:03 CET: ISDN Se0/0/0:15 Q921: User TX -> SABMEp sapi=0 tei=0

*May 6 20:30:04 CET: ISDN Se0/0/0:15 Q921: User TX -> SABMEp sapi=0 tei=0

*May 6 20:30:11 CET: ISDN Se0/0/0:15 Q921: L2_EstablishDataLink: sending SABME

The output of show controllers e1:

E1 0/0/0 is up.

Applique type is Channelized E1 - balanced

No alarms detected.

alarm-trigger is not set

Version info Firmware: 20060707, FPGA: 13, spm_count = 0

Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (97 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 1 15 minute intervals):

0 Line Code Violations, 0 Path Code Violations,

1 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

1 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

The tei esthablisment in not been done. Telco says they received a Multiframe-error.

Thanks a lot.

5 REPLIES

Re: PRI (E1) Mexico - MGCP gateway

Did you verify w/telco the correct ISDN switch-type to use, as well as the correct framing and linecode settings?

Re: PRI (E1) Mexico - MGCP gateway

The framing and linecode settings are correct NO-CRC and HDB3 the onlything about ISDN type is that the telco gives a strange answer about that. The only thing is that the voice gateway is connected via an CAB-E1-RJ45BNC= to the Telmex equipment. On Cisco I have read about a R2 connection in Mexico but I don't know if this is for voice calls.

Re: PRI (E1) Mexico - MGCP gateway

Try playing with the changing the ISDN switch type, make sure they match in the call manager and the gateway. However, Im not too familiar with R2 signaling, as I am here in the US, but I do know that you should check with your telco to get the exact settings you need to configure. example configuration

ds0-group 0 timeslots 1-31 type [line-signaling-type] [interregister-signaling-type] ani service mgcp

New Member

Re: PRI (E1) Mexico - MGCP gateway

Hi, R2 is also for voice. Here is an example for the E1 controller in Mexico.

framing NO-CRC4

clock source line primary

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 1

unused-abcd 0 1 1 1

country telmex

seizure-ack-time 30

disconnect-tone

category 2

signal-end-to-end

answer-signal group-b 1

caller-digits 4

dnis-digits min 4 max 13

ani-digits min 0 max 10

dnis-complete

answer-guard-time 750

ani-timeout 10

groupa-callerid-end

HTH

If this helps pls rate

Vhilario

New Member

According to my researsches

According to my researsches it is impossible to set the GW as MGCP up. Is this correct?

1327
Views
0
Helpful
5
Replies
CreatePlease to create content