Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Problem calling to PSTN with MGCP gatway

For some reason I cant call to an outside line. After dialing an outside line I hear the busy tone.

debug mgcp packets and debug mgcp error are giving me the following response:

*May 1 09:36:22.439: MGCP Packet received from 10.0.1.100:2427--->

CRCX 113 BRI/S0/SU2/P0/1@VoiceGW MGCP 0.1

C: D000000001000040000000F50000000b

M: inactive

<---

*May 1 09:36:22.439: Failed to create voice call leg, rc = -25!!!

*May 1 09:36:22.439: Following traceback is for INFO ONLY. -Traceback= 0x40A0E0A8 0x40A33EBC 0x40A27C8C 0x40A29BDC 0x40A0FE88 0x409D05CC 0x409D19A4 0x409D42C8 0x42110180 0x42110164

*May 1 09:36:22.439: MGCP Packet sent to 10.0.1.100:2427--->

400 113 Voice call setup failed-Incoming-Outgoing call collision

<---

*May 1 09:36:23.455: MGCP Packet received from 10.0.1.100:2427--->

CRCX 10113 BRI/S0/SU2/P0/1@VoiceGW MGCP 0.1

C: D000000001000040000000F50000000b

M: inactive

<---

*May 1 09:36:23.459: Failed to create voice call leg, rc = -25!!!

*May 1 09:36:23.459: Following traceback is for INFO ONLY. -Traceback= 0x40A0E0A8 0x40A33EBC 0x40A27C8C 0x40A29BDC 0x40A0FE88 0x409D05CC 0x409D19A4 0x409D42C8 0x42110180 0x42110164

*May 1 09:36:23

VoiceGW#.459: MGCP Packet sent to 10.0.1.100:2427--->

400 10113 Voice call setup failed-Incoming-Outgoing call collision

<---

*May 1 09:36:23.463: MGCP Packet received from 10.0.1.100:2427--->

DLCX 114 BRI/S0/SU2/P0/1@VoiceGW MGCP 0.1

X: 1

S:

<---

*May 1 09:36:23.463: MGCP Packet sent to 10.0.1.100:2427--->

250 114 already deleted connection

<---

I use the following hardware:

MCS 7800 series Server with OS 2000.4.4aSR5

Callmanager 4.2(3)

Cisco 2851 ISR Router

- PVDM2-48 in slot 0

- VIC2-2BRI-NT/TE in HWIC 2

- VWIC-1MFT-E1 in HWIC 0 (not in use)

Anyone any idea's?

1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

Re: Problem calling to PSTN with MGCP gatway

BRI backhaul is not supported in 12.4 train on 2800 series. You need a 12.4T image.

http://www.cisco.com/en/US/products/ps6441/products_configuration_guide_chapter09186a0080541c9f.html

12 REPLIES
Community Member

Re: Problem calling to PSTN with MGCP gatway

The gateway config is as follows:

Building configuration...

Current configuration : 4382 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname VoiceGW

Building configuration...

Current configuration : 4382 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname VoiceGW

!

boot-start-marker

boot system flash:/c2800nm-ipvoicek9-mz.124-13b.bin

boot-end-marker

!

enable secret xxx

!

no aaa new-model

clock timezone CET 1

clock summer-time CET recurring last Sun Mar 2:00 last Sun Oct 2:00 1

no network-clock-participate wic 0

network-clock-participate wic 2

!

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.0.1.1 10.0.1.50

ip dhcp excluded-address 10.0.10.1 10.0.10.50

ip dhcp excluded-address 10.0.11.1 10.0.11.50

ip dhcp excluded-address 10.0.20.1 10.0.20.50

ip dhcp excluded-address 10.0.21.1 10.0.21.50

!

ip dhcp pool Data

network 10.0.1.0 255.255.255.0

default-router 10.0.1.1

dns-server 195.85.130.161 195.35.128.5

!

ip dhcp pool DataBedrijf1

network 10.0.10.0 255.255.255.0

default-router 10.0.10.1

dns-server 195.85.130.161 195.35.128.5

option 150 ip 10.0.1.100

!

ip dhcp pool VoiceBedrijf1

network 10.0.11.0 255.255.255.0

default-router 10.0.11.1

option 150 ip 10.0.1.100

dns-server 195.85.130.161 195.35.128.5

!

ip dhcp pool DataBedrijf2

network 10.0.20.0 255.255.255.0

default-router 10.0.20.1

dns-server 195.85.130.161 195.35.128.5

!

ip dhcp pool VoiceBedrijf2

network 10.0.21.0 255.255.255.0

default-router 10.0.21.1

option 150 ip 10.0.1.100

dns-server 195.85.130.161 195.35.128.5

!

!

isdn switch-type basic-net3

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

username ap password xxx

archive

path flash:/archive/$h

maximum 14

write-memory

time-period 1440

!

!

controller E1 0/0/0

!

!

!

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.0.1.1 255.255.255.0

ip nat inside

!

interface GigabitEthernet0/0.10

encapsulation dot1Q 10

ip address 10.0.10.1 255.255.255.0

ip nat inside

!

interface GigabitEthernet0/0.11

encapsulation dot1Q 11

ip address 10.0.11.1 255.255.255.0

ip nat inside

!

interface GigabitEthernet0/0.20

encapsulation dot1Q 20

ip address 10.0.20.1 255.255.255.0

ip nat inside

!

interface GigabitEthernet0/0.21

encapsulation dot1Q 21

ip address 10.0.21.1 255.255.255.0

ip nat inside

!

interface GigabitEthernet0/1

ip address dhcp hostname CCM

ip nat outside

duplex auto

speed auto

!

interface BRI0/2/0

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn bind-l3 ccm-manager service mgcp

!

interface BRI0/2/1

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn bind-l3 ccm-manager service mgcp

!

!

ip http server

no ip http secure-server

ip nat inside source list 1 interface GigabitEthernet0/1 overload

!

Community Member

Re: Problem calling to PSTN with MGCP gatway

Wait for Show ISDN Status, but depending on your provider, it's possible that the command "isdn static-tei 0" is missing under the interface BRI.

Community Member

Re: Problem calling to PSTN with MGCP gatway

I'm using dynamic tei's. So thats not the problem. My ISDN interface is up and running.

Community Member

Re: Problem calling to PSTN with MGCP gatway

Config Continued:

access-list 1 remark NAT

access-list 1 permit 10.0.1.0 0.0.0.255

access-list 1 permit 10.0.10.0 0.0.0.255

access-list 1 permit 10.0.11.0 0.0.0.255

access-list 1 permit 10.0.20.0 0.0.0.255

access-list 1 permit 10.0.21.0 0.0.0.255

!

!

!

control-plane

!

!

!

voice-port 0/2/0

compand-type a-law

cptone NL

!

voice-port 0/2/1

compand-type a-law

cptone NL

!

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.0.1.100

ccm-manager config

!

mgcp

mgcp call-agent 10.0.1.100 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface GigabitEthernet0/0.1

mgcp bind media source-interface GigabitEthernet0/0.1

!

mgcp profile default

!

!

!

dial-peer voice 20 pots

service mgcpapp

direct-inward-dial

!

dial-peer voice 21 pots

service mgcpapp

direct-inward-dial

!

gateway

timer receive-rtp 1200

!

banner exec ^C

You are logged on on $(hostname) via VTY $(line).

^C

!

line con 0

exec-timeout 0 0

logging synchronous

login local

line aux 0

line vty 0 4

private

login local

terminal-type monitor

!

scheduler allocate 20000 1000

ntp update-calendar

ntp server 192.43.244.18

!

end

Re: Problem calling to PSTN with MGCP gatway

Can you paste a sh isdn status

Community Member

Re: Problem calling to PSTN with MGCP gatway

I wont be at work till friday so I cant give you an exact show isdn status. But I can tell you that layer 2 is up and that layer 3 is under callmanager control. Thats what i remember since my last show isdn status.

And btw when there is a problem with my isdn interface, it wont register with CCM.

Community Member

Re: Problem calling to PSTN with MGCP gatway

Could it be that I need to register the PVDM's in CCM?

Or does the gateway automatically use its local PVDM's like CCM Express?

Community Member

Re: Problem calling to PSTN with MGCP gatway

BRI backhaul is not supported in 12.4 train on 2800 series. You need a 12.4T image.

http://www.cisco.com/en/US/products/ps6441/products_configuration_guide_chapter09186a0080541c9f.html

Community Member

Re: Problem calling to PSTN with MGCP gatway

Ok, I'll try that tomorrow.

Community Member

Re: Problem calling to PSTN with MGCP gatway

This was indeed the solution to my problem!

Thanks!

Community Member

Re: Problem calling to PSTN with MGCP gatway

please can you post the runing configuration in your router ???

Community Member

Re: Problem calling to PSTN with MGCP gatway

I already did....

The only thing I changed later on was the following:

dial-peer voice 20 pots

service mgcpapp

direct-inward-dial

port 0/2/0 <------------- Added this line

!

dial-peer voice 21 pots

service mgcpapp

direct-inward-dial

port 0/2/1 <------------- Added this line

539
Views
0
Helpful
12
Replies
CreatePlease to create content