Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

problem of voice communication between a gateway 2901 and CUCM 8.5

hi 

i have the next problem

I have outgoing but not incoming calls, I have configured my gateway as h323 in callmanager I got discharged, I can make calls to the PSTN (outcoming) and everything works fine, but incoming calls do not work, and the carrier sends me a voice message, which tells me that the call can not be answered because the phone is off hook or repair. 

I've checked the settings on the gateway and everything looks good. 

I share the computer's configuration.

 

Building configuration...


Current configuration : 8555 bytes
!
! Last configuration change at 19:33:36 UTC Tue Mar 25 2014 by Cysco
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ############
!
boot-start-marker
boot-end-marker
!
!
card type e1 0 1
enable secret 4 kKt2Se69p1vj8oXsVcOb4nVtT/YpLyKoYfbXdt49ZWc
!
no aaa new-model
network-clock-participate wic 1 
!
ip cef
!
!
!
ip dhcp excluded-address 192.168.18.1
ip dhcp excluded-address 10.77.3.1
ip dhcp excluded-address 10.77.4.1
!
ip dhcp pool lan-user
 network 10.77.3.0 255.255.255.0
 default-router 10.77.3.1 
 dns-server 10.2.1.70 
!
ip dhcp pool movil-user
 network 10.77.4.0 255.255.255.0
 default-router 10.77.4.1 
 dns-server 10.2.1.70 
!
ip dhcp pool voice
 network 192.168.18.0 255.255.255.0
 dns-server 10.2.1.70 
 default-router 192.168.18.1 
 option 150 ip 192.168.12.10 192.168.12.11 
 domain-name ######.net
!
!
!
ip domain name ######.net
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice-card 0
 dsp services dspfarm
!
!
!
voice service voip
 no ip address trusted authenticate
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
 sip
  registrar server expires max 600 min 60
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g729r8
!
!
voice register global
 max-dn 200
 max-pool 15
!
voice register pool  10
 id network 192.168.18.0 mask 255.255.255.0
 preference 1
 proxy 192.168.18.1
 voice-class codec 1
!
voice moh-group 1
 moh flash:/CUCM(MoH).wav
 description Internal MOH
 multicast moh 239.1.3.2 port 16384 route 192.168.18.1
!
!
!
!
!
!
license udi pid CISCO2901/K9 sn FTX1809808V
hw-module pvdm 0/0
!
!
!
redundancy
!
!
!
!
!
controller E1 0/1/0
 framing NO-CRC4 
 ds0-group 0 timeslots 1-10 type r2-digital r2-compelled ani
 cas-custom 0
  country telmex
  category 2
  answer-signal group-b 1
  caller-digits 4
  dnis-digits min 1 max 4
  groupa-callerid-end
 description Controladora de voz a PSTN
!
ip ssh version 2
!
class-map match-any mark_datos-criticos
 match access-group name rpvm_datos-criticos
class-map match-any rpvm_datos-criticos
 match ip dscp cs2 
 match ip dscp af31 
 match ip dscp af32 
 match ip dscp af33 
class-map match-any rpvm_voz
 match ip dscp cs3 
 match ip dscp cs5 
 match ip dscp ef 
class-map match-any mark_voz
 match access-group name rpvm_voz
class-map match-any rpvm_business
 match ip dscp cs1 
 match ip dscp af21 
 match ip dscp af22 
 match ip dscp af23 
class-map match-any mark_business
 match access-group name rpvm_business
!
policy-map pa12_lan
 class mark_voz
  set ip dscp ef
 class mark_datos-criticos
  set ip dscp af32
 class mark_business
  set ip dscp af22
 class class-default
  set ip dscp default
policy-map rpvm_pa12_out
 class rpvm_voz
  police cir percent 25
   conform-action transmit 
   exceed-action drop 
 class rpvm_datos-criticos
  bandwidth percent 52 
  queue-limit 66 packets
 class rpvm_business
  bandwidth percent 16 
  queue-limit 20 packets
 class class-default
  bandwidth percent 1 
  queue-limit 32 packets
policy-map rpvm_pa12_in
 class rpvm_voz
  police cir percent 25
   conform-action transmit 
   exceed-action drop 
 class rpvm_datos-criticos
  police cir percent 50
   conform-action transmit 
   exceed-action transmit 
 class rpvm_business
  police cir percent 25
   conform-action transmit 
   exceed-action transmit 
!

!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description TRUNK-HACIA-SWITCH
 no ip address
 duplex full
 speed 1000
!
interface GigabitEthernet0/1.11
 description ADMON
 encapsulation dot1Q 11
 ip address 10.77.1.1 255.255.255.0
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.77.1.1
!
interface GigabitEthernet0/1.13
 description LAN-user
 encapsulation dot1Q 13
 ip address 10.77.3.1 255.255.255.0
!
interface GigabitEthernet0/1.14
 description movile-user
 encapsulation dot1Q 14
 ip address 10.77.4.1 255.255.255.0
!
interface GigabitEthernet0/1.16
 description voice
 encapsulation dot1Q 16
 ip address 192.168.18.1 255.255.255.0
!
interface Serial0/0/0
 bandwidth 512
 ip address 187.219.41.178 255.255.255.252
 encapsulation ppp
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 187.219.41.177
!
ip sla auto discovery
!
!
snmp-server community redes2000 RW
snmp-server enable traps entity-sensor threshold
snmp-server host 10.2.1.13 version 2c redes2000 
!
control-plane
!
call fallback active
!
voice-port 0/1/0:0
 !
 !
 !
!
ccm-manager music-on-hold
!
!
mgcp profile default
!
sccp local GigabitEthernet0/1.16
sccp ccm 192.168.12.11 identifier 2 priority 2 version 7.0 
sccp ccm 192.168.12.10 identifier 1 priority 1 version 7.0 
sccp
!
sccp ccm group 1
 bind interface GigabitEthernet0/1.16
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 2 register CFB_#####
 associate profile 1 register XCODE_######
!
dspfarm profile 1 transcode  
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 codec g722-64
 codec g729br8
 maximum sessions 4
 associate application SCCP
!
dspfarm profile 2 conference  
 codec g729br8
 codec g729r8
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 codec g722-64
 maximum sessions 2
 associate application SCCP
!
dial-peer voice 1 pots
 incoming called-number .
 direct-inward-dial
!
dial-peer voice 45 pots
 description CEL-LD
 shutdown
 destination-pattern 045..........
 port 0/1/0:0
 forward-digits all
!
dial-peer voice 3020 voip
 translation-profile outgoing 1
 destination-pattern 302..
 session target ipv4:192.168.12.10
 dtmf-relay h245-alphanumeric
 no vad
!
!
num-exp 7590 30202
sip-ua 
 registrar ipv4:192.168.18.1 expires 600
!
!
!
gatekeeper
 shutdown
!
!
call-manager-fallback
 max-conferences 4 gain -6
 transfer-system full-consult
 ip source-address 192.168.18.1 port 2000
 max-ephones 25
 max-dn 50 dual-line
 moh "flash0:/CUCM(MoH).wav"
 multicast moh 239.1.1.1 port 16384 route 192.168.18.0 192.168.18.1
!

 

 

the gateway model 2901 and the Version 15.0(1r)M16.

 

the Gateway has SRST configuration, so when the SRST is active all calls works fine outcoming and incoming.

 

thank for your attention, greetings!

 

 

8 REPLIES

Did you reset the H.323

Did you reset the H.323 gateway in CUCM after adding it?  Is the inbound CSS on the H.323 gateway okay?

New Member

Hi Brian  yes, i reset the

Hi Brian 

 

yes, i reset the gateway and the gateway okay

dude,  you have CUCM point to

dude,

 

 

you have CUCM point to:

 

interface GigabitEthernet0/1.11
 description ADMON
 encapsulation dot1Q 11
 ip address 10.77.1.1 255.255.255.0
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.77.1.1

 

looking at your h225 and 245 debugs the gateway seems to bind with GigabitEthernet0/1.16  which has a different I address all together. what interface is used to route traffic from your gateway to your CUCM 192.168.12.10?   you need to sort this out first and make it consistent.

 

 

 

Please remember to rate useful posts, by clicking on the stars below.

VIP Super Bronze

Can you please configur the

Can you please configur the ff

service sequence-numbers
service timestamps debug datetime localtime msec
logging buffered 10000000 debug
no logging console
no logging monitor
default logging rate-limit
default logging queue-limit

Then enale the ff debugs

1. debug isdn q931

2. debug voip ccapi inout

3.debug h225 asn1

4. debug h245 asn1

 

<Enable session capture to txt file in terminal program.> (such as Putty)

then do the ff:

terminal length 0

NB: you need to enable the logs at the same time. Once you are done, attach the logs here
show logging

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Also make sure the H.323

Also make sure the H.323 gateway is added in CUCM as 10.77.1.1 since that's the address you binded to.

New Member

of curse the gateway is added

of curse the gateway is added in CUCM

Cisco Employee

Hello Mauro,You need to check

Hello Mauro,

You need to check is the call reaching to the call-manager from GW side. Try to collect the debug on GW and traces and call-manager side to check status of the calls whether it has been reaching to CUCM and the error message.

 

on GW collect Debug H245 asn1 and h225 ans1 and CCM traces on CUCM.

 

Br,

Nadeem Ahmed

 

Br, Nadeem Please rate all useful post.
New Member

of the debug h245 send this:

of the debug h245 send this:

*Mar 25 22:17:46.327: //-1/208AA82F8057/CCAPI/cc_api_call_setup_ind_common:
   Sub Calling(TON=National, NPI=Unknown, Data=(, Length=34)
*Mar 25 22:17:46.327: //-1/208AA82F8057/CCAPI/cc_api_call_setup_ind_common:
   Sub Called(TON=Unknown, NPI=Data, DatAP"'(AP<3, Length=3)cch323_ip_best_local_address: IP 192.168.18.1 found for bound IDB GigabitEthernet0/1.16term mon

 

and the debug h225 send this:

*Mar 25 22:21:32.875: //-1/A79321E4806C/CCAPI/cc_api_call_setup_ind_common:
   Sub Calling(TON=National, NPI=Unknown, Data=(, Length=34)
*Mar 25 22:21:32.875: //-1/A79321E4806C/CCAPI/cc_api_call_setup_ind_common:
   Sub Called(TON=Unknown, NPI=Data, DatAP"'(AP<3, Length=3)cch323_ip_best_local_address: IP 192.168.18.1 found for bound IDB GigabitEthernet0/1.16

 

 

so, i change the h323 of subinterface, it was before the subinterface 0/1.11 and now is on 0/1.16 

 

197
Views
0
Helpful
8
Replies