Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem SRST and CUBE

Hello all.

  I don't know what's going on, at first time that setup worked, but now still doesn't work. 

 

I got this error..

 %CALL_CONTROL-6-CALL_LOOP: The incoming call has a global identfier already present in the list of currently handled calls. It is being refused.

 

The running-confg:

!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname test
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock summer-time BR date Oct 20 2013 0:00 Feb 16 2014 0:00
!
!
!
!
!
!
!
!
!


!
!
!
!
ip name-server 192.168.2.6
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice-card 0
!
!
voice rtp send-recv
!
voice service voip
 no ip address trusted authenticate
 mode border-element 
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 sip
  bind control source-interface GigabitEthernet0/0
  bind media source-interface GigabitEthernet0/0
  registrar server
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729br8
 codec preference 3 g722-64
!
!
!
voice register global
 mode srst
 system message ### WE ARE IN SRST ###
 max-dn 10
 max-pool 5
!
voice register pool  1
 id network 192.168.2.0 mask 255.255.255.0
 dtmf-relay rtp-nte
 codec g711ulaw
!
!
!
!
!
media profile recorder 1
 media-recording 20
!
media class 1
 recorder profile 1
!

redundancy
!
!

!
!
!
interface Loopback0
 no ip address
 shutdown
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description <<WAN_VPN_DevNet_Lab_SandboxL>>
 ip address 192.168.2.161 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description <<LAN>>
 no ip address
 ip nat inside
 ip virtual-reassembly in
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!
!
!
control-plane
!
 !
 !
 !
 !
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 1 voip
 destination-pattern 89..$
 session protocol sipv2
 session target ipv4:192.168.2.161:5060
 voice-class codec 1  
 media-class 1
 dtmf-relay sip-notify
!
dial-peer voice 2 voip
 session protocol sipv2
 session target ipv4:192.168.2.161:5060
 incoming called-number 89..$
 voice-class codec 1  
 media-class 1
 dtmf-relay sip-notify
!
dial-peer voice 20 voip
 description FORKING to MediaSense
 destination-pattern 99999
 session protocol sipv2
 session target ipv4:192.168.2.242:5060
 session transport tcp
 voice-class codec 1  
 dtmf-relay sip-notify
!
!
dial-peer hunt 7
!
!
gatekeeper
 shutdown
!
!
call-manager-fallback
 max-conferences 8 gain 6
 transfer-system full-consult
 ip source-address 192.168.2.161 port 2000
 max-ephones 5
 max-dn 5
!

line con 0
 login local
line aux 0
 login local
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 password qwe123
 login
 transport input telnet
line vty 5 15
 password qwe123
 login
 transport input none
!
no scheduler allocate
ntp update-calendar
sntp server 192.168.10.103
!
end

 

 

 

Someone can help?

Everyone's tags (4)
2 REPLIES
Super Bronze

HiYou have dial-peers

Hi

You have dial-peers pointing calls at the router itself - dps 1 and 2 ( session target ipv4:192.168.2.161:5060). Those look like a fairly obvious loop cause.

What's the purpose of those?

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

The purpose is the IPphones

The purpose is the IPphones have registered in this router as a SRST mode, and I need send that call flow to a CUBE forking (dial-peer 20) and then this dial-peer will send to MediaSense.

I don't know if a understood correctly but, I think the router has to route the call to itself (CUBE) and than fork to the MediaSense server.

 

~Pedro 

429
Views
0
Helpful
2
Replies
CreatePlease login to create content