Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem with CP-7915 on CUCM 5.1(3g)

Hi All

i have a CUCM 5.1(3), with the latest available patch (                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                             cisco-ipt-k9-patch5.1.3.8000-4.tar.gz.sgn ).. i tried to install the CP-7915 expansion module on a couple CP-7962G but they didn't work (all the led are solid amber).

this is what I had already done:

- installed latest firmware for CP-7962G (                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                             cmterm-7942_7962-sccp.9-0-2SR1.cop.sgn )

- installed latest firmware for CP-7915 (cmterm-7915.1-0-4.cop.sgn )

- configured the phone with the correct Expansion Module Information

- configured some blf for testing

the device is still not working.. the only strange thing i discovered is that in the "Device Defaults" page the device is recognized and load information is present, but protocol is "unspecified" while CP-7914  and all the phones have their own protocol (please see ddef.png attached)..

any idea?

thanks a lot in advance

Marco

6 REPLIES
Super Bronze

Re: Problem with CP-7915 on CUCM 5.1(3g)

Hi

Since 5.1(3g) appears to be the first 5.x release  to support the 7915, I would try the latest devicepack rather than individual firmware. There is a cmterm-devicepack-5_1_3_8104-1 available, with same 7915 firmware and slightly older 7942 firmware. Worth a try, I would say...

Regards

Aaron

Please rate helpful posts...

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
Bronze

Re: Problem with CP-7915 on CUCM 5.1(3g)

Hi,

I had a similiar issue on a CM6 install.In the end stop/restarting the TFTP service managed to kick them into life.

Mark

New Member

Re: Problem with CP-7915 on CUCM 5.1(3g)

i just installed this device package (and obviously restarted tftp service and both phone and expansion) but nothing has changed.... later i'll try to reboot the whole CUCM.. i'll let you know if anything changes..

thanks

Marco

Cisco Employee

Re: Problem with CP-7915 on CUCM 5.1(3g)

The install of FW for a device DOES NOT add support for it, what you're doing is just uploading the FW to TFTP. Uploading a FW does not modify the DB to add support for new phone models, you use DevPacks for that purpose. And if you're installing a DevPack to add support for a new model a cluster reboot is required as explained in the readme

When applying this Device Package to enable new device support, a cluster-wide reboot is required for those devices to register successfully.   A clusterwide reboot IS NOT required when running to update existing firmware/support.

HTH

java

If this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Re: Problem with CP-7915 on CUCM 5.1(3g)

Hi Java

     thanks for your answer... btw i already rebooted the CM after the DevPack installation, but nothing has changed: in the "device defaults" page the device is still "protocol unspecified", and the expansion is still not working..

i tried to force the load in the phone config page, and the led of the expansion module changed from solid amber to green.. but still not working..

New Member

Re: Problem with CP-7915 on CUCM 5.1(3g)

finally we got it:

the point is CP-7962 needs "Skinny Client Control Protocol (SCCP) Software 8.3(5) and later "...

on all our CP-7962 the SCCP soft. was SCCP42.8-3-2S.. i thought that installing the latest device-package would automatically resolve this problem but we found two problems:

the minor was that phones needed to be put on cucm vlan to perform firmware upgrade (we found the same problem times ago with CP-7960)

the major problem was that the phones didn't upgrade directly to latest firmware available, because during the process they encountered an error: "auth-fail"  ( I think it is this same bug: https://supportforums.cisco.com/thread/302267 )

so we upgraded sccp software of CP-7962 to 8.3(5)

last step was that we had to force the load name of the expansion module in the phone configuration, because for some reasons it ignored the default one..

bye

Marco

1521
Views
0
Helpful
6
Replies