Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bronze

Problem with directory feature on CME - no xmldirectory.asp

Hi there,

I'm building a new CME installation using IOS 15.0(1)XA1 on a 2851 and I'm having problems with the built in directory feature.  I've added ephone-dn's and configured a name for each one, but when I go to my phone(s) and press the Directories button, I only see missed, received, and placed calls, and a 404 not found error.  I've added the ' url directories http://10.1.254.254/CCMCIP/xmldirectory.asp' command, and verified that the phone configuration files are generated with the correct URL.  The file doesn't seem to exist anywhere!  Can anybody help me out on this?

Thanks in advance,

Brandon

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Problem with directory feature on CME - no xmldirectory.asp

Brandon,

Is 10.1.254.254 your CME host?  If so, then the URL you provided will not work because the CME hosts does not run a web server engine that can handle .asp scripts.  The .asp file you are referencing is a CallManager 3.x/4.x application.  While you could use this as an external directory on CME, you would need to host the application on an external server.

I recommend you read through this configuration guide.  It may help clear things up quite a bit.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmedirs.html#wp1010670

HTH.


Regards,
Bill

Please remember to rate helpful posts.

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

3 REPLIES

Re: Problem with directory feature on CME - no xmldirectory.asp

Brandon,

Is 10.1.254.254 your CME host?  If so, then the URL you provided will not work because the CME hosts does not run a web server engine that can handle .asp scripts.  The .asp file you are referencing is a CallManager 3.x/4.x application.  While you could use this as an external directory on CME, you would need to host the application on an external server.

I recommend you read through this configuration guide.  It may help clear things up quite a bit.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmedirs.html#wp1010670

HTH.


Regards,
Bill

Please remember to rate helpful posts.

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

Bronze

Re: Problem with directory feature on CME - no xmldirectory.asp

Thanks Bill -- I was definitely barking up the wrong tree.  As soon as I removed that url entry it started working.

Community Member

Re: Problem with directory feature on CME - no xmldirectory.asp

Hi

I've tried to use a CCM4.2 directory service in a CME.

But no success.

I cannot see the corporate directoy in my CME Phones

1525
Views
0
Helpful
3
Replies
CreatePlease to create content