Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

problem with inserting cmd records in the database

Hello people,

I have an issue with CDR insert.

CMR files are copied into the BAD directory by CCM.When i move them into the cmr directory,they are being copied again to the BAD directory instead of begin written into the database.

At the same time,i have the following message in the insertcdr traces:

07/23/2008 15:05:41.686 CDR| CMonitor::ConvertFile Processing file [\\DCCM01\CDR\CMR\cmr_GRP_AS02072320081504]|<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR|-->CMonitor::SetupColumnNames |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR|<--CMonitor::SetupColumnNames |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR|-->CMonitor::SetupColumnTypes |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR|<--CMonitor::SetupColumnTypes |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR|-->CMonitor::InsertRecord Error |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR| CMonitor::InsertRecord Error *ERROR* ParseCsvStr failed|<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR|<--CMonitor::InsertRecord Error |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR|-->CMonitor::InsertRecord Error |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR| CMonitor::InsertRecord Error *ERROR* Insert failed S [42000] E [aa]|<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR|Error executing "insert into CallDetailRecordDiagnostic (": [Microsoft][ODBC SQL Server Driver][SQL Server]Line 1: Incorrect syntax near '('.|<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR|<--CMonitor::InsertRecord Error |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR| CMonitor::ConvertFile 1 records in 0 ms|<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR| CMonitor::ConvertFile Moving [\\DCCM01\CDR\CMR\cmr_GRP_AS02072320081504]->[\\DCCM01\CDR\Bad\cmr_GRP_AS02072320081504]|<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR|<--CMonitor::ConvertFile |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR| CMonitor::ProcessDirectoryChange () Remove connection|<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR|<--CMonitor::ProcessDirectoryChange () |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR| CMonitor::MonThreadProc NTFS FindNext|<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR| CMonitor::MonThreadProc NTFS close event|<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR|-->CMonitor::ReadConfiguration |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.686 CDR|-->SDIControlLayer::ReadDatabase(a24) |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.718 CDR|<--SDIControlLayer::ReadDatabase(a24) |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.718 CDR|-->SDIControlBase::Init(a24) |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.718 CDR|<--SDIControlBase::Init(a24) |<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.749 CDR| CMonitor::ReadConfiguration Directory = '\\DCCM01\CDR\'|<CLID::GRP_AS><NID::10.10.180.3>

07/23/2008 15:05:41.749 CDR| CMonitor::ReadConfiguration DSN override is empty|<CLID::GRP_AS><NID::10.10.180.3>

Syntax error???

Anyone encountered this before?

cdr records are fine.

Thanks for some advise

Kind regards,

Kurt

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: problem with inserting cmd records in the database

CIPC produces funny characters in the VarVQMetrics column in CMR files, which causes the CMR files to get stuck in the BAD folder.

This bug might help: CSCsm57884

2 REPLIES
Silver

Re: problem with inserting cmd records in the database

CIPC produces funny characters in the VarVQMetrics column in CMR files, which causes the CMR files to get stuck in the BAD folder.

This bug might help: CSCsm57884

New Member

Re: problem with inserting cmd records in the database

Indeed,this is the bug.

I already openened a TAC case for that.

Hard to find this bug...

Ayway,thanks for the reply.

Kurt

134
Views
0
Helpful
2
Replies