Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

problem with registration IP phone

Hi evryone,

I have a little problem with my ip phone. My ip phone is in remote office and hi won't register with my voice router (Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.1(1)T,)  Connection between two office looks like this Voice route -> Router gateway ->ipsec tunnel to remote office-> asa 5510 ->  C3750 .  

On C3750 is configure vlan 5 and dhcp for ip address for phones .

ip dhcp pool VOICE
   network 10.11.5.0 255.255.255.0
   dns-server 10.10.10.2    
   option 150 ip 172.16.0.10
   default-router 10.11.5.1

I can ping phone from  voice router but he won't register .

 

Configuration on router :

voice-card 0
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  call start slow
 modem passthrough nse codec g711alaw
 sip
  header-passing
  registrar server expires max 1200 min 60
  early-offer forced
  midcall-signaling passthru
!
voice class codec 1
 codec preference 1 g711alaw
 codec preference 2 g711ulaw
!
!
!

class-map match-all L3-to-L2_VoIP-Cntrl
 match ip dscp af31
class-map match-all L3-to-L2_VoIP-RTP
 match ip dscp ef
class-map match-all SIP
 match protocol sip
class-map match-all RTP
 match protocol rtp
!
!
policy-map EthOut
 class RTP
policy-map output-L3-to-L2
 class L3-to-L2_VoIP-RTP
  set cos 5
 class L3-to-L2_VoIP-Cntrl
  set cos 3
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 172.16.0.10 255.255.0.0
 duplex auto
 speed auto

 

 

gatekeeper
 shutdown

telephony-service
 no auto-reg-ephone
 pin 11000 override
 max-ephones 58
 max-dn 72
 ip source-address 172.16.0.10 port 2000
 calling-number initiator
 service phone videoCapability 1
 timeouts interdigit 5
 system message DIS
 cnf-file location flash:
 time-zone 28
 time-format 24
 date-format dd-mm-yy
 max-conferences 8 gain -6
 call-forward pattern .T
 moh music-on-hold.au
 dn-webedit
 time-webedit
 transfer-system full-consult dss
!

ephone-dn  1  dual-line
 number 111
 label TEST
 description TEST
 name TEST
 corlist incoming CALLS

 

ephone  1
 video
 mac-address 000D.BC8E.E0C1
 username "user1" password 201
 type 7940
 button  1:1

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Hello!Did you try to register

Hello!

Did you try to register this 7940 before? Did you try to register any 7940 inside the office (not remote office)?

I think, you should try:

1) telephony service

    cnf-file perphone

    create cnf

2) to download wirmware files from cisco.com , put it onto CME and configure tftp server with firmware for 7940.

tftp-server flash:<file_name> alias <file_name>

telephony service

load 7940 <name_of_firmaware>

2) to see: debug ephone register

                   debug tftp events

If phone tries to download configuration and firmware from CME and what it tries to download.

 

Regards,

Kirill

 

7 REPLIES
New Member

settings on the phone

settings on the phone attached

You need to make sure that

You need to make sure that the ASA is not blocking your registration. Check with your security team.

Regards,

Yosh

HTH Regards, Yosh
Cisco Employee

Hello!Did you try to register

Hello!

Did you try to register this 7940 before? Did you try to register any 7940 inside the office (not remote office)?

I think, you should try:

1) telephony service

    cnf-file perphone

    create cnf

2) to download wirmware files from cisco.com , put it onto CME and configure tftp server with firmware for 7940.

tftp-server flash:<file_name> alias <file_name>

telephony service

load 7940 <name_of_firmaware>

2) to see: debug ephone register

                   debug tftp events

If phone tries to download configuration and firmware from CME and what it tries to download.

 

Regards,

Kirill

 

New Member

thanks for reply ,I work with

thanks for reply ,

I work with 6921 and 7906 but inside office. Now my callmenager is in on another network.

Cnf file I did not create. I will try it now.

this will likely be your fix

this will likely be your fix if nothing is blocking...  If not, get the TFTP debugs going and post them.

 

New Member

cnf file was the solution,

cnf file was the solution, Thanks smiley

Cisco Employee

U r welcome, thanx for rating

U r welcome, thanx for rating!

smiley

145
Views
5
Helpful
7
Replies
CreatePlease to create content