Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

PSTN Router Config pls check

Hi Guys,

I am trying to setup PSTN router. Following is the configuraiton. I am not sure when I do show isdn status it says my layer 1 is shutdown. I checked the config and cant see any where they are shut. I am thinking may be because of error I am getting but not sure. Another thing is I am not sure whether I have the correct rollover cables. Even if I have wrong rollover cables the controllers should come up correct or not ? Please someone help me out. Tks

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname PSTN

!

boot-start-marker

boot-end-marker

!

!

enable secret 5 $1$bJ1/$OYNeITJ2UaBepap3.PJ8u/

!

no aaa new-model

!

network-clock-participate wic 0

network-clock-participate wic 1

network-clock-participate wic 3

!

dot11 syslog

ip source-route

!

!

ip cef

!

!

!

no ip domain lookup

ip multicast-routing

no ipv6 cef

!

multilink bundle-name authenticated

isdn switch-type primary-net5

!

!

!

voice service voip

sip

  bind control source-interface GigabitEthernet0/0

  bind media source-interface GigabitEthernet0/0

  header-passing

  registrar server

  no call service stop

!

!!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

!

!

username cisco password 0 cisco

!

redundancy

!

!

controller E1 0/0/0

clock source internal

pri-group timeslots 1-2,16

!

controller E1 0/1/0

pri-group timeslots 1-5,16

!

controller E1 0/3/0

pri-group timeslots 1-5,16

!

!

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn send-alerting

isdn bchan-number-order ascending

no cdp enable

!

interface Serial0/1/0:15

description connect-sb

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn protocol-emulate network

isdn incoming-voice voice

no cdp enable

!

interface Serial0/3/0:15

description connect-sc

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn protocol-emulate network

isdn incoming-voice voice

isdn send-alerting

isdn sending-complete

no cdp enable

router ospf 1

network 0.0.0.0 255.255.255.255 area 0

!

ip forward-protocol nd

ip http server

ip http authentication local

no ip http secure-server

ip http path flash:gui

!

!

!

logging esm config

!

ixi transport http

response size 4

no shutdown

request outstanding 1

nls resp-timeout 1

cpd cr-id 1

!

!

!

!

!

!

control-plane

!

!

voice-port 0/1/0:15

translate called 2

!

voice-port 0/3/0:15

translate called 5

!

voice-port 0/0/0:15

!

!

!

mgcp profile default

!

!

!

!

gateway

timer receive-rtp 1200

!

sip-ua

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

password cisco

login

transport input all

!

scheduler allocate 20000 1000

ntp master 2

end

PSTN#show isdn st

Global ISDN Switchtype = primary-net5

ISDN Serial0/0/0:15 interface

        dsl 0, interface ISDN Switchtype = primary-net5

    Layer 1 Status:

        SHUTDOWN

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

    Layer 3 Status:

        0 Active Layer 3 Call(s)

    Active dsl 0 CCBs = 0

    The Free Channel Mask:  0x00000000

    Number of L2 Discards = 0, L2 Session ID = 1

ISDN Serial0/1/0:15 interface

        ******* Network side configuration *******

        dsl 1, interface ISDN Switchtype = primary-ni

    Layer 1 Status:

        SHUTDOWN

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

    Layer 3 Status:

        0 Active Layer 3 Call(s)

    Active dsl 1 CCBs = 0

    The Free Channel Mask:  0x00000000

    Number of L2 Discards = 0, L2 Session ID = 0

ISDN Serial0/3/0:15 interface

        ******* Network side configuration *******

        dsl 2, interface ISDN Switchtype = primary-net5

    Layer 1 Status:

        SHUTDOWN

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

    Layer 3 Status:

        0 Active Layer 3 Call(s)

    Active dsl 2 CCBs = 0

    The Free Channel Mask:  0x00000000

    Number of L2 Discards = 0, L2 Session ID = 21

    Total Allocated ISDN CCBs = 0

PSTN#show int s0/0/0:15

Serial0/0/0:15 is down, line protocol is down

  Hardware is DSX1

  MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation HDLC, loopback not set

  Keepalive set (10 sec)

  Last input never, output never, output hang never

  Last clearing of "show interface" counters 00:15:08

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/0/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 48 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

  Timeslot(s) Used:16, SCC: 0, Transmitter delay is 0 flags

PSTN#show int s0/1/0:15

Serial0/1/0:15 is down, line protocol is down

  Hardware is DSX1

  Description: connect-sb

  MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation HDLC, loopback not set

  Keepalive set (10 sec)

  Last input never, output never, output hang never

  Last clearing of "show interface" counters 00:15:24

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/0/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 48 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

  Timeslot(s) Used:16, SCC: 0, Transmitter delay is 0 flags

PSTN#show int s0/3/0:15

Serial0/3/0:15 is down, line protocol is down

  Hardware is DSX1

  Description: connect-sc

  MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,

     reliability 252/255, txload 1/255, rxload 1/255

  Encapsulation HDLC, loopback not set

  Keepalive set (10 sec)

  Last input 01:19:34, output never, output hang never

  Last clearing of "show interface" counters 00:15:41

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/1/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 48 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

  Timeslot(s) Used:16, SCC: 0, Transmitter delay is 0 flags

PSTN#show ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

GigabitEthernet0/0         172.16.0.1    YES NVRAM  up                    up

GigabitEthernet0/1         192.168.1.1   YES NVRAM  up                    down

Serial0/0/0:0              unassigned      YES unset  down                  down

Serial0/0/0:1              unassigned      YES unset  down                  down

Serial0/0/0:15             unassigned      YES unset  down                  down

Serial0/1/0:0              unassigned      YES unset  down                  down

Serial0/1/0:1              unassigned      YES unset  down                  down

Serial0/1/0:2              unassigned      YES unset  down                  down

Serial0/1/0:3              unassigned      YES unset  down                  down

Serial0/1/0:4              unassigned      YES unset  down                  down

Serial0/1/0:15             unassigned      YES NVRAM  down                  down

Serial0/3/0:0              unassigned      YES unset  down                  down

Serial0/3/0:1              unassigned      YES unset  down                  down

Serial0/3/0:2              unassigned      YES unset  down                  down

Serial0/3/0:3              unassigned      YES unset  down                  down

Serial0/3/0:4              unassigned      YES unset  down                  down

Serial0/3/0:15             unassigned      YES NVRAM  down                  down

PSTN#show controllers e1 0/0/0

E1 0/0/0 is down.

  Applique type is Channelized E1 - balanced

  Transmitter is sending remote alarm.

  Receiver has loss of frame.

  alarm-trigger is not set

  Version info Firmware: 20090113, FPGA: 20, spm_count = 0

  Framing is CRC4, Line Code is HDB3, Clock Source is Internal.

  Data in current interval (168 seconds elapsed):

     10531475 Line Code Violations, 0 Path Code Violations

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 168 Unavail Secs

  Data in Interval 1:

     40709769 Line Code Violations, 0 Path Code Violations

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 900 Unavail Secs

  Total Data (last 1 15 minute intervals):

     40709769 Line Code Violations, 0 Path Code Violations,

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 900 Unavail Secs

PSTN#show controllers e1 0/1/0

E1 0/1/0 is down.

  Applique type is Channelized E1 - balanced

  Transmitter is sending remote alarm.

  Receiver has loss of frame.

  alarm-trigger is not set

  Version info Firmware: 20090113, FPGA: 20, spm_count = 0

  Framing is CRC4, Line Code is HDB3, Clock Source is Line.

  Data in current interval (182 seconds elapsed):

     9734896 Line Code Violations, 0 Path Code Violations

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 182 Unavail Secs

  Data in Interval 1:

     54478431 Line Code Violations, 0 Path Code Violations

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 900 Unavail Secs

  Total Data (last 1 15 minute intervals):

     54478431 Line Code Violations, 0 Path Code Violations,

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 900 Unavail Secs

PSTN#show controllers e1 0/3/0

E1 0/3/0 is down.

  Applique type is Channelized E1 - balanced

  Far End Block Errors Detected

  Transmitter is sending remote alarm.

  Receiver has loss of frame.

  alarm-trigger is not set

  Version info Firmware: 20090113, FPGA: 20, spm_count = 0

  Framing is CRC4, Line Code is HDB3, Clock Source is Line.

  Data in current interval (195 seconds elapsed):

     11638646 Line Code Violations, 0 Path Code Violations

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 195 Unavail Secs

  Data in Interval 1:

     52019089 Line Code Violations, 0 Path Code Violations

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 900 Unavail Secs

  Total Data (last 1 15 minute intervals):

     52019089 Line Code Violations, 0 Path Code Violations,

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 900 Unavail Secs

NAME: "2821 chassis", DESCR: "2821 chassis"

PID: CISCO2821         , VID: V01 , SN: FHK0925F00U

NAME: "One port E1 voice interface daughtercard on Slot 0 SubSlot 0", DESCR: "One port E1 voice interface daughtercard"

PID: VWIC-1MFT-E1=     , VID: 1.0, SN: 32548685

NAME: "One port E1 voice interface daughtercard on Slot 0 SubSlot 1", DESCR: "One port E1 voice interface daughtercard"

PID: VWIC-1MFT-E1=     , VID: 1.0, SN: 26682761

NAME: "One port E1 voice interface daughtercard on Slot 0 SubSlot 3", DESCR: "One port E1 voice interface daughtercard"

PID: VWIC-1MFT-E1=     , VID: 1.0, SN: 29804671

NAME: "PVDMII DSP SIMM with one DSP on Slot 0 SubSlot 4", DESCR: "PVDMII DSP SIMM with one DSP"

PID: PVDM2-16          , VID: V01 , SN: FOC13200WJF

2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Purple

PSTN Router Config pls check

Hi Kuldeep,

Your controller won't come UP till the E1 connections are rightly patched/connected.

you can also refer the link for Pin details of RJ-45

https://supportforums.cisco.com/docs/DOC-9474

Even after having right pins , if still controller does not come UP, try swapping pairs at either end.

regds,

aman

Re: PSTN Router Config pls check

Yes thats right. Since you are connecting two e1 cards back to back you need to use e1 cross over cable.

Terry

Please rate helpful posts!

Sent from Cisco Technical Support iPhone App

5 REPLIES
New Member

PSTN Router Config pls check

Guys the config under Int serial are wrong. Here is the correct one. Even with this it is giving me same errors pasted above

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn protocol-emulate network

isdn incoming-voice voice

isdn send-alerting

isdn sending-complete

isdn outgoing display-ie

no cdp enable

!

interface Serial0/1/0:15

description connect-sb

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn protocol-emulate network

isdn incoming-voice voice

no cdp enable

!

interface Serial0/3/0:15

description connect-sc

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn protocol-emulate network

isdn incoming-voice voice

isdn send-alerting

isdn sending-complete

no cdp enable

Re: PSTN Router Config pls check

Hi Kuldeep,

First and foremost please ensure you are using E1 cross over cable. It appears you have wrong cables.

You can either make the cables if you have a crimper and some connectors or you can buy the E1 cross over cables. Refer here for E1 cross over pin lay outs: http://wiki.beronet.com/index.php/Howto_E1_/_T1_Crossover_Cable

Thanks,
Terry

Sent from Cisco Technical Support iPhone App

VIP Purple

PSTN Router Config pls check

Hi Kuldeep,

Your controller won't come UP till the E1 connections are rightly patched/connected.

you can also refer the link for Pin details of RJ-45

https://supportforums.cisco.com/docs/DOC-9474

Even after having right pins , if still controller does not come UP, try swapping pairs at either end.

regds,

aman

New Member

PSTN Router Config pls check

Hi Guys

Really appreciated for your replies / answers. I still have one question I.e why it is

Showing layer 1 shutdown? Is it becos of wrong cables? Tks for ur help guys

Tks

Re: PSTN Router Config pls check

Yes thats right. Since you are connecting two e1 cards back to back you need to use e1 cross over cable.

Terry

Please rate helpful posts!

Sent from Cisco Technical Support iPhone App

777
Views
0
Helpful
5
Replies
CreatePlease to create content