Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

Q931 errors with Cisco IAD ISDN PRI To 3COM NBX3000

CAN ANYONE TELL ME WHAT THES DEBUG ERROR MESSAGES MEAN. ALSO HERE IS MY IAD CONFIG AS WELL. NEED HELP PLEASE!

Jul 13 15:55:51.848: ISDN Se0/0:23 Q931: RX <- BAD PACKET()

Jul 13 15:55:51.848: ISDN Se0/0:23 Q931: do_statistics: protocol 0x80 protocol not supported.

Jul 13 15:55:52.844: ISDN Se0/0:23 Q931: RX <- BAD PACKET()

Jul 13 15:55:52.844: ISDN Se0/0:23 Q931: do_statistics: protocol 0x80 protocol not supported.

Jul 13 15:55:53.844: ISDN Se0/0:23 Q931: RX <- BAD PACKET()

Jul 13 15:55:53.844: ISDN Se0/0:23 Q931: do_statistics: protocol 0x80 protocol not supported.

Jul 13 15:55:54.844: ISDN Se0/0:23 Q931: RX <- BAD PACKET()

Jul 13 15:55:54.844: ISDN Se0/0:23 Q931: do_statistics: protocol 0x80 protocol not supported.

Jul 13 15:55:59.844: ISDN Se0/0:23 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x0021

Cause i = 0x809F - Normal, unspecified

Jul 13 15:55:59.848: ISDN Se0/0:23 SERROR: L3_GetUser_NLCB: EVENT 0X5A No NLCB 2

Jul 13 15:55:59.848: ISDN Se0/0:23 **ERROR**: L3_BadPeerMsg: event 0x5A cr 0x8021 callid 0x0

Jul 13 15:56:04.348: ISDN Se0/0:23 Q931: RX <- BAD PACKET()

Jul 13 15:56:04.348: ISDN Se0/0:23 Q931: do_statistics: protocol 0x80 protocol not supported.

Jul 13 15:56:05.344: ISDN Se0/0:23 Q931: RX <- BAD PACKET()

Jul 13 15:56:05.344: ISDN Se0/0:23 Q931: do_statistics: protocol 0x80 protocol not supported.

Jul 13 15:56:06.344: ISDN Se0/0:23 Q931: RX <- BAD PACKET()

Jul 13 15:56:06.344: ISDN Se0/0:23 Q931: do_statistics: protocol 0x80 protocol not supported.

Jul 13 15:56:07.344: ISDN Se0/0:23 Q931: RX <- BAD PACKET()

Jul 13 15:56:07.344: ISDN Se0/0:23 Q931: do_statistics: protocol 0x80 protocol not supported.

Jul 13 15:56:12.344: ISDN Se0/0:23 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x0022

Cause i = 0x809F - Normal, unspecified

Jul 13 15:56:12.348: ISDN Se0/0:23 SERROR: L3_GetUser_NLCB: EVENT 0X5A No NLCB 2

Jul 13 15:56:12.348: ISDN Se0/0:23 **ERROR**: L3_BadPeerMsg: event 0x5A cr 0x8022 callid 0x0

PRE-PRI Config

service password-encryption

!

hostname MILL

!

boot-start-marker

boot-end-marker

!

card type t1 1

logging buffered 2000000 debugging

!

no aaa new-model

clock timezone est -5

clock summer-time edt recurring

network-clock-participate wic 0

network-clock-participate T1 1/0

network-clock-participate T1 1/1

network-clock-select 1 T1 1/1

!

!

ip cef

ip name-server 66.119.112.2

ip name-server 4.2.2.2

!

!

isdn switch-type primary-ni

!

!

trunk group MCC

!

voice-card 0

!

!

voice call send-alert

voice rtp send-recv

!

voice service voip

fax protocol t38 ls-redundancy 1 hs-redundancy 0 fallback pass-through g711ulaw

sip

!

voice class codec 100

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

!

!

!

!

!

!

!

!

!

controller T1 0/0

framing esf

fdl both

clock source internal

linecode b8zs

cablelength short 133

pri-group timeslots 1-24

!

controller T1 0/1

framing esf

linecode b8zs

channel-group 1 timeslots 1-24

!

controller T1 1/0

framing esf

linecode b8zs

channel-group 1 timeslots 1-24

!

controller T1 1/1

framing esf

linecode b8zs

channel-group 1 timeslots 1-24

!

!

class-map match-all voip

match access-group 101

match ip precedence 5

!

!

policy-map voice-policy

class voip

priority percent 25 512000

1 REPLY
New Member

Re: Q931 errors with Cisco IAD ISDN PRI To 3COM NBX3000

!

!

translation-rule 40

Rule 1 null null

!

!

!

!

interface Multilink200

ip address 209.150.X.X 255.255.255.X

no cdp enable

ppp multilink

ppp multilink fragment disable

ppp multilink group 200

service-policy output voice-policy

!

interface FastEthernet0/0

description WAN

ip address 209.150.X.X 255.255.255.X

ip accounting output-packets

ip route-cache flow

duplex full

speed 100

no cdp enable

!

interface Serial0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn protocol-emulate network

isdn incoming-voice modem

isdn supp-service name calling

isdn send-alerting

isdn negotiate-bchan resend-setup

isdn outgoing-voice info-transfer-capability 3.1kHz-audio

isdn outgoing ie facility

isdn outgoing ie called-number

no cdp enable

!

interface FastEthernet0/1

description LAN

ip address 209.150.X.X 255.255.255.X

ip route-cache flow

duplex auto

speed auto

no cdp enable

!

interface Serial0/1:1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 200

!

interface Serial1/0:1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 200

!

interface Serial1/1:1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 200

!

no ip http server

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 209.150.X.X

!

!

access-list 101 permit ip any any dscp ef

dialer-list 1 protocol ip permit

no cdp run

!

!

!

control-plane

!

!

voice-port 0/0:23

translate calling 40

!

voice-port 2/0

ren 5

disconnect-ack

loss-plan plan4

input gain 2

output attenuation 9

echo-cancel coverage 24

no vad

no comfort-noise

timeouts interdigit 3

timing hookflash-in 400 150

caller-id enable

!

voice-port 2/1

!

voice-port 2/2

!

voice-port 2/3

!

voice-port 2/4

!

voice-port 2/5

!

voice-port 2/6

!

voice-port 2/7

!

voice-port 2/8

!

voice-port 2/9

!

voice-port 2/10

!

voice-port 2/11

!

voice-port 2/12

!

voice-port 2/13

!

voice-port 2/14

!

voice-port 2/15

!

voice-port 2/16

!

voice-port 2/17

!

voice-port 2/18

!

voice-port 2/19

!

voice-port 2/20

!

voice-port 2/21

!

voice-port 2/22

!

voice-port 2/23

!

!

!

!

dial-peer voice 2 voip

tone ringback alert-no-PI

huntstop

preference 2

destination-pattern T

progress_ind setup enable 3

modem passthrough nse codec g711ulaw

session protocol sipv2

session target sip-server

session transport udp

codec g711ulaw

fax-relay ecm disable

fax rate 9600

clid strip pi-restrict

clid strip name

no vad

!

dial-peer voice 100 pots

destination-pattern 77256290XX

direct-inward-dial

forward-digits 7

!

dial-peer voice 300 voip

destination-pattern .T

session protocol sipv2

session target sip-server

session transport udp

codec g711ulaw

!

dial-peer voice 501 voip

session protocol sipv2

session target sip-server

session transport udp

incoming called-number 77256290XX

codec g711ulaw

!

dial-peer voice 406 pots

destination-pattern 77256290XX

port 2/0

authentication username 77256290XX password

!

gateway

timer receive-rtcp 120

timer receive-rtp 1200

!

sip-ua

no remote-party-id

retry invite 4

retry bye 2

retry cancel 2

registrar dns:mars.pbx-change.com expires 3600

sip-server dns:mars.pbx-change.com

!

!

line con 0

password 7

line aux 0

transport preferred none

transport output none

line vty 0 4

password

login

!

ntp clock-period 17180084

ntp server 198.31.248.6 prefer

end

ALSO THIS ONY SEEMS TO HAPPEN ON OUTGOING ONLY. WE CAN RECEIVE INCOMING CALLS

921
Views
0
Helpful
1
Replies
CreatePlease to create content