Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

QoS for Jabber

Does the voice stream of a Jabber client have the same QoS markings as a phone like the 7900 series or is the voice best effort over an on-premise network?             

4 REPLIES
VIP Super Bronze

QoS for Jabber

Assuming Jabber for Windows since you didn't specify. The client will attempt to set DSCP markings; however, Windows policy may prevent this from getting passed to the network. You may need to create a Group Policy that allows the application to set QoS. Additionally, the access-layer switch port needs to accept DSCP markings from the data VLAN. Historically (i.e. auto qos) this has not been the case.

Additionally, Cisco is adding support for MediaNet Services Interface which - if installed on the endpoint and configured in the network - allows Jabber, WebEx, or other MediaNet-aware applications to explictily tell the network about the traffic flows and the treatment they need. This should end up being far more precise than blindly trusting or policing traffic on the data VLAN.

PS- There is a dedicated Jabber space here on the communities.

Please remember to rate helpful responses and identify helpful or correct answers.

Re: QoS for Jabber

Hi

I can share with for example if your question regarding Cisco jabber for windows.

1-First question , you have to ask your self which ports which Jabber used to established please find the below link which includes all ports

http://www.cisco.com/en/US/docs/voice_ip_comm/jabber/Windows/9_0_1/b_jabber_win_icg_chapter_011.html

based on that you have to do an access list which capture all the above ports. i created QOS which can capture Jabber traffic and applied to F0/1 which connected to a PC which have jabber.

mls qos

mls qos map cos-dscp 0 8 16 24 32 46 48 56

ip access-list extended jabber_ports

permit tcp any any eq 80

permit tcp any any eq 443

permit tcp any any eq 993

permit tcp any any eq 7993

permit tcp any any eq 143

permit tcp any any eq 389

permit tcp any any eq 2748

permit tcp any any eq 5060

permit udp any any eq 5060

permit udp any any eq 69

and so on match the ports based on your usage for jabber

class-map match-any Jabber-sig

match access-group name jabber_ports

ip access-list extended udp

permit udp any any range 16384 16424

class-map match-any Jabber-udp

match access-group name udp

policy-map JAPPER

class Jabber-udp

set dscp ef

class Jabber-sig

set dscp cs3

class class-default

interface f0/1

mls qos trust dscp

service policy input JAPPER

Thank you

please rate all useful information

VIP Super Bronze

Re: QoS for Jabber

Terry,

There are two ways documented here..

http://www.cisco.com/en/US/docs/voice_ip_comm/jabber/Windows/9_1/JABW_BK_CA48EE46_00_cisco-jabber-for-windows-administration_chapter_010.html#JABW_CN_IDBE72E9_00

1. Deploy with Cisco Media Services Interface

2. Set DSCP values in IP headers of RTP media packets

Read the documentation and it will give you a better understanding..

Islam,

Jabber signalling traffic should not be calssiffied as EF. Thats RTP traffic. Signalling should be classified as CS3 and RTP as EF

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Re: QoS for Jabber

Hello

Yes sir , you are completely true.Please check my configuration again , RTP which represnet (UDP access list) is mapped to EF and signal (jabber ports) mapped to CS3 .I am sure from my configuration now , maybe i changed the classes names by mistake.

Thank you

please rate all useful informaton

3595
Views
10
Helpful
4
Replies
CreatePlease to create content