Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

QoS for voice on a multi-link frame relay interface / subinterfaces

Hello,

My question is in regards to QoS on an MFR interface/subinterfaces. We have a remote site with two bundled T1's terminating on a 2951 router for a total bandwidth of 3072. The circuit is provided by Paetec and the subinterfaces are designated for internet and MPLS traffic respectively. The issue we are facing is with outbound voice quality. It seems that no matter how we apply QoS, either to the main MFR interface or the MFR subinterfaces, voice packets do not seem to be prioritized. We tried FRTS, which slowed the entire link down to a crawl, we tried applying a class map to the main interface as well as a service policy, none of which seemed to affect anything. Please see below for current partial configuration. Any input will be greatly appreciated.

class-map match-all VOICE

match ip dscp ef

class-map match-any SIGNALING

match ip dscp af31

match ip dscp cs3

class-map match-all AZ-SERVERS

match access-group 10

!

!

policy-map VOICE-POLICY

class VOICE

    priority 640

class SIGNALING

    bandwidth 64

  set dscp af41

class AZ-SERVERS

    police 1000000

class class-default

    fair-queue

!

!

!

!

!        

interface Loopback1

no ip address

!

interface Tunnel1

no ip address

!

interface MFR1

no ip address

ip flow ingress

ip flow egress

load-interval 30

frame-relay lmi-type ansi

service-policy output VOICE-POLICY

!

interface MFR1.501 point-to-point

description => Internet via PAETEC

ip vrf forwarding internet

ip address 63.255.X.X 255.255.255.252
ip flow ingress
ip flow egress
no cdp enable

frame-relay interface-dlci 501 IETF  

!

interface MFR1.502 point-to-point

description => MPLS VPN via PAETEC

ip address 63.253.X.X 255.255.255.252
ip flow ingress
ip flow egress
no cdp enable
frame-relay interface-dlci 502 IETF

6 REPLIES
Green

QoS for voice on a multi-link frame relay interface / subinterfa

Hi,

Can you post the output of

show policy-map interface mfr1 out

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

QoS for voice on a multi-link frame relay interface / subinterfa

Sure. I've looked at this output in the past and do see voice packets being treated with priority as well as policing on data from some servers but we continue to have voice issues.

AZ-2951VG1#sh policy-map int
MFR1

  Service-policy output: VOICE-POLICY

    queue stats for all priority classes:
     
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 6867970/1396926660

    Class-map: VOICE (match-all)
      6867971 packets, 1395297936 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: ip dscp ef (46)
      Priority: 640 kbps, burst bytes 16000, b/w exceed drops: 0
     

    Class-map: SIGNALING (match-any)
      179239 packets, 10913653 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: ip dscp af31 (26)
        11784 packets, 2323721 bytes
        30 second rate 0 bps
      Match: ip dscp cs3 (24)
        167455 packets, 8589932 bytes
        30 second rate 0 bps
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 179239/10960789
      bandwidth 64 kbps
      QoS Set
        dscp af41
          Packets marked 179239

    Class-map: AZ-SERVERS (match-all)
      2547381 packets, 2400552064 bytes
      30 second offered rate 23000 bps, drop rate 0 bps
      Match: access-group 10
      police:
          cir 1000000 bps, bc 31250 bytes
        conformed 2504654 packets, 2338453602 bytes; actions:
          transmit
        exceeded 42727 packets, 62098462 bytes; actions:
          drop
        conformed 23000 bps, exceed 0 bps

    Class-map: class-default (match-any)
      3807965 packets, 973152148 bytes
      30 second offered rate 13000 bps, drop rate 0 bps
      Match: any
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops/flowdrops) 0/380109/0/380109
      (pkts output/bytes output) 5978340/3298256266
      Fair-queue: per-flow queue limit 16

Green

QoS for voice on a multi-link frame relay interface / subinterfa

Hi,

Class-map: VOICE (match-all)

      6867971 packets, 1395297936 bytes

      30 second offered rate 0 bps, drop rate 0 bps

      Match: ip dscp ef (46)

      Priority: 640 kbps, burst bytes 16000, b/w exceed drops: 0

So you are or at least have been matching VOIP EF traffic

One thing you could try is looking at the T1 tx ring size

For voice traffic you may need to cut this down.

A similar config I have showed that the TX ring had been put down to 2

!

no tx-queue-limit

tx-ring-limit 2

!

Verify what you have before making any changes

Know how to revert

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

QoS for voice on a multi-link frame relay interface / subinterfa

Verified the tx limit is set to 2.

Green

QoS for voice on a multi-link frame relay interface / subinterfa

Hi,

So its looks to me like you are prioritizing the EF traffic OK.

Is the WAN carrier SP providing QOS end to end for you too.

Your config looks good to me.

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

QoS for voice on a multi-link frame relay interface / subinterfa

They are, that was one of the first places we turned to in order to troubleshoot. Strange.

301
Views
0
Helpful
6
Replies
CreatePlease to create content