Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS Implementation

Hi Sirs,

, I need some information on QOS. My Boss gave me a project to implement a basic QoS on 1 of our remote locations which has a DSL link to the HQ. I need the basic configuration to implement on this 2851 router.

Since i'm new to cisco VoIP I would appriciate if you can help me with the commands.. Also, I want to make sure we have enough DSCP resources available ? how to do this ?

1 REPLY

Re: QoS Implementation

You can do a search on cisco.com (or google) for LLQ QOS.

Here's a sample voice qos config:

class-map match-any voice-control

match ip dscp af31

match ip dscp cs3

match access-group 101

class-map match-any voice-RTP

match ip dscp ef

match ip rtp 16384 16383

!

!

policy-map Voice-QoS

class voice-RTP

priority [bandwidth-value]

set dscp ef

class voice-control

bandwidth [bandwidth-value]

set dscp af31

class class-default

fair-queue

!For MGCP

access-list 101 permit udp any any range 2427 2428

!For H.323

access-list 101 permit tcp any any range 1718 1720

access-list 101 permit tcp any any eq 1731

!For Skinny (phones registered to CCM)

access-list 101 permit tcp any any eq 2000

!For Sip

access-list 101 permit tcp any any eq 5060

interface x/x

service-policy output Voice-QoS

Note that for some versions of IOS, the command 'match ip dscp' needs to be replaced with 'match dscp'.

What this will do is take any traffic marked as a DSCP of 'ef', or any unmarked RTP traffic, and marks it as RTP traffic and sets the DSCP values accordingly. This traffic is sent to a priority queue. Then, it takes any traffic marked as DSCP of 'af31' or running on port thatis used for control traffic, marks it as control traffic (and sets the DSCP if needed), then puts it in a queue. All other traffic is sent to the fair-queue.

Estimate about 8K of call-control traffic per call. You can find out how much bandwidth you will need for RTP traffic with the voice-call bandwidth calculator found here:

http://tools.cisco.com/Support/VBC/do/CodecCalc1.do

Just be careful when you apply this QoS policy that those 100 and 101 access-lists aren't overwriting any ACLs that you already have configured.

For DSP resources, you will want the DSP calculator:

http://www.cisco.com/cgi-bin/Support/DSP/cisco_prodsel.pl

hth,

nick

118
Views
0
Helpful
1
Replies