Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Silver

QOS issue

i am having trouble with qos at work. We had one site and everything seems to set up properly but still call quality is not good. This is a I site where they take calls and ans . we check the firewall as well and its not striping any incoming and outgoing packets. DSCP ef making we can see on the packet capture. Any idea?

we use auto Qos

config ..

mls qos map policed-dscp 0 10 18 to 8

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos srr-queue input bandwidth 70 30

mls qos srr-queue input threshold 1 80 90

mls qos srr-queue input priority-queue 2 bandwidth 30

mls qos srr-queue input cos-map queue 1 threshold 2 3

mls qos srr-queue input cos-map queue 1 threshold 3 6 7

mls qos srr-queue input cos-map queue 2 threshold 1 4

mls qos srr-queue input dscp-map queue 1 threshold 2 24

mls qos srr-queue input dscp-map queue 1 threshold 3 48 49 50 51 52 53 54 55

mls qos srr-queue input dscp-map queue 1 threshold 3 56 57 58 59 60 61 62 63

mls qos srr-queue input dscp-map queue 2 threshold 3 32 33 40 41 42 43 44 45

mls qos srr-queue input dscp-map queue 2 threshold 3 46 47

mls qos srr-queue output cos-map queue 1 threshold 3 4 5

mls qos srr-queue output cos-map queue 2 threshold 1 2

mls qos srr-queue output cos-map queue 2 threshold 2 3

mls qos srr-queue output cos-map queue 2 threshold 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 0

mls qos srr-queue output cos-map queue 4 threshold 3 1

mls qos srr-queue output dscp-map queue 1 threshold 3 32 33 40 41 42 43 44 45

mls qos srr-queue output dscp-map queue 1 threshold 3 46 47

mls qos srr-queue output dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23

mls qos srr-queue output dscp-map queue 2 threshold 1 26 27 28 29 30 31 34 35

mls qos srr-queue output dscp-map queue 2 threshold 1 36 37 38 39

mls qos srr-queue output dscp-map queue 2 threshold 2 24

mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55

mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63

mls qos srr-queue output dscp-map queue 3 threshold 3 0 1 2 3 4 5 6 7

mls qos srr-queue output dscp-map queue 4 threshold 1 8 9 11 13 15

mls qos srr-queue output dscp-map queue 4 threshold 2 10 12 14

mls qos queue-set output 1 threshold 1 100 100 50 200

mls qos queue-set output 1 threshold 2 125 125 100 400

mls qos queue-set output 1 threshold 3 100 100 100 400

mls qos queue-set output 1 threshold 4 60 150 50 200

mls qos queue-set output 1 buffers 15 25 40 20

mls qos

!

!

auto qos srnd4

!

spanning-tree mode rapid-pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

class-map match-all AUTOQOS_VOIP_DATA_CLASS

match ip dscp ef

class-map match-all AUTOQOS_DEFAULT_CLASS

match access-group name AUTOQOS-ACL-DEFAULT

class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS

match ip dscp cs3

!

!

policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY

class AUTOQOS_VOIP_DATA_CLASS

set dscp ef

police 128000 8000 exceed-action policed-dscp-transmit

class AUTOQOS_VOIP_SIGNAL_CLASS

set dscp cs3

police 32000 8000 exceed-action policed-dscp-transmit

class AUTOQOS_DEFAULT_CLASS

set dscp default

police 10000000 8000 exceed-action policed-dscp-transmit

!

!

interface FastEthernet0/24

description DATA+VOICE

switchport access vlan 101

switchport mode access

switchport voice vlan 201

srr-queue bandwidth share 1 30 35 5

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

snmp trap mac-notification change added

snmp trap mac-notification change removed

no snmp trap link-status

storm-control broadcast level 4.00

storm-control multicast level 10.00

storm-control action shutdown

storm-control action trap

auto qos voip cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable

service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY

!

interface GigabitEthernet0/1

description TO:OO_Router_

switchport trunk allowed vlan 101,201,240,250

switchport mode trunk

bandwidth 2000

load-interval 30

media-type rj45

speed 100

duplex full

srr-queue bandwidth share 1 30 35 5

queue-set 2

priority-queue out

mls qos trust cos

auto qos trust

!

!

ip access-list extended AUTOQOS-ACL-DEFAULT

permit ip any any

1 ACCEPTED SOLUTION

Accepted Solutions
Gold

Re: QOS issue

well, data is not as time critical as voice is, and data should not be in a same Expedit queue as voice.

but if thats you want, thats it.

plz Rate if it helped,

Soroush.

Hope it Helps, Soroush.
11 REPLIES
Gold

Re: QOS issue

Hi there,

what chasis are you using?

It is either mls qos trust cos or service-policy input on a Layer 2 port.

try adding a match for COS 5 under the AUTOQOS_VOIP_DATA_CLASS.

also as for your policy-map is 128K all you want to give to your Voice traffic? how many concurrent voice calls are you handling in your net?

besides: under your service poilcy "AUTOQOS-SRND4-CISCOPHONE-POLICY" you policed the bandwidth and the exceed action is policed-dscp-transmit although you never set any mappings for dscp 46.

plz Rate if it helped.

Soroush.

Hope it Helps, Soroush.
Silver

Re: QOS issue

Hi thanks Soroush,

we using C2960 Software (C2960-LANBASEK9-M), Version 12.2(55)SE3.

didnt get your poit on "It is either mls qos trust cos or service-policy input on a Layer 2 port."

the funny thing is i cant see any traffic under any interface

sh policy-maP int f0/1
FastEthernet0/1

  Service-policy input: AutoQoS-Police-CiscoPhone

    Class-map: AutoQoS-VoIP-RTP-Trust (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip dscp ef (46)

    Class-map: AutoQoS-VoIP-Control-Trust (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip dscp cs3 (24) af31 (26)

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
        0 packets, 0 bytes
        5 minute rate 0 bps

how can i match =match for COS 5 under the AUTOQOS_VOIP_DATA_CLASS.

i am really new to qos and please advise me how i can set mapping for dscp 46 in service poilcy "AUTOQOS-SRND4-CISCOPHONE-POLICY.

thanks

Silver

Re: QOS issue

we had 1 MB link and there are only 3-4 phones

Green

QOS issue

Amrinder

You are hitting a statistics issue with LAN switches.

The stats will not be the same as you see on a router

From this link for example

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_55_se/configuration/guide/swqos.html

show policy-map [policy-map-name [class class-map-name]]

Display QoS policy maps, which define classification criteria for incoming traffic.

Note Do not use the show policy-map interface privileged EXEC command to display classification information for incoming traffic. The control-plane and interface keywords are not supported, and the statistics shown in the display should be ignored.

This is the same on all IOS release up to the latest 15.0.1SE

Try looking at

show mls qos int f0/1 stat

That will show you which DSCP & COS values are ingressing and egressing the interface

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Gold

Re: QOS issue

Hi,

Look, what acampbell wrote was for the Show cmnd output, for voice quality, remove the policy-map binding on Fa0/24. you have loads of extra unnecessary qos config there. save a backup of ur current config an try this one.

add these commands for ingress qos:

mls qos srr-queue input threshold 1 50 80

mls qos srr-queue input buffers 60 40

mls qos srr-queue input bandwidth 50 50

mls qos srr-queue input priority-queue 2 bandwidth 20

By default, DSCP values 0-39 and 48-63 are mapped to queue 1 and threshold 1. DSCP values 40-47 are mapped to queue 2 and threshold 1. By default, CoS values 0-4, 6, and 7 are mapped to queue 1 and threshold 1. CoS value 5 is mapped to queue 2 and threshold 1. LEAVE them as it is.

to keep things simple, queueing and threshold in SRR will drop extra packets, so you dont need to police them with a input policy-map.

Egress Queue:

Again here, you set an Expedite queue and configured a whole bunch of CoS/DSCP values as a part of your expedite queue, you dont have to do this, only Voice and critical packets should be in it, CoS 5 and DSCP 46. remove every other values from queue 1.

ALL of these should be off queue 1.

mls qos srr-queue output dscp-map queue 1 threshold 3 32 33 40 41 42 43 44 45

mls qos srr-queue output dscp-map queue 1 threshold 3 46 47

CONFIG:

! set the output buffer for queue 1 (your Voice) 15%

mls qos queue-set output 1 buffers 15 25 30 30

! ONLY map the CoS 5 and DSCP 46 (ef) to queue 1.

mls qos srr-queue output cos-map queue 1 threshold 2 5

mls qos srr-queue output dscp-map queue 1 threshold 2 46

! set the threshold for Queue 1 (ONLY), leave the others as its default.

mls qos queue-set output 1 threshold 1 100 100 100 400

PS: Disable the auto-qos   for test.

plz Rate if it helped,

Soroush.

Hope it Helps, Soroush.
Silver

Re: QOS issue

we had some citrix users so we Can’t degrade there data priority?

Gold

Re: QOS issue

well, data is not as time critical as voice is, and data should not be in a same Expedit queue as voice.

but if thats you want, thats it.

plz Rate if it helped,

Soroush.

Hope it Helps, Soroush.
Silver

Re: QOS issue

thanks so much for your help.

where do i  use auto qos trust cos and where to use auto qos trust dscp. ?

any idea?

thanks

Gold

Re: QOS issue

well, it depends on your network and how ur equipment work with regards to setting cos or dscp bits on the packets in network. for exmple; if the ip phone use dscp value to prioritize their voice packets, you should trust dscp at the ingress, otherwise use CoS.

finally, CoS is Layer 2 value that's used in trunk encapsulations wherever you have trunk int and DSCP is an IP (L3) parameter.

plz Rate if it helped,

Soroush.

Hope it Helps, Soroush.
New Member

Re: QOS issue

The configuration we normally use on a Voice gateway for QoS.

class-map match-any Voice-RTP

match ip precedence 5

match ip dscp ef

match ip rtp 16384 16383

class-map match-any Voice-Cntl

match ip precedence 3

match ip dscp af31

match access-group name voice-signal

!

ip access-list extended voice-signal

permit tcp any any range 2000 2002

permit udp any any eq 2427

permit tcp any any eq 2428

permit tcp any any eq 1720

permit tcp any any range 11000 11999

!

!

policy-map QoS-LAN-Policy

class Voice-RTP

set dscp ef

priority 500

class Voice-Cntl

set dscp af31

bandwidth 30

class class-default

fair-queue

!

Apply it on Voice VLAN interface or towards the WAN interface if you are configuring it between sites:

!

interface FastEthernet0/1

ip address 10.0.1.1 255.255.255.0

ip rip advertise 2

ip virtual-reassembly

ip tcp adjust-mss 1360

duplex full

speed 100

service-policy output QoS-LAN-Policy

!

OR

!

interface GigabitEthernet0/0.105

description *** Voice VLAN ***

encapsulation dot1Q 105

ip address 10.60.x.x 255.255.255.0

h323-gateway voip bind srcaddr 10.60.x.x

service-policy output QoS-LAN-Policy

Rate this post if helpfull

Green

QOS issue

Hi Omerpal1190.

You are applying a service policy outbound on your interface to the voice gateway router.

Thats OK

But you also need to apply qos for the voip traffic from the gateway on the interface

Depending on the type of switch but lets say a 3750 for example

something like :-

!

interface FastEthernet0/1

desc *** Link to Voice Gateway ***

ip address 10.0.1.1 255.255.255.0

ip rip advertise 2

ip virtual-reassembly

ip tcp adjust-mss 1360

duplex full

speed 100

service-policy output QoS-LAN-Policy

mls qos trust dscp

srr-queue bandwidth share 1 70 25 5

!

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
1400
Views
10
Helpful
11
Replies