Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

QOS on 3560 12.2(35)

Hi,

I'm trying to configure qos for the first time.

My configuration is as follows:

mls qos

access-list 100 permit udp any any range 16384 32767

class-map match-any rtp-stream

match access-group 100

Policy-map voice

class rtp-stream

set dscp ef

interface fa0/41

service-policy input voice

#show mls qos

QoS is enabled

QoS ip packet dscp rewrite is enabled

The issue is that I don't think it's working.When I issue a show access-list 100 there are no hits. Although there are phones on this port, making calls.

Does anyone know where I have gone wrong please?

Sam

1 REPLY
Bronze

Re: QOS on 3560 12.2(35)

Sam,

You need a bit more config. But I do remember that certain IOS images had a bug where the QOS policy worked but the stats did no increment. If you want to prove it works use a sniffer sucha as wireshark, set up a span session and check that you can see the DSCP value

The sort of config you can have as based on the QoS SRND for the 3560 could be

mls qos

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos map policed-dscp 0 24 to 8

class-map VVLAN-VOICE

match access-group name VOICE

class-map VVLAN-SIGNALING

match access-group name SIGNALING

class-map VVLAN-ANY

match access-group name VOICE-ANY

ip access-list extended VOICE

permit udp 10.1.1.0 0.0.0.255 any range 16384 32767

ip access-list extended SIGNALING

permit tcp 10.1.1.0 0.0.0.255 any range 2000 2002

ip access-list extended VOICE-ANY

permit ip 10.1.1.0 0.0.0.255 any

policy-map IPPHONE

class VVLAN-VOICE

set ip dscp 46

police 128000 8000 exceed-action drop

class VVLAN-SIGNALING

set ip dscp 24

police 32000 8000 exceed-action policed-dscp-transmit

class VVLAN-ANY

set ip dscp 0

police 32000 8000 exceed-action policed-dscp-transmit

class class-default

set ip dscp 0

police 5000000 8000 exceed-action policed-dscp-transmit

interface FastEthernet0/1

switchport mode access

switchport access vlan XXX

switchport voice vlan YYY

service-policy input IPPHONE

spanning-tree portfast

Data Traffic will just be treated as normal. The first part of the policy map permits only one voice call and remarks it ef, the second part remark the call control CS3 and the third part reduces any other voice traffic to scavanger value along with the default class which is the data

Hope this helps, will see ig I can find the bug id

Paul

100
Views
0
Helpful
1
Replies
CreatePlease to create content