Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS weird issue! Help

Hello

I'm working in deploying QoS in a branch office

but I'm getting poor voice quality on calls.

here is the configuration of the QoS parameters

*****************************************

class-map match-all VOZ

match dscp ef

class-map match-all VOZ(SIGNAL)

match dscp af31

class-map match-all APLICACION-CRITICA

match access-group name AS400

!

!

policy-map POLITICAS-QoS

class VOZ

priority percent 60

class VOZ(SIGNAL)

bandwidth percent 5

class APLICACION-CRITICA

bandwidth percent 10

class class-default

fair-queue

*****************************************

!

!

!

interface FastEthernet0/0

description LAN

ip address 10.12.1.1 255.255.255.0

speed auto

!

interface Serial0/0

description Link to HQ

bandwidth 128

ip address 192.168.50.42 255.255.255.252

service-policy output POLITICAS-QoS

load-interval 60

compress stac

!

interface BRI1/0

no ip address

shutdown

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0

ip route 16.0.0.0 255.255.255.0 Serial0/0

no ip http server

!

ip access-list extended AS400

permit ip any host 16.0.0.2

Now take a look at the Output of the show policy-map interface serial 0/0

CS-1760-PN#show policy-map interface serial 0/0

Serial0/0

Service-policy output: POLITICAS-QoS

Class-map: VOZ (match-all)

1034703 packets, 66220992 bytes

1 minute offered rate 147000 bps, drop rate 71000 bps

Match: dscp ef

Queueing

Strict Priority

Output Queue: Conversation 40

Bandwidth 60 (%)

Bandwidth 76 (kbps) Burst 1900 (Bytes)

(pkts matched/bytes matched) 1034703/66220992

(total drops/bytes drops) 530418/33946752

Class-map: VOZ(SIGNAL) (match-all)

0 packets, 0 bytes

1 minute offered rate 0 bps, drop rate 0 bps

Match: dscp af31

Queueing

Output Queue: Conversation 41

Bandwidth 5 (%)

Bandwidth 6 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0

Class-map: APLICACION-CRITICA (match-all)

1423 packets, 84273 bytes

1 minute offered rate 0 bps, drop rate 0 bps

Match: access-group name AS400

Queueing

Output Queue: Conversation 42

Bandwidth 10 (%)

Bandwidth 12 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 1423/84273

(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)

38296 packets, 21064743 bytes

1 minute offered rate 47000 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 32

(total queued/total drops/no-buffer drops) 11/130/0

CS-1760-PN#

As you can see there are A LOT of packets being dropped

related to DSCP ef (voice bearer packets) but there are actually 0 (ZERO!!) calls being placed at this time ?

Notice that there is also 0 packets matching DSCP af31 (voice signaling)

Can anyone tell me what might be happeing here ??

Why am I getting so many drops ?

Thanks

10 REPLIES
VIP Super Bronze

Re: QoS weird issue! Help

Do you have Qos enabled on your switch.

Also, you should add this to your VOZ(signalling)

class-map match-any VOZ(SIGNAL)

match cs3

match dscp af31

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Re: QoS weird issue! Help

This bit of configuration allows the router bandwidth scheduler to enforce a minimum BW guarantee out of an interface capacity and to enforce a queue drop profile to any of the classes previously defined. This builds a certain “behaviour” for the router.

Also you should make sure it is enabled.

!

interface input_interface_name

mls qos trust dscp

!

!

The scheduler is attached to the output port and is active for the traffic leaving the router (output) by the mean of a template called “service-policy” containing the already defined “policy map” template.

!

interface output_interface_name

service-policy output policy_map_name

mls qos trust dscp

!

The command lines “mls qos” deserve a paragraph on its own.

The command line “mls qos” in the global configuration mode is needed to enable QoS on the supervisor engine while “mls qos trust dscp” issued in the input and output interfaces is there to avoid cards to reset the dscp code of packets entering or leaving the interfaces.

Re: QoS weird issue! Help

Hi ROYCE

i agrre with i think he has a missing trustbounday for the DSCP

however

u have mentioned that mls qos trust dscp should be entered on the Router interfaces

while it should be enabled on the switch side

especially on uplink ports and port going tward the router interface !!

and the router will use this DSCP marking in its matching cratiria

and about reseting the marking this happen if the marking is on L2 COS and gose to a L3 device like layer three switch or router in this case the packet will loss its marking unless u trust DSCP marking on switch uplinks and the switch will use default COS to DSCP maping so this default maping should be altered aswell as bellow....

Glenn PLEASE, MAKE SURE UHAVE THIS CONFIG ON UR SWITCH:

When configuring an access-switch to trust/conditionally-trust CoS, then the default mapping for CoS 5

should be adjusted to point to DSCP EF (46), instead of DSCP CS5 (40). This modification is shown

below:

(config)#mls qos map cos-dscp 0 8 16 24 32 46 48 56

! Maps CoS 5 to EF

for aditional config (optional) u can remap DSCP marking to its COS marking in the returne path linke this example

ip cef ! IP CEF is Required for Packet Marking

policy-map BRANCH-LAN-EDGE-OUT ! Enables default DSCP-to-CoS Mapping

class class-default

set cos dscp

interface [interface No. connected to LAN switch]

service-policy output BRANCH-LAN-EDGE-OUT

good luck

please, if helpful rate

New Member

Re: QoS weird issue! Help

My friend!

It worked quite well!!

Thx a lot...

Re: QoS weird issue! Help

hi Glenn

i am glad its working now

but can u let us know what did u add exactly and get work

is it the trust interface on the switch and cos maping only ?

thank you

New Member

Re: QoS weird issue! Help

Are you running muticast routing and multicast MoH? That could be 2 MoH streams.

add match dscp cs3 to VOZ(SIGNAL) and see if you get some hits

Good Luck!

New Member

Re: QoS weird issue! Help

Hello friend!

I added that sentence amd I'm getting lots of hits... But why exactly is this happening ?

Thx!

New Member

Re: QoS weird issue! Help

The first thing I will try is to setup a SPAN on your switch to sniff what exactly traffic is marked as dscp ef. Or you can enable netflow on the router to look at the traffic.

New Member

Re: QoS weird issue! Help

Hello Richard

Unfortunaly I do not know how to setup a sniffer on a switch or how to enable netflow on the router(never done it before)

Do you have examples available ?

Thanks

New Member

Re: QoS weird issue! Help

To enable netflow

interface FastEthernet0/0

ip flow ingress

And then you can use 'show ip cach verbose flow' to check the netflow static.

To using SPAN, here is the link http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a008015c612.shtml

170
Views
15
Helpful
10
Replies
CreatePlease to create content