Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

QoS witch a "Non-Cisco-IP-Phone" on a TRUNK-Port

we have "Non-Cisco-IP-Phones" with Cat3560+PoE and TRUNK-Ports with 2 Vlans(one DATAvlan,one VOICEvlan)

how is it possible to enable QoS (1st step: Classification and Marking) on this TRUNK-Ports with "service-policy input" (with class-map,policy-map)

it seem so, as it doesn't work on a TRUNK ?

there are no matches in ACL (sh access-lists) and POLICY-MAP (sh policy-map interface fastEthernet 0/1)

....any idea....

regards,

Ralf

4 REPLIES
Anonymous
N/A

Re: QoS witch a "Non-Cisco-IP-Phone" on a TRUNK-Port

Here is the link to the full configuration document:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3560/12225see/scg/swqos.htm#wp1231446

This command will tell the switch to trust whatever QoS values it recieves on the port and map it to the correct queue.

New Member

Re: QoS witch a "Non-Cisco-IP-Phone" on a TRUNK-Port

mls qos map cos-dscp 0 8 16 26 32 46 48 56

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 1 2 4

mls qos srr-queue output cos-map queue 2 threshold 2 3

mls qos srr-queue output cos-map queue 2 threshold 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 0

mls qos srr-queue output cos-map queue 4 threshold 3 1

mls qos srr-queue output dscp-map queue 1 threshold 3 46

mls qos srr-queue output dscp-map queue 2 threshold 1 16 18 20 22 25 32 34 36

mls qos srr-queue output dscp-map queue 2 threshold 1 38

mls qos srr-queue output dscp-map queue 2 threshold 2 24 26

mls qos srr-queue output dscp-map queue 2 threshold 3 48 56

mls qos srr-queue output dscp-map queue 3 threshold 3 0

mls qos srr-queue output dscp-map queue 4 threshold 1 8

mls qos srr-queue output dscp-map queue 4 threshold 3 10 12 14

mls qos queue-set output 1 threshold 2 70 80 100 100

mls qos queue-set output 1 threshold 4 40 100 100 100

mls qos

!

class-map match-all voip-class

match access-group name voip-ports

!

!

policy-map voip-policy

class voip-class

set dscp ef

!

ip access-list extended voip-ports

permit udp any range 6004 7039 any

permit udp any any eq 5667

permit udp any any eq 5006

permit tcp any any eq 5666

permit udp any any range 6004 7039

permit udp any eq 5667 any

permit tcp any eq 5666 any

permit udp any eq 5006 any

!

end

edit your ports, im sure my ports wont match up with yours.

on your interfaces, you have to enable the priority queueing and bandwidth percentage:

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

service-policy input voice

srr-queue bandwidth share 1 70 25 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

queues 2,3,4 get 70% 25% and 5% respectively.

queue 1 gets 33% of all available bandwidth.

New Member

Re: QoS witch a "Non-Cisco-IP-Phone" on a TRUNK-Port

Allen,

attached is my topology. The IP phones are placed on the access switches.

All access switches are 2960 and the L3 is 3750.

Where should i mark the traffic, on the 2960 or the 3560 and do i need to apply the service policy input to all the ports?

New Member

Re: QoS witch a "Non-Cisco-IP-Phone" on a TRUNK-Port

Attached diagram

323
Views
0
Helpful
4
Replies
CreatePlease to create content