Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QSIG issue - no audio

Hi

We have a QSIG link between a 3845 and Avaya PBX.  When we try calling across it (IP to Analog), the phone rings but there is no audio stream when going off hook.

Any suggestions on what could cause this type of behaviour?

Thanks

config

controller E1 0/2/0

framing NO-CRC4

pri-group timeslots 1-31

description E1 controller card for QSIG

interface Serial0/2/0:15

description QSIG interface towards Avaya PBX

no ip address

encapsulation hdlc

isdn switch-type primary-qsig

isdn incoming-voice voice

isdn contiguous-bchan

no cdp enable

dial-peer voice 9000 pots

description <=== QSIG trunk test  ===>

destination-pattern 777....

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

fax rate disable

port 0/2/0:15

forward-digits 4

On CUCM there is a route pattern 777xxxx towards the gateway (H323) with no discard digits

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Super Bronze

QSIG issue - no audio

I don't recall having to set 'isdn contiguous-bchan' before.

From the docs it looks like it might adjust the channel usage so the first call goes out 30 rather than 31? I'm not sure to be honest, but since it's working one direction and not the other (and I presume you have verified the call lands on a phone with someone answering it at the other end) I'd try it without - it might require a similar setting on the far end.

Try taking that out and shut/no shutting it, or try setting the channel selection order to ascending.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
9 REPLIES
Bronze

QSIG issue - no audio

I do not know what the Problem ist, but i can suggest you a document from Cisco which handles an similar configuration.

http://www.cisco.com/en/US/solutions/collateral/ns340/ns414/ns728/ns829/467019.pdf

Blue

QSIG issue - no audio

HI

If you do not find any solution. Consider change gateway to MGCp and configured as shown below.

http://www.cisco.com/en/US/solutions/collateral/ns340/ns414/ns728/ns784/537421.pdf

Regards

Ronak Patel

Rate helpful posts.

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
New Member

QSIG issue - no audio

I know but we can not change it to MGCP

Super Bronze

QSIG issue - no audio

Hi

1) Does it work when calling in the other direction?

2) When you make the call from the IP phone, if you view the call stats (e.g. press ? quickly twice when on the call on a 794x/6x handset)  do you see the 'rx' packets increasing?


Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

QSIG issue - no audio

Hi Aaron

yes, for some strange reason it started to work from Avaya towards Cisco 5I can confirm nothing changed on the Cisco end)

in both directions we see RTP stream on the IP phone and they increment

Koen

Super Bronze

QSIG issue - no audio

I don't recall having to set 'isdn contiguous-bchan' before.

From the docs it looks like it might adjust the channel usage so the first call goes out 30 rather than 31? I'm not sure to be honest, but since it's working one direction and not the other (and I presume you have verified the call lands on a phone with someone answering it at the other end) I'd try it without - it might require a similar setting on the far end.

Try taking that out and shut/no shutting it, or try setting the channel selection order to ascending.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

QSIG issue - no audio

Thanks Aaron

I will change that line and make a test call, I have a TAC case open for it as well so in a way I want to make as less changes to the config as possible :-)

Koen

New Member

QSIG issue - no audio

Hi Aaron

that worked removed it and I could hear the other party

Thank you

Koen

Super Bronze

QSIG issue - no audio

Great news.

Thanks

Aaron Harrison

Principal Engineer at Logicalis UK

Please rate helpful posts...

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
1016
Views
10
Helpful
9
Replies
CreatePlease to create content