Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

QSIG PRI configuration

Hi folks--i'm working on deploying a CME system that's tied back across a high-speed MAN link to a 2901 that's connected to an Avaya PBX.  I don't have control of the Avaya (nor would i know what to do with it...).  The PRI on the 2901 is up (multiple_frame_established).  But, when i try to make a call from the CME system, i see 'identified channel does not exist' in the q931 debug.  I just want to make sure my bases are covered on the Cisco side so that I can start getting after the person that handles the Avaya system.

Has anyone seen this before and is there something specific i need to look for on the 2901?  The switch-type is primary-qsig, the serial interface is setup to emulate 'user'...the channels show that they're up when i do a show voice port summary.

Appreciate any help.

SJ

Everyone's tags (6)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Silver

QSIG PRI configuration

Under the Serial interface for the PRI enter:

interface Serial0/0/0:23

isdn protocol-emulate Network

HTH,

Chris

Super Bronze

Re: QSIG PRI configuration

Hi

If you are 'network' side (which I guess is what he means by 'PBX' - though a PBX would typically be user side, and the SP network) then you should probably set 'clock source internal' on the E1 controller.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
12 REPLIES
Green

QSIG PRI configuration

Scott

Can you post the 2901 config  and the debug q931 of the failed call

Regards

Alex

Regards, Alex. Please rate useful posts.

Re: QSIG PRI configuration

Absolutely! Here’s the debug:

debug isdn q931 is ON.

2901-VGW#

Mar 15 19:53:19.810: ISDN Se0/0/0:23 Q931: Applying typeplan for sw-type 0x16 is 0x0 0x0, Calling num 1402

Mar 15 19:53:19.810: ISDN Se0/0/0:23 Q931: Sending SETUP callref = 0x0083 callID = 0x8002 switch = primary-qsig interface = User

Mar 15 19:53:19.810: ISDN Se0/0/0:23 Q931: TX -> SETUP pd = 8 callref = 0x0083

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA18397

Preferred, Channel 23

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x80, '1402'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '7000'

Plan:Unknown, Type:Unknown

Mar 15 19:53:19.846: ISDN Se0/0/0:23 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x8083

Cause i = 0x81D2 - Identified channel does not existConnection closed by foreign host.

Config now:

hostname 2901-VGW

!

boot-start-marker

boot-end-marker

!

!

card type t1 0 0

logging buffered 51200 warnings

!

no aaa new-model

!

network-clock-participate wic 0

network-clock-select 1 T1 0/0/0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

!

ip domain name yourdomain.com

!

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-qsig

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-124576944

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-124576944

revocation-check none

rsakeypair TP-self-signed-124576944

!

!

crypto pki certificate chain TP-self-signed-124576944

certificate self-signed 01

30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274

69666963 6174652D 31323435 37363934 34301E17 0D313131 31303931 37303231

325A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F

532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3132 34353736

39343430 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100

9CB270EC 0CACBA72 BE013F76 FB887D84 DF234550 DF20BC02 CC2C4802 23D09EB9

7A0DF63D FD814AA7 26753457 E3C1AB60 A2808D55 38577259 68C5B775 8107E93A

584C1CC9 6E039446 0310BBEB F9A30F35 61290B03 E8799F8F 071242C6 D23D0443

932345DF CE0C9D3C 173E7A6A E71D9BA9 32E37336 92E6E46A E3250D83 22AC940B

02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D

23041830 16801440 99B58E45 F6B38DA7 AD87D306 C080B392 48FF4330 1D060355

1D0E0416 04144099 B58E45F6 B38DA7AD 87D306C0 80B39248 FF43300D 06092A86

4886F70D 01010505 00038181 0046B353 6328B81D CA2EDC10 B9F05160 5B700AFF

31264829 D1356EE9 69D4F656 5A72EE80 7ADDB34C EE9AC755 F9521219 FDE46B2F

04BCDD7C 8B77E59F C8C666DA A824C128 8692CBC3 342F20EC 6A5B44A1 92E28644

E0C0F4E3 ED669EB6 2A61AC79 B7287169 33989415 9C44F783 FD0B5A4C 30C0367F

1853531A 3BEF4293 DC29B2C9 98

quit

voice-card 0

!

!

voice call send-alert

voice rtp send-recv

!

voice service voip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

h323

!

!

!

!

!

license udi pid CISCO2901/K9 sn FTX154681YM

hw-module pvdm 0/0

!

!

!

!

!

redundancy

!

!

!

!

controller T1 0/0/0

cablelength long 0db

pri-group timeslots 1-24

!

!

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 10.18.200.20 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.18.200.20

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-qsig

isdn overlap-receiving

isdn incoming-voice voice

isdn negotiate-bchan

no cdp enable

!

ip default-gateway 10.18.200.1

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 0.0.0.0 0.0.0.0 10.18.200.1

!

!

!

!

!

!

!

control-plane

!

!

voice-port 0/0/0:23

!

!

!

mgcp profile default

!

!

dial-peer voice 3000 pots

destination-pattern ...

incoming called-number 3...

no digit-strip

port 0/0/0:23

!

dial-peer voice 1400 voip

destination-pattern 14..

session target ipv4:10.18.226.20

incoming called-number 14..

dtmf-relay h245-alphanumeric h245-signal

codec g711ulaw

!

dial-peer voice 1500 pots

destination-pattern 1[5-7]..

no digit-strip

port 0/0/0:23

!

!

!

!

gatekeeper

shutdown

!

!

!

line con 0

login local

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

privilege level 15

login local

transport input telnet ssh

line vty 5 15

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

end

Green

QSIG PRI configuration

Scott

Can you try removing the isdn negotiate-bchan from the d channel config

I dont think the other end likes it

!

!

interface Serial0/0/0:23

no isdn negotiate-bchan

!

Let us know if that helps

Regards

Alex

Regards, Alex. Please rate useful posts.

Re: QSIG PRI configuration

Just got this info from the customer. This is from the PBX person:

Tell Cisco Installer to use ISDN-PRI, Connect Mode: PBX on their side and I will set main hospital as USER.

Not sure what that means though…have never seen those options when I configure a PRI…☺

Hall of Fame Super Silver

QSIG PRI configuration

Under the Serial interface for the PRI enter:

interface Serial0/0/0:23

isdn protocol-emulate Network

HTH,

Chris

Re: QSIG PRI configuration

Appreciate the info Chris. Tried it and it’s stuck bouncing between awaiting_establishment and TEI_assigned. Tried changing the switch-type also to primary-ni, no luck. Also tried with and without negotiate-bchan, same result…

Any other thoughts?

SJ

Super Bronze

Re: QSIG PRI configuration

Hi

If you are 'network' side (which I guess is what he means by 'PBX' - though a PBX would typically be user side, and the SP network) then you should probably set 'clock source internal' on the E1 controller.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Re: QSIG PRI configuration

Thank you both Aaron and Chris--as it turns out, it was a combination of things.  I was supposed to emulate the network, and also, even though i thought i had set the clock to internal, i happened to have term mon turned on and noticed a message when i put the command in a second time that i needed to remove the network-clock-select command.  Also, had to change the switch-type to primary-ni.  After making the changes and bouncing the controller, it came up and i was able to call across to the PBX. 

Now, the challenge is people can't call back into my CME system...thinking it's call routing on the PBX, which (thankfully) isn't mine to control...

Thank you all for your help

SJ

Hall of Fame Super Gold

Re: QSIG PRI configuration

Callback is a PBX-specific QSIQ feature. CME won't support it natively.

Re: QSIG PRI configuration

Understood. Fortunately, this is a short-term solution as the client is looking for a full UC system in the future. Once that’s done, this will be converted into an SRST location, so won’t be an issue in the future…

Appreciate the info.

SJ

Hall of Fame Super Gold

Re: QSIG PRI configuration

Test and demo CME 9.0 before.

It is a very feature rich system, easier and more flexible than CUCM.

Re: QSIG PRI configuration

Cool—I’ll definitely give it a shot…it’s not a fit for this particular situation (large hospital, satellite offices that will tie-back via dedicated fiber; hospital itself has over 2000 phones). I’ve got a couple situations though where they’re right on that border of needing CUCM for what they want to do, so CME 9 might be a good fit.

Thanks for the info!

SJ

6010
Views
5
Helpful
12
Replies