Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

rate limiting and QoS

Hello,

I would like to ask the pros of QoS,if  Reducing the bandwidth and simultaneously applying QoS (QoS that prioritizes VoIP traffic) doesn't limit the effectiveness of QoS!

what I mean is that, since  the rate limit is applied first to all traffic (so there will surely have been Dropped packets, and  possibly RTP packets). so even if QoS which prioritizes VoIP traffic is configured I will have  bad communications?

those who have already tested, your answers will help me.

thank you.

4 REPLIES

rate limiting and QoS

Hi,

it depends.

If you police all traffic on the ingress, then the policer drops packets/frames - so there's no chance to recover them anywhere, since they're dropped.

What you might want to do: classify voice (signalling and media) on the ingress, police it, and police class default traffic as well. Then implement priority queuing for voice, on the ingress and the egress, so you have a wide path for voice.

What kind of a network equipment are we talking about here?

G.

New Member

rate limiting and QoS

hi, 

thanks for your answer, I am using a cisco 3750-12s switch.

what do you thin about this?

CAT3750(config)#mls qos

CAT3750(config)#mls qos map policed-dscp 8 16 24 32 40 56 to 0

CAT3750(config)#access-list 101 permit ip any any dscp ef

CAT3750(config)#access-list 102 permit ip any any dscp default

CAT3750(config)#class-map voip

CAT37500(config-cmap)#  match access-group 101

CAT3750(config)#policy-map test

CAT3750(config-pmap)#class c-voip

CAT3750(config-pmap-c)# police 2000000 20000 exceed-action drop

CAT3750(config)#class c-default

CAT37500(config-cmap)#  match access-group 102

CAT3750(config)#policy-map test

CAT3750(config)#class c-default

CAT3750(config-pmap-c)# police 200000 20000 exceed-action drop

and I limit the egress bandwidth of the two ports:

speed 10

srr-queue bandwidth limit 25


Re: rate limiting and QoS

Hi,

well, actually, if you are dropping traffic anyway, you can omit the mls qos map policed-dscp map altoghether.

I would do this:

! access list matching voice bearer (ef) and signalling (af31, cs3):

access-list 101 permit tcp any any dscp ef

access-list 101 permit tcp any any dscp af31

access-list 101 permit tcp any any dscp cs3

!

! class map matching the above access list:

!

class-map match-all VOIP

  match access-group 101

!

! and the policy map, policing voice bearer and signalling

! at 200kbps and default at 50kbps

!

policy-map VOIP

class VOIP

  police 200000 8000 exceed-action drop

class class-default

  police 50000000 8000 exceed-action drop

!

! now guaranteeing priority treatment for voice:

! remember, signaling (af31 ~ 24 and cs3 ~ 26) already in Q3T1

!

mls qos srr-queue output dscp-map queue 3 threshold 1 46

! sending everything else to Q4T1 (by default, DSCP 16-31 in Q3T1):

mls qos srr-queue output dscp-map queue 4 threshold 1 16 17 18 19 20 21 22 23

mls qos srr-queue output dscp-map queue 4 threshold 1 25 27 28 29 30 31

mls qos

!

! applying the service policy on the ingress

! also, assigning 55% for the Q3 on the egress:

interface FastEthernet0/3

srr-queue bandwidth share 15 15 55 15

service-policy input VOIP

This way you can police both voip (bearer and signalling) and also everything else on the ingress.

On the egress, using the srr-q bandw share you can guarantee priority treatment for voice.

G.

New Member

rate limiting and QoS

thank you very much for your help, I test it and see if it works

174
Views
0
Helpful
4
Replies